[e10s] Investigate additional perf histograms

RESOLVED FIXED

Status

()

Toolkit
Telemetry
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jimm, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox43 affected)

Details

(URL)

(Reporter)

Description

2 years ago
From Vlad's perf doc, investigate:

Finer-grained startup metrics, feature performance metrics, new tab-switch histogram, etc etc. There are hundreds of performance histograms in Histograms.json. 

Using the following methodology:

Just doing a diff of all histogram distributions for e10s vs non-e10s population will almost certainly generate some interesting insights. We do something like this in our "Medusa" Telemetry detection-regression system. I'm not saying any of the regressions found should be a release-blocker, but we do need to do the diff to see if we overlooked anything big. I could go through the 1000+ histograms in Histograms.json to see if there are any that I forgot that measure important aspects of perf/correctness/stability, but doing a giant diff seems like a better use of our time.
tracking-e10s: --- → +
Blocks: 1222849
Assignee: nobody → rvitillo
Duplicate of this bug: 1222976
Depends on: 1225093
Depends on: 1225096
Depends on: 1225097
Depends on: 1225100
Depends on: 1225101
Depends on: 1225104
Depends on: 1225106
Depends on: 1226564
Assignee: rvitillo → nobody
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.