Closed Bug 119881 Opened 21 years ago Closed 19 years ago

Mac: Hebrew page titles / tab titles / bookmarks in bookmarks manager appear as question marks

Categories

(Core :: Layout: Text and Fonts, defect)

PowerPC
Mac System 9.x
defect
Not set
major

Tracking

()

RESOLVED WONTFIX

People

(Reporter: xslf, Assigned: mkaply)

References

()

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.7+) Gecko/20020111
BuildID:    20022011108

on Mac, Hebrew page titles appear as question mark. the same page titles appear
OK in the bookmarks list and in the personal toolbar folder

Reproducible: Always
Steps to Reproduce:
go to a web site which has Hebrew in the title. another example:
http://www.dotkof.org

Actual Results:  the page title has question marks instead of hebrew characxters

Expected Results:  Hebrew should display correctly
Dupe of 36689?
I don't think so, since the problem is still there even when I set my system
script to Hebrew. It is intresting to note that althugh you can see this bug in
the title bar, mozilla tab titles are ok. In the mail Hebrew messge titles
appear reversed, but not as question marks. Same with Hebrew folder names.

*** This bug has been marked as a duplicate of 9449 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
to prevent comfusion: hebrew tab titles no longer display properly with mozilla
Reopening. Bug 9449's fix has been declared Windows-only.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Hebrew page titles appear as question marks → Mac: Hebrew page titles appear as question marks
Bug 36689 was marked as won't fix: will this bug ever get fixed? it is pretty
ugly :-(
this is seen in the bookmark manager as well- making it almost impossible to
mmanage them.
Severity: normal → major
Summary: Mac: Hebrew page titles appear as question marks → Mac: Hebrew page titles / tab titles / bookmarks in bookmarks manager appear as question marks
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
Since Mozilla is no longer supported on Mac OS X pre-OS X I am attepting to test
the remaining open bugs (all 175 of them).

The test client will be the Mozilla (SeaMonkeys) 1.6 running Mac OS X 10.3.2

Result/Status: Mix results..
http://www.haayal.co.il/story.php3?id=838&NewOnly=1&LastView=2002-01-14%2012%3A04%3A31#NewReply

does show hebrew, but title does start with a question mark, should it?

http://www.dotkof.org

shows some jiberish

http://www.info.org.il/rss/ does appear to render correctly under OS X

Suggest to dup 36689
<Result/Status: Mix results..
http://www.haayal.co.il/story.php3?id=838&NewOnly=1&LastView=2002-01-14%2012%3A04%3A31#NewReply

does show hebrew, but title does start with a question mark, should it?>

The title has a question mark in it, but it should appear at the end, not at the
begining (directionality propblem)

>Suggest to dup 36689

Well, this happens on os9 even when the leading system script is set to Hebrew,
so it is not really a dup (althugh they are probably related).
Shoshannah, Mac OS 8/9 is dead as far as Mozilla is concerned. Nobody working on
Mozilla will work on Mac OS 8/9 bugs anymore and fixes will no longer be checked
into the cvs repository.

This is WONTFIX.
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → WONTFIX
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.