The default bug view has changed. See this FAQ.

Mac window title doesn't display characters which cannot be encoded as system script

VERIFIED WONTFIX

Status

()

Core
Internationalization
P3
normal
VERIFIED WONTFIX
17 years ago
15 years ago

People

(Reporter: Charles Wang, Assigned: Frank Tang)

Tracking

({helpwanted, intl, testcase})

Trunk
Future
PowerPC
Mac System 9.x
helpwanted, intl, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build:2000-04-20-10-M16 comm build:

Mac Mail compose window title doesn't display Japanese characters.
(Reporter)

Updated

17 years ago
QA Contact: momoi → cwang

Comment 1

17 years ago
Changed the title since this is a generic window title problem.
Reassign to trudelle.
Assignee: nhotta → trudelle
Summary: Mac Mail compose window title doesn't display Japanese characters. → Mac window title doesn't display Japanese characters when using US system.

Updated

17 years ago
Keywords: nsbeta2

Comment 2

17 years ago
reassigning to danm as p3 for M17. couldn't find dup.
Assignee: trudelle → danm
Target Milestone: --- → M17

Comment 3

17 years ago
[nsbeta2-]
Whiteboard: [nsbeta2-]

Updated

17 years ago
Target Milestone: M17 → M20

Updated

17 years ago
QA Contact: cwang → teruko

Comment 4

17 years ago
  Ugh. We're talking WDEF here, aren't we? Handily, I know a group that wants to 
be able to skin the entire window, including OS window borders, that's working on 
a WDEF. As icky as the idea of putting a WDEF into Mozilla is, we can probably 
piggyback off their work once they're ready for it. That's gonna be "later," 
though.
Target Milestone: M20 → Future

Comment 5

17 years ago
Changed QA contact to ylong@netscape.com.
OS: All
QA Contact: teruko → ylong

Updated

17 years ago
Keywords: intl, nsbeta1

Comment 6

16 years ago
This is Mail&News.  Changed QA contact to ji@netscape.com.
QA Contact: ylong → ji

Comment 7

16 years ago
This is *not* just Mail & News. It counts for all windows in Mozilla. So this
should be changed!

And it is not just japanese. On norwegian MacOS 9.1 it is only possible to have
ISO-8859-1 in title window. If you test e.g. a russian page (e.g. <URL
http://www.mn.ru/2001/21/23.html> ), no window title will be displayed at all.
(The title will still be displayed in the Bookmarks file.)

Comment 8

16 years ago
Yes, this is not only happening on Mail/News. It's a browser generic problem.
Changed the component to browser. QA contact to andreasb.
Product: MailNews → Browser
QA Contact: ji → andreasb

Updated

16 years ago
Summary: Mac window title doesn't display Japanese characters when using US system. → Mac window title doesn't display non-ASCII characters when using US system.

Comment 9

16 years ago
hmmmmm . . . how bad is this? should it be considered for M0.9.2?

Comment 10

16 years ago
I think it depends on how many users are using US Mac users + language kits
For them, it's a very annoying problem, especially when the user has multiple 
windows open.

Comment 11

16 years ago
In my opinion users of western MacOS-es (not only US!) which are using
non-MacRoman scripts are very common. The language kits are included with the OS
since OS 8.5. It is just as important for mac users as anyone else to have this
working. And perhaps even *more* important because the MacOS has not been
translated to many languages the latest years. (E.g. OS X is not in cyrillic.)

Comment 12

16 years ago
Cleaning up Status Whiteboard and Keywrods. Marking as nsCatFood.

Dan - Is this doable for M0.9.2?
Keywords: nsbeta2 → nsCatFood
Whiteboard: [nsbeta2-]

Comment 13

16 years ago
No, dude. I spend most of my time fighting crash bugs. Realistically, I don't 
know that I'll *ever* be able to address this bug (and related PC version bug 
9449 -- yes that's four digits). Such attempts have been known to fail in the 
past, but I'll try reassigning it to internationalization.
Assignee: danm → ftang
Hardware: PC → Macintosh

Comment 14

16 years ago
*** Bug 83685 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

16 years ago
Change the subject from "Mac window title doesn't display non-ASCII characters 
when using US system." to "Mac window title doesn't display characters which 
cannot be encoded as system script"
Summary: Mac window title doesn't display non-ASCII characters when using US system. → Mac window title doesn't display characters which cannot be encoded as system script

Comment 16

16 years ago
Changing qa contact to ylong.
QA Contact: andreasb → ylong
(Assignee)

Comment 17

16 years ago
mark it as assigned
Status: NEW → ASSIGNED

Comment 18

16 years ago
Created attachment 44349 [details]
Basic HTML document with Shift JIS-encoded TITLE and BODY text.

Comment 19

16 years ago
Interestingly, bug 92503 refers to implementing this capability under Mac OS X,
and apparently there is a patch in hand on it in need of some testing.

Updated

16 years ago
Keywords: testcase

Comment 20

16 years ago
Reference also bug 74753 for this bug under Linux.

Updated

16 years ago
Blocks: 104166

Comment 21

15 years ago
This seems to be working for MacOS X.
http://www.yomiuri.co.jp/ shows Japanese title even when my system language is
not set to Japanse.

Comment 22

15 years ago
*** Bug 141707 has been marked as a duplicate of this bug. ***
Blocks: 136556

Comment 23

15 years ago
nhotta, please see my Comment #19.

Comment 24

15 years ago
*** Bug 146083 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 25

15 years ago
mark this bug as fixed
If you can still reproduce this bug on Mac OS 8/9 but not mac os x, please
reopen it and change platform to mac os9.x
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 26

15 years ago
Reproduced in build 2002081003, Mac OS 9.2.2, with attachment 44349 [details]. Reopening.
Status: RESOLVED → REOPENED
OS: All → Mac System 9.x
Resolution: FIXED → ---

Comment 27

15 years ago
It happens in Lycos Mail too, where accents are loaded as "?". Contacted them:
Hello,

Thank you for contacting Lycos Customer Support.

This sounds like a Netscape issue.  You may want to consult  technical 
support at Netscape to resolve the character encoding problem.

If there is anything else that I can do for you, please let me know.

Sincerely,

Veronica
Lycos Product Support Specialist
http://lycos.com



Original Message Follows:
-------------------------

Name: Michele Bugliaro
MemberName: michelebugliaro
Contact Email Address: michelebugliaro@lycos.com
Service: Lycos Mail
Browser & Platform = Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2a) 
Gecko/20020910
IP information = 62.202.95.69
Date/Time: 9/15/2002 11:29
Comments: 

In Mozilla (it's like Netscape 6), character encoding has a problem: I 
read/write some messages in Italian, but accents are not displayed 
correctly. I've to switch manually. The pop up address book has the same
problem...it identifies itself as US-ASCII, in stead of Western 
ISO-8859-1. 
Can you fix it?
(Assignee)

Comment 28

15 years ago
Mac OS 9 only bug Mark it as WONTFIX now. I won't work on MacOS 9- issue from
now on. Anyone who want to take the bug is welcome to reopen if they want to
assign to themself. 
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WONTFIX

Updated

15 years ago
Keywords: helpwanted

Comment 29

15 years ago
Mark as verified as wontfix per comment above.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.