Closed Bug 119882 Opened 19 years ago Closed 16 years ago

Hebrew text appears outside table border

Categories

(Core :: Layout: Text and Fonts, defect)

PowerPC
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 174470

People

(Reporter: xslf, Assigned: smontagu)

References

(Blocks 1 open bug, )

Details

(Keywords: testcase)

Attachments

(3 files)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.7+) Gecko/20020111
BuildID:    200220011108

in this page, when viewed in logical version, the text is inside colored table
cells. notice how the Hebrew text appears incorrectly to the right of the color-
outside the cell border

Reproducible: Always
Steps to Reproduce:
go to the page, and look at the Hebrew text

Actual Results:  text is to the right of the cell

Expected Results:  text should be within the cell
Mac-specific Bidi bug -> ftang
Assignee: mkaply → ftang
screen shot please. 
see for exmaple the screen shot at:
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=65868
I am attaching another exmple from
http://www.bernisoft.co.il/bernisite/course_online.html Here the problem looks
more isolated and less general.
see exactly the same problem on my English Win XP. I think this is a 
general Bidi problem on non Bidi platform. give it back to smontagu.
Assignee: ftang → smontagu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
Blocks: 137995
Yet another example:
http://anavy.net/frad.php
The funny things is, that I seem to remember this stie looking ok once in 
mozilla...
Attaching a screen shot
Attached image The site on mozilla OSX
Severity: normal → major
OS: Mac System 9.x → All
related to bug 172569?
Similar cases with LTR character encoding (English even!) using Mozilla 1.3.1
release:

http://zetafleet.com/dev/rmt/docs.php (Eng)
 > Find "// typo in docs?"

http://y-hosting.net (Eng/Jap)
 > Resize window until content bleeds out of the "Your location" cell

Both these pages are W3C validated XHTML.
Here's another example on my site - this is a static page that I don't plan to
change in the near future:

http://www.hug-elad.org/plan_info.html
The example from http://frad.anavy.net/ is NOT valid XHTML

The text in the right side seems fine now. The text in the left is rendered wrong, but its much 
worse in Safari. So it might be the page design.

The first two attachments are acually caused by the RTL list bug that is FIXED now.

http://www.hug-elad.org/plan_info.html is does show a list out of its table, but this page is also 
not valid html.

Unless someone come with a validated testcase here I vote for ignoring this bug.
>The example from http://frad.anavy.net/ is NOT valid XHTML

It fails mainly for unescaped & signs in the URL, which have nothing to do with
how Mozilla renders the page.

>http://www.hug-elad.org/plan_info.html is does show a list out of its table,
but >this page is also not valid html.

Again, it fails for unescaped & in URLs- Nothing to do with the Mozilla rendering.

>Unless someone come with a validated testcase here I vote for ignoring this bug.

I think you are beeing a bit to harsh here. The validator  and the W3C standards
are tools, not God. If we follow your request, we might as well get rid of the
quirks mode in Mozilla.
I might have said something diffrent if it looked liked the pages fail to
validate with something that might be related to what Mozilla is haveing
problems with, but that is not the case here.
Anyone care to create a reduced testcase? not only will it help the assignee of
this bug, it will also negate the possibility of invalidated code causing this
behavior.

Prog.
Most pages given as examples here no longer exist, or have changed. I created
this tescase based on the page provided in comment #11 (the only one which
still exists).
What happens here is that "border-collapse: collapse;" somehow causes the cell
widths to be assigned in the wrong direction: The first (right-side) cell,
which contains the short text, is wide enough for the text contained in the
second cell, and vice versa.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0

Also seeing this on a trunk build (20041029) - the spacing is a bit different,
but the basic problem remains.
Keywords: testcase
Attachment #166558 - Attachment description: tescase (based on comment #11) → testcase (based on comment #11)
In a current trunk build, attachment 166558 [details] and
http://www.hug-elad.org/plan_info.html display correctly. I am marking this a
dupe of bug 174470.

*** This bug has been marked as a duplicate of 174470 ***
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.