Closed Bug 1198824 Opened 5 years ago Closed 5 years ago

[Dialer] Call volume cannot be adjusted while screen is turned off by proximity sensor

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S6 (04Sep)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: AdamA, Assigned: alwu)

References

()

Details

(Keywords: regression, smoketest, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(3 files)

Attached file logcat
Summary (title) Field:
[Dialer] Call volume cannot be adjusted while screen is turned off by proximity sensor

Description:
If the user is in a phone call and holding the phone to their ear the screen will be turned off by the proximity sensor. when the screen is turned off  by the procimity sensor the call volume cannot be adjusted.

Repro Steps:
1) Update a Aries to 20150826051728
2) Make a phone call
3) Hold phone to ear
4) Attempt to change call volume
5) Observe phone call volume

Actual:
The call volume cannot be adjusted while the screen is off

Expected:
It is expected that the call volume can be adjusted at all points.

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150826051728
Gaia: c1ae9f02f2a9cfb89bf67aeea97e467c41c3362c
Gecko: f61c3cc0eb8b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 10/10
Link to failed test case: https://moztrap.mozilla.org/manage/case/1298/
See attached: video clip, logcat
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150826030209
Gaia: c1ae9f02f2a9cfb89bf67aeea97e467c41c3362c
Gecko: f61c3cc0eb8b
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Result:
Call volume cannot be adjusted in call when screen is off.
-----------------------------------
This issue DOES NOT occur on a previous Aries 2.5, or Flame 2.2.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150825022022
Gaia: b441bde54293bea5254dc340845effe951fa3906
Gecko: 04b8c412d9f5
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.2 [Full Flash]
Build ID: 20150826032503
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: 1effc4cb6414
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
The call volume can be adjusted while the screen is off.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:

Smoke test blocker. Let's get a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: mshuman
From the log, at what times did you do which steps approximately?  It would help to be able to match the logs with the steps.
Flags: needinfo?(aalldredge)
Attached file Clearer logcat
Attaching a new logcat that I only performed the actions to reproduce the bug on.
Flags: needinfo?(aalldredge)
This bug appears to be caused by:
Bug  1185442 - Do not react to mozinterruptbegin events anymore and remove the AudioCompetingHelper

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150820075238
Gaia: 5d3a7bbe66f26a22b3179edc7b3a7cb26561c59b
Gecko: 37a7c0a7fc9dcb11c90cf7b9a80aa38b50d8936f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150820082237
Gaia: c6705f739fb605031eb2a0b943ba55c64bee5a03
Gecko: 6c9cd390c157040b28ed8e4b8509f72ee5c14e2b
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working gaia / First Broken gecko - Issue does NOT reproduce
Gaia: 5d3a7bbe66f26a22b3179edc7b3a7cb26561c59b
Gecko: 6c9cd390c157040b28ed8e4b8509f72ee5c14e2b

First Broken gaia / Last Working gecko - Issue DOES reproduce
Gaia: c6705f739fb605031eb2a0b943ba55c64bee5a03
Gecko: 37a7c0a7fc9dcb11c90cf7b9a80aa38b50d8936f

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/5d3a7bbe66f26a22b3179edc7b3a7cb26561c59b...c6705f739fb605031eb2a0b943ba55c64bee5a03
Blocks: 1185442
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Kevin this smoketest blocker seems to have been caused by the changes for bug 1185442, can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(kevingrandon)
Not really sure I'll have time to dig into this, but might be able to if given some guidance.

Gabriele - maybe could you take a look at this?
Flags: needinfo?(kevingrandon) → needinfo?(gsvelto)
Smoke tests blocker.
blocking-b2g: 2.5? → 2.5+
Doug, do you think you have time to work on it?  Both the gsvelto and kgrandon seem to have their hands full.
Flags: needinfo?(drs)
Assignee: nobody → drs
Flags: needinfo?(drs)
Assignee: drs → gsvelto
[Root cause]
This issue is caused by "the wrong current audio channel in sound manager".

[Situation]
When we press the volume button, the sound manager would check whether need to trigger the changeVolume().
If the screen is disable and current audio channel is "none", then we would not change the volume.

The bug1185442 removed the telephony AudioContext, which would tell the Gaia's AudioChannelService that the telephony is started, and then the AudioChannelService would notify sound manger to change the current audio channel. 

That is why this issue happened after landing bug1185442, we don't change the audio channel to "telephony" even if the call is connected.

However, this issue can be solved in bug1129882. The telephony object in call_handler would take charge of notifying the Gaia's AudioChannelService. Therefore, the current audio channel in sound manager can be set correctly.

---

Hi, Gabriele,
If this bug is very urgent that we can't wait for landing the bug1129882, I have another workaround can fix it [1].
Do you think we need to wait for the bug1129882 or temporarily use this workaround?
Thanks!

[1] https://github.com/mozilla-b2g/gaia/pull/31573
Yes, this is urgent so if a workaround can fix the issue we should land it ASAP.
Assignee: gsvelto → alwu
Status: NEW → ASSIGNED
Flags: needinfo?(gsvelto)
Comment on attachment 8653947 [details] [review]
[gaia] alastor0325:Bug1198824_TeleVolumeControl > mozilla-b2g:master

Etienne, can you help us find who's suitable for reviewing this workaround? It's rather urgent and from what I can tell from the logs all previous reviewer of this bit of the system app have left :(
Attachment #8653947 - Flags: review?(etienne)
Comment on attachment 8653947 [details] [review]
[gaia] alastor0325:Bug1198824_TeleVolumeControl > mozilla-b2g:master

stamp.
Please add a comment in the code mentioning bug 1129882.
(Hopefully this won't be too long lived.)
Attachment #8653947 - Flags: review?(etienne) → review+
Thanks Gabriele & Etienne :)
This changeset would be revert once we land the bug1129882, I have added the comment to mention that.
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/0f0c59df536a85113c572ded263d84b72e0a45d7
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S6 (04Sep)
Keywords: verifyme
This issue is fixed in the latest master(2.5) build.

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150902124951
Gaia: e2fab8f6ac345ecde10a1350e699be9ceb6987d6
Gecko: 1b687fcb5213
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Result:
Call volume can be adjusted with the screen off.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jmercado)
Keywords: verifyme
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.