Closed Bug 1199420 Opened 5 years ago Closed 4 years ago

[Audio Mgmt] Audio not working in packaged app for Cut the Rope

Categories

(Firefox OS Graveyard :: Gaia::System::Audio Mgmt, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: jthomas, Assigned: evanxd)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(4 files)

Description:
The Audio for the packaged app "Cut the Rope" is currently not being played. 


Repro Steps:
1) Update a Aries to 20150827025304
2) Select Market Place
3) Install Cut the Rope
4) Launch Cut the Rope

Actual:
Audio is not heard regardless of volume level.

Expected:
Audio is heard at set volume.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150827025304
Gaia: c1ae9f02f2a9cfb89bf67aeea97e467c41c3362c
Gecko: c70338a96e33a92583c27670a065196f7a934d44
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: (2/3, 100%, etc.)
See attached: Logcat(x2) & Video
Video link: https://youtu.be/wKKhXuutlXI
This issue DOES occur on Flame 2.5
Result: Sound is not initiating.

Environmental Variables:
Device: Flame 2.5 Kk Fullflash (319mb)
Build ID: 20150827083721
Gaia: d784c81961d82cbe9e111405468c590a8345856c
Gecko: b33eae31bd7188024b54228e0c0345800a65e595
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

------------------------------------

This issue does NOT occur on the Aries RC4.
Result: Audio is successfully heard.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150619225606
Gaia: 4c06ed88ddccaba8dc941e5006bd2a9e57306f07
Gecko: 7c1a6b1151a1539186b950a144387e2d7f378d1b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Environmental Variables:
Device: Flame 2.2 Kk Fullflash (319mb)
Build ID: 20150826191108
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: 16d864d163de
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Systemsfe][Spark]
Let's check if this is due to one of the audio channel landings.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Contact: ddixon
Mozilla Inbound Regression Window: 

Last Working 

Device: Flame Master
BuildID: 20150821092739
Gaia: c6705f739fb605031eb2a0b943ba55c64bee5a03
Gecko: c574db1b372e997a8d6389ccae2e207c264d0197
Version: 43.0a1 (Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken 

Device: Flame Master
BuildID: 20150821093040
Gaia: c6705f739fb605031eb2a0b943ba55c64bee5a03
Gecko: 7b24a94110d066be3b8f9c28e6439605a5e02a29
Version: 43.0a1 (Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working Gaia and First Broken Gecko
Issue DOES occur here: 
Gaia: c6705f739fb605031eb2a0b943ba55c64bee5a03
Gecko: 7b24a94110d066be3b8f9c28e6439605a5e02a29

Last Working Gecko and First Broken Gaia
Issue DOES NOT occur here:
Gaia: c6705f739fb605031eb2a0b943ba55c64bee5a03
Gecko: c574db1b372e997a8d6389ccae2e207c264d0197

Mozilla Inbound Pushlog (Gecko): 
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c574db1b372e997a8d6389ccae2e207c264d0197&tochange=7b24a94110d066be3b8f9c28e6439605a5e02a29

Possible Cause: 

Bug 1188754 - Music app doesn't resume after Ringer ends.
Blocks: 1188754
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Ehsan this issue seems to have been caused by the landig for bug 1188754.  Can you please take a look?
Flags: needinfo?(jmercado) → needinfo?(ehsan)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
(In reply to Jayme Mercado [:JMercado] from comment #5)
> Ehsan this issue seems to have been caused by the landig for bug 1188754. 
> Can you please take a look?

No, I don't have a b2g dev environment.  Please ask a b2g developer like :alwu.
Flags: needinfo?(ehsan)
ni?ing alwu per Comment 6
Flags: needinfo?(alwu)
Keep NI, I'll check it later.
[Blocking Requested - why for this release]:
Nominating since it breaks one of the more popular apps.
blocking-b2g: --- → 2.5?
Can you please confirm if its only this app that is broken or are there any other apps that are affected?
Whiteboard: [2.5-Daily-Testing][Systemsfe][Spark] → [2.5-Daily-Testing][Spark]
blocking-b2g: 2.5? → 2.5+
Preliminary analysis, this issue can't be 100% reproduced.
Sometime, the event "activestatechanged" can't send to the system app, so the system app wouldn't open the sound of the app. 
Still debugging...
Assignee: nobody → alwu
Flags: needinfo?(alwu)
From the log, the BrowserElementAudioChannel didn't be created yet when we started playing the audio. 
Therefore, we can't send the notification to the system app to request the playable permission.
Thanks Alastor's investigating.
Component: Gaia::System::Audio Mgmt → AudioChannel
Priority: -- → P1
Blocks: TV_Gecko_P2
From the comment12,
The system app needs to create the "allowedaudiochannel" before the app starts playing audio.
After offline discussion, Evan will help to check this issue.
Hi Alastor,

I cannot reproduce this with Flame in latest build. I've tried more than 20 times. 

Let me try it in Aries.

Build ID               20151014150203
Gaia Revision          c64d6e345aa477f2a24b676e84a47020a00d015d
Gaia Date              2015-10-14 15:54:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4f4615ffec6a6a7ec40ff61ffda90a46c53f8d31
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150622.193834
Firmware Date          Mon Jun 22 19:38:45 EDT 2015
Bootloader             L1TC00011880
Now Evan is investigating this issue, change the owner.
Please feel free to reassign to me if this issue is Gecko bug.
Assignee: alwu → evan
Comment on attachment 8674168 [details] [review]
[gaia] evanxd:bug-1199420 > mozilla-b2g:master

Hi Alastor,

Could you review the patch?

Thanks.
Attachment #8674168 - Flags: review?(alwu)
Component: AudioChannel → Gaia::System::Audio Mgmt
Comment on attachment 8674168 [details] [review]
[gaia] evanxd:bug-1199420 > mozilla-b2g:master

LGTM, thanks!
Attachment #8674168 - Flags: review?(alwu) → review+
Alastor, thanks for the review.

I updated patch[1] for fix unit test. Once treeherder is good, let's land the code.

[1]: https://github.com/evanxd/gaia/commit/1902b235c9629786c4392c45855ef705921fb28b
[2]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=1902b235c9629786c4392c45855ef705921fb28b
master: https://github.com/mozilla-b2g/gaia/commit/fbf31b7de795e104ca16221a5c38a60b8d7a34b8
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.