If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

QuickSearch: Selection no longer preserved

VERIFIED FIXED in mozilla0.9.9

Status

SeaMonkey
MailNews: Message Display
P2
major
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: laurel, Assigned: Navin Gupta)

Tracking

({regression})

Trunk
mozilla0.9.9
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

4.69 KB, patch
Bienvenu
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Using jan14 commercial trunk

When you select a message in QuickSearch then clear the text, you're returned to
the folder view without any selection.  This used to work.

1.  Select a folder with messages (sorted by subject or date, etc. to avoid
threaded view complications).
2.  Select a message or don't (results are the same either way).
3.  Type text in the search bar which will yield matches.
4.  Select a message in search results.
5.  Backspace to clear the text from search bar.
6.  You are returned to folder view with no message selected.

Actual result:  no message selected when returned to folder view.

Expected:  should have the message which I selected in search results shown as
selected upon return to folder view.
(Reporter)

Updated

16 years ago
Keywords: nsbeta1, regression
QA Contact: esther → laurel
(Assignee)

Updated

16 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 1

16 years ago
I have a patch that will fix this one as well as bug 116075, bug 110860, bug 
106709
(Assignee)

Comment 2

16 years ago
Created attachment 64907 [details] [diff] [review]
proposed fix

The fix is to use SaveSelection and RestoreSelection rather than doing from
FE. This will also preserve multiple selection and has the advantage of not
reloading the message. Also this will fix sort by thread when coming out of
quick search, InitSort() was just sorting top level threads and setting
m_sortValid to true so Sort() was not being done.

It also fixes the other bug where we had to expand the thread and select the
message that was selected in QS view. 

seth, can you review?
(Assignee)

Comment 3

16 years ago
Ignore the copyMessageListener changes, they are for a different bug.
(Assignee)

Comment 4

16 years ago
cc bienvenu for review. 
(Assignee)

Comment 5

16 years ago
this patch will not fix bug 116075

Comment 6

16 years ago
Comment on attachment 64907 [details] [diff] [review]
proposed fix

if I'm looking at the right part of the diff, it looks OK. r=bienvenu. Please
let Seth sr since he's been working on these selection issues too.
Attachment #64907 - Flags: review+
Comment on attachment 64907 [details] [diff] [review]
proposed fix

I only reviewed the searchBar.js and nsMsgThreadedDBView.cpp

In the future, edit patches before you attach them to make it easier on the
reviewer.

note, there are code paths in searchBar.js where you don't call

ClearThreadPaneSelection(); and ClearMessagePane();

in some code paths you return before you do that.  is that desired?

if so, sr=sspitzer

make sure to test well.
Attachment #64907 - Flags: superreview+
(Assignee)

Updated

16 years ago
Blocks: 110374
(Assignee)

Updated

16 years ago
Blocks: 110370
(Assignee)

Updated

16 years ago
Blocks: 106709
(Assignee)

Updated

16 years ago
Blocks: 110367
(Assignee)

Updated

16 years ago
Blocks: 110860
(Assignee)

Comment 8

16 years ago
fix checked in. 
(Assignee)

Updated

16 years ago
Blocks: 107829
(Assignee)

Comment 9

16 years ago
marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

16 years ago
Selection is now preserved if there is a selection made in quicksearch results.
If no selection made in search results, there is no selection when returned to
folder view.

OK using jaan29 commercial trunk: win98, mac OS 9.2, linux rh6.2
Status: RESOLVED → VERIFIED
(Assignee)

Updated

16 years ago
No longer blocks: 107829
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.