Copy and Paste joins multiple space characters into one, breaking ascii-formatting

RESOLVED DUPLICATE of bug 1193153

Status

RESOLVED DUPLICATE of bug 1193153
3 years ago
3 years ago

People

(Reporter: github, Unassigned)

Tracking

38 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.37 Safari/537.36

Steps to reproduce:

I composed a Plaintext, non-HTML Email with a ascii-table in it, that is columns indented using multiple spaces. 


Actual results:

When copying text from the same window and pasting it again to re-order some lines, on paste multiple spaces are joined into one single space character, thus breaking formatting
"  1     xxx foo         blah"
gets replaced by
"  1 xxx foo blah"



Expected results:

Copy and Paste should not alter the data in the copy/paste textbuffer!
(In reply to github from comment #0)
> Actual results:
> When copying text from the same window and pasting it again to re-order some lines,
> on paste multiple spaces are joined into one single space character,

Confirmed it with Tb 38.2.0 on Win.
(1) Copy following string in this bug's comment, then Paste at Tb's Plain mail composition window
>   1     xxx foo         blah
> (1-a) Paste at Subject field :   1     xxx foo         blah
> (1-b) Paste at Body    field :   1     xxx foo         blah
(2) Save as draft => Subject field is unvhaanged at composer window,
    but Subject of saved draft mail is changed to "1 xxx foo blah"(This is intentional space removal)
(3) Copy&Paste following string in message body at Tb's Plain mail composition window
>   1     xxx foo         blah
> (2-a) Paste at Subject field : 1 xxx foo
> (2-b) Paste at Body    field : 1 xxx foo
(4) Copy&Paste following string at Tb's HTML mail composition window
>   1     xxx foo         blah
> (4) at any field :   1     xxx foo         blah


(a) "joins multiple space characters into one" is done on Subject line upon mail send.
    This is intentional behaviour to avoid "all space line in Subject" which is prohibited by RFC.
(b) This "joins multiple space characters into one" lookes invoked upon
    Copy operation at Plain mail composition window of Thunderbird.

To bug opener:
I couldn't see the phenomenon in Seamonkey 2.33.1.
New problem in Tb 38.2.0 and no prooblem in Tb 38.1.0? Or new in Tb 38 and no problem util Tb 37?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

3 years ago
I noticed just after update to the latest version using the builtin update mechanism of TB in Linux, unfortunately I do not know which version is the latest without this behaviour as I did not update for some time.

I just checked with another machine: 31.2.0 does not show this bug, 38.2.0 whows the bug.
Closing as dup of bug 1174452. If duping is wrong, please re-open.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1174452
Duplicate of bug: 1193153
You need to log in before you can comment on or make changes to this bug.