Closed Bug 1199863 Opened 6 years ago Closed 6 years ago

[Flame][OTA] Update doesn't install possibly because of out of space issue on the system partition

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1037056

People

(Reporter: gaby2300, Unassigned)

References

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

Flame with 2.5, base image 18D v4.

1) Check for updates.
2) New update is available.
3) Tap to download update.
4) The update downloads, uncompresses but fails to install.
5) Notice "1 new update" in notifications.

Expected: the update should download, uncompress and install
Actual: the update fails to install.


The logcat shows that the update failed due to errorCode 70, this is related to an out of space issue on the system partition.
Flags: needinfo?(nhirata)
Flags: needinfo?(nhirata) → needinfo?(nhirata.bugzilla)
Duplicate of this bug: 1201674
(In reply to Gabriela [:gaby2300] from comment #0)
> Flame with 2.5, base image 18D v4.
> 
> 1) Check for updates.
> 2) New update is available.
> 3) Tap to download update.
> 4) The update downloads, uncompresses but fails to install.
> 5) Notice "1 new update" in notifications.
> 
> Expected: the update should download, uncompress and install
> Actual: the update fails to install.
> 
> 
> The logcat shows that the update failed due to errorCode 70, this is related
> to an out of space issue on the system partition.

Would have been great to have:
 - logcat output
 - partition size and free space infos
 - size of the OTA
(In reply to Alexandre LISSY :gerard-majax from comment #2)
> Would have been great to have:
>  - logcat output

I/GeckoUpdater(11503): Progress [ ============================================
     ]
I/GeckoUpdater(11503): Progress [ =============================================
     ]
I/GeckoUpdater(11503): Progress [ ==============================================
=    ]
I/GeckoUpdater(11503): Progress [ ==============================================
==   ]
I/GeckoUpdater(11503): Progress [ ==============================================
===  ]
I/GeckoUpdater(11503): Progress [ ==============================================
==== ]
I/GeckoUpdater(11503): Finished applying update
I/GonkAutoMounter(11503): Mounted /system partition as read-only
I/Gecko   (  752): *** AUS:SVC readStatusFile - status: failed: 70, path: /data/local/updates/0/update.status
I/GeckoConsole(  752): AUS:SVC readStatusFile - status: failed: 70, path: /data/local/updates/0/update.status
I/Gecko   (  752): UpdatePrompt: Update error, state: failed, errorCode: 70
E/GeckoConsole(  752): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 145}]
W/GeckoConsole(  752): Content JS WARN: L10n Deprecation Warning: using innerHTML in translations is unsafe and will not be supported in future versions of l10n.js. See https://bugzil.la/1027117
W/GeckoConsole(  752):     at translateElement (app://system.gaiamobile.org/gaia_build_index.js:223:130)
W/GeckoConsole(  752): Content JS WARN: L10n Deprecation Warning: using innerHTML in translations is unsafe and will not be supported in future versions of l10n.js. See https://bugzil.la/1027117
W/GeckoConsole(  752):     at translateElement (app://system.gaiamobile.org/gaia_build_index.js:223:130)
I/Gecko   (  752): UpdatePrompt: Setting gecko.updateStatus: Install Pending
E/GeckoConsole(  752): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 145}]
E/GeckoConsole(  752): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 145}]
I/Gecko   (  752): *** AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 70
I/GeckoConsole(  752): AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 70

>  - partition size and free space infos
>  - size of the OTA

How does one obtain these?
Flags: needinfo?(lissyx+mozillians)
Attached file gab_logcat.txt
Logcat from Gabby attached.

C:\Users\Gabriela>adb shell df
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
Filesystem               Size     Used     Free   Blksize
/dev                   451.7M   132.0K   451.6M   4096
/sys/fs/cgroup         451.7M     0.0K   451.7M   4096
/sys/fs/cgroup/memory: Permission denied
/mnt/asec              451.7M     0.0K   451.7M   4096
/mnt/obb               451.7M     0.0K   451.7M   4096
/system                412.0M   278.3M   133.8M   4096
/data                    2.0G   118.8M     1.9G   4096
/cache                  70.8M    65.8M     5.0M   4096
/persist                 4.9M     4.0M   852.0K   4096
/firmware               64.0M    31.7M    32.2M   16384
/storage/sdcard          3.8G    27.9M     3.8G   4096
/mnt/media_rw/sdcard: Permission denied

For "buildID": "20150820202733" from "https://queue.taskcluster.net/v1/task/NBHLNIaWRgSZq5yN2zO87g/runs/0/artifacts/public/build/b2g-flame-gecko-update.mar" the "filesize": 95680379
oops wrong one:
nightly-latest shows 20150904191104 from https://queue.taskcluster.net/v1/task/C4V7xqCeSrW0_0FhyHUSPg/runs/0/artifacts/public/build/b2g-flame-gecko-update.mar" which has filesize: 99085726
Flags: needinfo?(nhirata.bugzilla)
Alexandre, how much more space do we have on device?  Can we just up it to 1 G?
Flags: needinfo?(nhirata.bugzilla)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #6)
> Alexandre, how much more space do we have on device?  Can we just up it to 1
> G?

Only T2M can do this.
Flags: needinfo?(lissyx+mozillians)
Six months ago, bug 1085230 comment 8, this is still valid: FOTA will not expose this issue.
Can't we build a new base image allowing more space for the OTA as was done with base image 18D v4?
(In reply to Gabriela [:gaby2300] from comment #9)
> Can't we build a new base image allowing more space for the OTA as was done
> with base image 18D v4?

see comment 7/8
Flags: needinfo?(nhirata.bugzilla)
3 MB difference comes between this change set: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ba43a48d3c52&tochange=08015770c9d6

https://tools.taskcluster.net/task-inspector/#qY5G9_jFQj2W3ArAVkJ7ow 
- buildid: 20150824125954 
- size: 95652756 
- hg rev: ba43a48d3c528cc956335793e02504e5ca2c149f

https://tools.taskcluster.net/task-inspector/#h_gMoVcyTTqxVSk-5l-cAA 
- buildid: 20150825013701 
- size: 99178174 
- hg rev: 08015770c9d687f93fc7b13970d32e457b680d2a
12 MB change; 2.28 MB, patch just for PocketSphinx etc. the voice engine for Vaani.

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e5ee2c56963c&tochange=0920f2325a6d

** https://tools.taskcluster.net/task-inspector/#SbxvnpIDQQempFnmk0vtVg
- buildid : 20150603203011
- size : 80346268
- hg rev: e5ee2c56963c52ea1bdf9758c07c63d20e6d4707
** https://tools.taskcluster.net/task-inspector/#yo5_pqTKTQOm27ynQxxahg
- buildid : 20150603203105
- size 92378167

Even if we make this more compact, we'll run into the same issue again.  We do need to be more conscience about being compact.  At the same time we also need to FOTA.
- hg rev : 0920f2325a6dd87f10aab26499601eb0c1c8a57d
Also if you use the V18D_nightly_v4 base image and shallow_flash the latest nightly master build, you do not get OTA updates at all. It doesn't even find any.
Depends on: 1211965
Reece, we're currently doing testing and such in regards to FOTA using the OTA channels, so the OTA will not find anything at all at this moment in time.

This is still a dependency on the FOTA.
Okay thank you for explaining, good luck with your testing! Updates are extremely handy for people running 2.5 to report bugs.
Yes, it's on one of my higher priorities to get going.
I apologize for the inconvenience, and appreciate the feedback.

I am hoping to either resolve this this week or next.
No longer blocks: 1196992
See Also: → 1196992
Fixed by moving to FOTA.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1037056
I still can't receive updates for 2.5, how do I set up/use FOTA?
Try setting the update channel to nightly or nightly test.
My version of 2.5 is shallow_flashed, so it's already set to nightly in the developer settings. There is a seperate FOTA thing located in "Mobile & Data > Sim 1 > APN Settings > FOTA Settings" but it's completely blank and asks for me to add a new APN with a name, an identifier, a password etc. All of that is blank.
(In reply to Reece from comment #21)
> My version of 2.5 is shallow_flashed, so it's already set to nightly in the
> developer settings. 
Then try with nightly-test.

There is a seperate FOTA thing located in "Mobile & Data
> > Sim 1 > APN Settings > FOTA Settings" but it's completely blank and asks
> for me to add a new APN with a name, an identifier, a password etc. All of
> that is blank.
I see these blank too but I FOTA without issues.
I've changed the name but it's still not working.
I'm on v18D_nightly_v4 and I'm running a shallow_flashed nightly version of 2.5 so I'm not sure why it's not.
Did you restart the device after changing the update channel?
Yep I did. I've now gone and re-flashed v18D_nightly_v4, then I've re-flashed 2.5. Now I'll wait for tomorrow's update and post here if I can FOTA to it.
Okay so FOTA updates work for me! All I needed to do was manually change the channel from "nightly" (the default) to "nightly-latest". Maybe it would be best for the channel documentation to be on the "Updating Your Flame" page as the nightly-latest channel is what it used to be before the change.
No, nightly-latest is untested and can be horribly broken at times. nightly is tested to work decently.
How about nightly-test? it's the one I set and FOTA updates work fine.
I'm aware don't worry. I've been manually flashing the 2.5 nightly updates for a few months and I've even been using them daily on my phone. Mainly the bugs I've encountered have been visual ones (granted I only really use it for playing music, texting, calling and viewing the web). 

I've not tried nightly-test yet.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #27)
> No, nightly-latest is untested and can be horribly broken at times. nightly
> is tested to work decently.

How about nightly-test? it's the one I set and FOTA updates work fine.
You need to log in before you can comment on or make changes to this bug.