Closed Bug 1085230 Opened 7 years ago Closed 6 years ago

[Flame] OTA needs enough /system space to update

Categories

(Firefox OS Graveyard :: Vendcom, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mlien, Unassigned)

References

Details

Attachments

(2 files)

Attached file memory.log
+++ This bug was initially created as a clone of Bug #1073399 +++

Since OTA will uncompress update package in /system partition, it should need enough space to let update successfully.

From vendor base image, it only has 102.9MB from their released user build.
We should have a better solution to avoid OTA fail again in the future.

Attachment shows different timing free space in /system. The potential problem is if update to v2.2, free space in /system only left over 760.0K while uncompressing update package.
The 18D base image does again not leave enough space. After deleting /system/media/audio, it works again.
Hi Robert, could you share the 18D base image is 18D-nightly? or the STR not enough space?

Here is my disk usage using 18D-nightly during update:

Clean 18D-nightly:
/system                354.2M   225.5M   128.7M   4096
/data                    2.0G    35.9M     2.0G   4096
/storage/sdcard          3.8G     8.0K     3.8G   4096

After uncompress, ready to apply:
/system                354.2M   315.0M    39.2M   4096
/data                    2.0G    36.2M     2.0G   4096
/storage/sdcard          3.8G    70.5M     3.8G   4096

After update to 20150211160231:
/system                354.2M   227.6M   126.5M   4096
/data                    2.0G    36.3M     2.0G   4096
/storage/sdcard          3.8G    16.0K     3.8G   4096

I don't have the /system/media/audio folder, will check in previous image.
Looks like /system/media/audio is in 18D, not 18D-nightly. I think STR is do a shallow_flash then followed by OTA will cause this problem?
I use 18D, not 18D-nightly, flash to 20150112000204

Clean 2015-01-12-00-02-04-mozilla-b2g32_v2_0-flame-kk: 
/system                354.2M   258.6M    95.5M   4096
/data                    2.0G    37.9M     2.0G   4096
/storage/sdcard          3.8G     8.0K     3.8G   4096

After uncompress 2015-02-11-16-02-55-mozilla-b2g32_v2_0-flame-kk, ready to apply:
/system                354.2M   340.8M    13.4M   4096
/data                    2.0G    37.9M     2.0G   4096
/storage/sdcard          3.8G    64.4M     3.8G   4096

After update to 20150211160255
/system                354.2M   259.3M    94.8M   4096
/data                    2.0G    38.0M     2.0G   4096
/storage/sdcard          3.8G    16.0K     3.8G   4096

/system seems small may be dangerous for large update
I had used 18D itself, and then followed https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame#Updating_your_Flame_to_a_nightly_build to get a master build, and then, some days later, tried to install the OTA, which failed in the "uncompressing" stage. Then, I deleted /system/media/audio and triggering the update again succeeded.
I have not tried 18D-nightly, I didn't know there was another build there. This is getting somewhat confusing... ;-)
From https://bugzilla.mozilla.org/show_bug.cgi?id=1073399#c66 , I think this is a general problem, /system partition is small for some update.
When reproduce, you can help to list original version, free disk space and the update package url. That will help to find out root cause.
18D-nightly temporary shown on MDN, but disappear today.
We can increase the /system partition size. I've asked Wesly whether this is risky or not :)
Flags: needinfo?(wehuang)
Any repartitioning will be risky. Repartitioning is also very likely to destroy data. We should switch to normal FOTA updates, which require less space and allow us to clean out any unnecessary files.
T2M claims there is indeed some unused sectors in current Flame partition layout, which simply follows QCT design and T2M didn't put anything there. (see below between "the end of modemst2" and "the beginning of system") Yet any partition change is risky like Michael said, so suggest anyone would like to try it must handle it with special care.

--------8<--------8<--------8<--------8<--------8<--------8<--------
Disk gpt_both0.bin: 67 sectors, 33.5 KiB
Logical sector size: 512 bytes
Disk identifier (GUID): 98101B32-BBE2-4BF2-A06E-2BB33D000C20
Partition table holds up to 32 entries
First usable sector is 34, last usable sector is 0
Partitions will be aligned on 2-sector boundaries
Total free space is 0 sectors (0 bytes)

Number  Start (sector)    End (sector)  Size       Code  Name
   1          131072          262143   64.0 MiB    0700  modem
   2          262144          263167   512.0 KiB   FFFF  sbl1
   3          263168          263423   128.0 KiB   FFFF  sdi
   4          393216          393279   32.0 KiB    FFFF  DDR
   5          524288          525311   512.0 KiB   FFFF  aboot
   6          525312          526311   500.0 KiB   FFFF  rpm
   7          655360          686079   15.0 MiB    FFFF  boot
   8          786432          787431   500.0 KiB   FFFF  tz
   9          787432          789479   1024.0 KiB  0700  pad
  10          789480          792551   1.5 MiB     FFFF  modemst1
  11          792552          795623   1.5 MiB     FFFF  modemst2
  12          917504         1654783   360.0 MiB   0700  system
Flags: needinfo?(wehuang)
If I read that correctly, there's north of 200MiB of wasted space besides what you mentioned (between sdi and DDR, then between DDR and aboot, then between rpm and boot and finally between boot and tz). Why was partitioning done this way? Is there a rationale for leaving that much unused space? That seems especially silly in the light of our troubles with the /system partition being not large enough (not that we shouldn't strive to keep our updates small mind you).
I made comment 8 with the assumption that increasing the size of /system would reduce the size of some other partition. Since this is not the case, I think it's worth increasing the size of /system for the next base image update. Base image updates already flash everything so it shouldn't increase the risk much.

That being said, we still need to switch to proper FOTA updates.
Attached file gpt_both0_big.bin
This is the GPT layout that increases /system to 419.5MB. The partition size should be set to 439877632 in the device tree to make use of it.

It should be flashed by doing: |fastboot flash partition gpt_both0_big.bin|. Please reflash a system partition after doing so, otherwise there may be issues.
Upgrade path should be:
 - land /system extension to 419.5MB
 - ask people to reflash gpt and system partition

This should not break OTA updating. This may break flashing pvtbuilds if the user still has the old partition layout and tries to flash a bigger /system partition. It will just fail to flash /system, though.

Maybe we can augment flash pvt scripts with the GPT partition header and flash it before system partition gets flashed?
Flags: needinfo?(fyen)
We should make the partition update part of the first L base image update. device-flame also needs to be updated and I don't want any concern about flashing to different devices with different system partition sizes.
Wesly, T2M needs to pick up this for next L base image.
Flags: needinfo?(wehuang)
(In reply to Alexandre LISSY :gerard-majax from comment #13)
> Upgrade path should be:
>  - land /system extension to 419.5MB
>  - ask people to reflash gpt and system partition
> 
> This should not break OTA updating. This may break flashing pvtbuilds if the
> user still has the old partition layout and tries to flash a bigger /system
> partition. It will just fail to flash /system, though.
> 
> Maybe we can augment flash pvt scripts with the GPT partition header and
> flash it before system partition gets flashed?

The 'flash_pvt' script do not control how to flash full images, 'flash.sh' [1] does.
If we want to update partition before flash images, we should do it in the 'flash.sh'.

[1] https://github.com/mozilla-b2g/B2G/blob/master/flash.sh
Flags: needinfo?(fyen)
(In reply to Alexandre LISSY :gerard-majax from comment #15)
> Wesly, T2M needs to pick up this for next L base image.

Hi Alex:

Just to be sure, you mean comment#14, right?

(In reply to Michael Wu [:mwu] from comment #14)
> We should make the partition update part of the first L base image update.
> device-flame also needs to be updated and I don't want any concern about
> flashing to different devices with different system partition sizes.

If my understanding is correct, it contains 2 things:

1. RF tuning parameter (partition "traceability" & "tuningpara") back/restore during KK <-> L SW flash
2. update content in folder "device-flame"

I think Francis (who is handling Flame L) has took them into consideration with T2M and team already.

@Francis, would you help share the status of above 2 items? Thanks.
Flags: needinfo?(wehuang)
Flags: needinfo?(lissyx+mozillians)
Flags: needinfo?(frlee)
Yes.
Flags: needinfo?(lissyx+mozillians)
hi Alexandre and Wesly,

for #1, backup/restore is already taken in consideration. Viral is preparing and we will validate it once we receive L source code from T2M.

for #2, are you talking about: we need to "rm backup-flame" before "build.sh"?

thank you very much
Flags: needinfo?(frlee) → needinfo?(lissyx+mozillians)
(In reply to Francis Lee [:frlee] from comment #19)
> hi Alexandre and Wesly,
> 
> for #1, backup/restore is already taken in consideration. Viral is preparing
> and we will validate it once we receive L source code from T2M.
> 
> for #2, are you talking about: we need to "rm backup-flame" before
> "build.sh"?
> 
> thank you very much

Which question am I expected to answer ?
Flags: needinfo?(lissyx+mozillians)
Kamil, I heard that you are going to get Flame shortly :p Please Update it manually to the master 3.0.0 and try to apply current OTA. Please also monitor space on /system during uncompressing of .mar file (with use of df command in the shell of Flame). Thx!
Flags: needinfo?(kamil0717)
(In reply to mac from comment #22)
> Kamil, I heard that you are going to get Flame shortly :p Please Update it
> manually to the master 3.0.0 and try to apply current OTA. Please also
> monitor space on /system during uncompressing of .mar file (with use of df
> command in the shell of Flame). Thx!

Ah, here we meet again!

My flame device shows this problem too.

Following information I can provide:

$ adb shell
root@flame:/ # df
df
Filesystem               Size     Used     Free   Blksize
/dev                   452.7M   132.0K   452.6M   4096
/sys/fs/cgroup         452.7M    12.0K   452.7M   4096
/mnt/asec              452.7M     0.0K   452.7M   4096
/mnt/obb               452.7M     0.0K   452.7M   4096
/system                354.2M   258.0M    96.1M   4096
/data                    2.0G   119.6M     1.9G   4096
/cache                  70.8M     8.5M    62.3M   4096
/persist                 4.9M     4.1M   848.0K   4096
/firmware               64.0M    31.7M    32.2M   16384
/storage/sdcard          3.8G    76.6M     3.8G   4096
/storage/sdcard1        15.1G    39.8M    15.0G   32768
/mnt/media_rw/sdcard     3.8G    76.6M     3.8G   4096
/mnt/media_rw/sdcard1    15.1G    39.8M    15.0G   32768
root@flame:/ #

The download which fails to uncompress is shown in the notification area thusly

System update
74.95 MB

What is the way to determine this is the issue for me?

Does following excerpt from dev-log-system.log look like this is my problem?

04-12 11:20:27.581   191   304 D Vold    : Volume sdcard1 state changing 1 (Idle-Unmounted) -> 3 (Checking)
04-12 11:20:27.821   789   789 D fsck_msdos: sectors Per cluster :64 
04-12 11:20:27.821   789   789 D fsck_msdos: boot->ClusterOffset :8064 
04-12 11:20:27.821   789   789 I fsck_msdos: FAT32 Filesystem
04-12 11:20:27.821   789   789 D fsck_msdos: Using cluster_chain_descriptor
04-12 11:20:27.821   789   789 I fsck_msdos: Total clusters 493282 
04-12 11:20:28.041   789   789 I fsck_msdos: Begin to compare FAT
04-12 11:20:28.061   789   789 I fsck_msdos: ** Phase 2 - Check Cluster Chains 
04-12 11:20:28.071   789   789 I fsck_msdos: Begin to handle the cluster chain
04-12 11:20:28.101   789   789 D fsck_msdos: rootDir->head :2
04-12 11:20:28.111   789   789 D fsck_msdos: Verify Filesystem information
04-12 11:20:28.111   789   789 W fsck_msdos: 65 files, 3161344 free (492008 clusters)
04-12 11:20:28.111   789   789 I fsck_msdos: free_rb_tree 
04-12 11:20:28.111   789   789 I fsck_msdos: free_fragment_tree
04-12 11:20:28.111   789   789 I fsck_msdos: free_fragment_tree
04-12 11:20:28.111   789   789 I fsck_msdos: free_fragment_tree: rb_tree is empty 
04-12 11:20:28.131   191   304 I Vold    : Filesystem check completed OK
04-12 11:20:28.191   191   304 D Vold    : Volume sdcard1 state changing 3 (Checking) -> 4 (Mounted)
04-12 11:20:38.991   200  1067 W SocketClient: write error (Broken pipe)
04-12 11:20:39.001   200  1068 W SocketClient: write error (Broken pipe)
04-12 11:20:40.151   200  1078 W SocketClient: write error (Broken pipe)
04-12 11:20:40.161   200  1079 W SocketClient: write error (Broken pipe)
04-12 11:20:40.161   200  1080 W SocketClient: write error (Broken pipe)
04-12 11:20:40.201   200  1081 W SocketClient: write error (Broken pipe)
04-12 11:20:40.211   200  1082 W SocketClient: write error (Broken pipe)
04-12 11:20:40.351   200  1083 W SocketClient: write error (Broken pipe)
Okay,
I started with base image v18D, then I shallow flashed nightly build

Build identifier: 20150421010201
Git info: 2015-04-20 19:30:21 a8e4f95d

Result:
Filesystem               Size     Used     Free   Blksize
/system                354.2M   258.0M    96.2M   4096

Update size: 75.05MB

And uncompressing failed because of lack of free space on /system. I tried twice
Flags: needinfo?(kamil0717)
(In reply to Kamil from comment #24)
> Okay,
> I started with base image v18D, then I shallow flashed nightly build
> 
> Build identifier: 20150421010201
> Git info: 2015-04-20 19:30:21 a8e4f95d
> 
> Result:
> Filesystem               Size     Used     Free   Blksize
> /system                354.2M   258.0M    96.2M   4096

After installing v18D_nightly_v2 you should see
Filesystem               Size     Used     Free   Blksize
...
/system                354.2M   226.9M   127.2M   4096

Check you get the same as me:

$ adb shell getprop ro.bootloader
L1TC000118D0
$

Then it is important to first install any OTA updates, before restoring a profile backup.

When I restored before OTA my flame would hang in the ThunderSoft banner.

> 
> Update size: 75.05MB
> 
> And uncompressing failed because of lack of free space on /system. I tried
> twice
Okay,
on v18d_nightly_v2 I have

Filesystem               Size     Used     Free   Blksize
/system                354.2M   226.9M   127.2M   4096

Ready to update:
Filesystem               Size     Used     Free   Blksize
/system                354.2M   323.6M    30.6M   4096

After update:
Filesystem               Size     Used     Free   Blksize
/system                354.2M   234.9M   119.3M   4096
I/GeckoUpdater( 2034): Progress [ ===============================================    ]
I/GeckoUpdater( 2034): Progress [ ================================================   ]
I/GeckoUpdater( 2034): Progress [ =================================================  ]
I/GeckoUpdater( 2034): Progress [ ================================================== ]
I/GeckoUpdater( 2034): Finished applying update
I/GonkAutoMounter( 2034): Mounted /system partition as read-only
I/Gecko   (  749): *** AUS:SVC readStatusFile - status: failed: 70, path: /data/local/updates/0/update.status
I/GeckoConsole(  749): AUS:SVC readStatusFile - status: failed: 70, path: /data/local/updates/0/update.status
I/Gecko   (  749): UpdatePrompt: Update error, state: failed, errorCode: 70
E/GeckoConsole(  749): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 136}]
I/Gecko   (  749): UpdatePrompt: Setting gecko.updateStatus: Install Pending
E/GeckoConsole(  749): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 136}]
E/GeckoConsole(  749): [JavaScript Error: "formatURLPref: Couldn't get pref: app.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFormatter.js" line: 136}]
I/Gecko   (  749): *** AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 70
I/GeckoConsole(  749): AUS:SVC UpdateManager:refreshUpdateStatus - Notifying observers that the update was staged. state: pending, status: failed: 70
I/nsVolumeMountLock(  749): nsVolumeMountLock released for 'sdcard'
W/GeckoConsole(  749): Content JS WARN: L10n Deprecation Warning: using innerHTML in translations is unsafe and will not be supported in future versions of l10n.js. See https://bugzil.la/1027117 
W/GeckoConsole(  749):     at translateElement (app://system.gaiamobile.org/gaia_build_index.js:266:130)
W/GeckoConsole(  749): Content JS WARN: L10n Deprecation Warning: using innerHTML in translations is unsafe and will not be supported in future versions of l10n.js. See https://bugzil.la/1027117 
W/GeckoConsole(  749):     at translateElement (app://system.gaiamobile.org/gaia_build_index.js:266:130)
I/nsVolume(  749): nsVolume: sdcard state Mounted @ '/storage/sdcard' gen 1 locked 0 fake 0 media 1 sharing 0 formatting 0 unmounting 0 removable 0 hotswappable 0
I/AutoMounter(  749): AutoMounter state changed from IDLE to UMS_CONFIGURED
I/AutoMounter(  749): UpdateState: ums:A1C1E0 mtp:A1C0E0 mode:0 usb:1 tryToShare:0 state:UMS_CONFIGURED
I/AutoMounter(  749): UpdateState: Volume sdcard is Mounted and inserted @ /storage/sdcard gen 1 locked 0 sharing en-n
I/AutoMounter(  749): UpdateState: Volume sdcard1 is Mounted and inserted @ /storage/sdcard1 gen 2 locked 0 sharing en-n


I saw this in my log. Usually 70 means that it's not enough disk space, though I think it's because the permissions is readonly and it's not remounting to a rw for OTA is the root cause?
Never mind. followed Comment 13 and then tried to OTA.  OTA worked.  Fixing the contributor build in bug 1154072 to have the fix as well.
70 is WRITE_ERROR_EXTRACT:

https://dxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/nsUpdateService.js#131

and comes from here:

https://dxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/updater/archivereader.cpp#311

I think the "/system mounted read-only" message that appears earlier in the log is triggered by the failure to finish the update and would in fact appear after the Geko error message if it weren't for two separate processes.
Depends on: 1175361
(In reply to Panos Astithas [:past] from comment #29)
> I think the "/system mounted read-only" message that appears earlier in the
> log is triggered by the failure to finish the update and would in fact
> appear after the Geko error message if it weren't for two separate processes.

Yep.

And the fact that the progress almost got to 100% means that it was extracting fine, and ran out of disk space near the very end.
my flame device hangs in thundersoft banner after it rebooted by itself yesterday morning (failed to unpack a nightly OTA download a few days ago, but functioned until yesterday morning).

I cannot communicate with it via adb, only fastboot. My flame is a brick.
(In reply to Adrian Aichner [:anaran] from comment #32)
> my flame device hangs in thundersoft banner after it rebooted by itself
> yesterday morning (failed to unpack a nightly OTA download a few days ago,
> but functioned until yesterday morning).
> 
> I cannot communicate with it via adb, only fastboot. My flame is a brick.

You need to flash a new base image, and then you'll be able to reflash for current builds.
(In reply to Clément Lefèvre from comment #33)
> (In reply to Adrian Aichner [:anaran] from comment #32)
> > my flame device hangs in thundersoft banner after it rebooted by itself
> > yesterday morning (failed to unpack a nightly OTA download a few days ago,
> > but functioned until yesterday morning).
> > 
> > I cannot communicate with it via adb, only fastboot. My flame is a brick.
> 
> You need to flash a new base image, and then you'll be able to reflash for
> current builds.

I already upgraded to
http://cds.w5v8t3u9.hwcdn.net/v18D_nightly_v2.zip
end of April (comment 25).

Is there a newer base image available? (I did not find any)
(In reply to Adrian Aichner [:anaran] from comment #34)
> (In reply to Clément Lefèvre from comment #33)
> > (In reply to Adrian Aichner [:anaran] from comment #32)
> > > my flame device hangs in thundersoft banner after it rebooted by itself
> > > yesterday morning (failed to unpack a nightly OTA download a few days ago,
> > > but functioned until yesterday morning).
> > > 
> > > I cannot communicate with it via adb, only fastboot. My flame is a brick.
> > 
> > You need to flash a new base image, and then you'll be able to reflash for
> > current builds.
> 
> I already upgraded to
> http://cds.w5v8t3u9.hwcdn.net/v18D_nightly_v2.zip
> end of April (comment 25).
> 
> Is there a newer base image available? (I did not find any)

Not yet, but the next one is being build and you can follow the evolution here: https://bugzilla.mozilla.org/show_bug.cgi?id=1154072
See Also: → 1181372
Duplicate of this bug: 1187550
Is this bug still New?
Looks resolved to me since newer base images exist now.
I think this should be fixed but I haven't received an OTA on my Flame yet since flashing the new base image so I'd be waiting for that before closing it.
I've been using 20150527010201 via https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame#Base_Image for weeks now. Have reset data numerous times too. 

Issue still around from my experience.
(In reply to David Ross from comment #39)
> I've been using 20150527010201 via
> https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/
> Updating_your_Flame#Base_Image for weeks now. Have reset data numerous times
> too. 
> 
> Issue still around from my experience.

With v4 base image? That's quite strange. I was able to update with OTA without any issues lately.
As were other people. v18Dv4 is supposed to have all required fixes regarding partitions sizes.
I have the same issue as David Ross. I flashed 1.8Dv4 nightly and then soft flashed to latest nightly but I have not been getting any OTA updates.
(In reply to Nick from comment #41)
> I have the same issue as David Ross. I flashed 1.8Dv4 nightly and then soft
> flashed to latest nightly but I have not been getting any OTA updates.

Yes, it's because nightly channel point to an earlier build.

If you full flash and then try to update, you should see an update, and after it you should be on build 20150820202733.

Nightly channel is pointing to this one, looking at bug https://bugzilla.mozilla.org/show_bug.cgi?id=1174840 and https://bugzilla.mozilla.org/show_bug.cgi?id=1174840

Other informations can be found here: https://wiki.mozilla.org/B2G/QA/Flame_OTA#Change_Sets
I meant https://bugzilla.mozilla.org/show_bug.cgi?id=1188992 for the second bug.
If you could by the way confirm that after a flash you correctly get this build on OTA
Flags: needinfo?(sw1ayfe)
Flags: needinfo?(nick.cumbo)
Ahh. I've been adding the most recent Flame nightly builds on top of the base image. I had not been aware doing so would effectively block the OTA. Had been wondering why additionally the Marketplace update would never download via OTA. Only via the Marketplace itself.

Done the OTA update via the base image and I shall quietly back away with a fully updated Flame. Feel the virtual hugz.
Flags: needinfo?(sw1ayfe)
Hi Clément. Thanks for your assistance - that worked. I'm now on build 20150820200530.
Flags: needinfo?(nick.cumbo)
(In reply to David Ross from comment #44)
> Ahh. I've been adding the most recent Flame nightly builds on top of the
> base image. I had not been aware doing so would effectively block the OTA.
> Had been wondering why additionally the Marketplace update would never
> download via OTA. Only via the Marketplace itself.
> 
> Done the OTA update via the base image and I shall quietly back away with a
> fully updated Flame. Feel the virtual hugz.

Hi David. I would greatly appreciate it if you could please tell what you mean by doing "the OTA update via the base image"!
(In reply to Gabriela [:gaby2300] from comment #46)
> (In reply to David Ross from comment #44)
> > Ahh. I've been adding the most recent Flame nightly builds on top of the
> > base image. I had not been aware doing so would effectively block the OTA.
> > Had been wondering why additionally the Marketplace update would never
> > download via OTA. Only via the Marketplace itself.
> > 
> > Done the OTA update via the base image and I shall quietly back away with a
> > fully updated Flame. Feel the virtual hugz.
> 
> Hi David. I would greatly appreciate it if you could please tell what you
> mean by doing "the OTA update via the base image"!

Probably is he talking about the Marketplace update which is always in the list of updates even after a fresh flash of the last build.

Anyway, this issue now looks solved, so closing the bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I meant not attempting the OTA once I had shallow flashed the latest (1 day behind haha) Flame nightly builds. Doing the OTA having only flashed the v18D_nightly_v4 fixed it without having to proceed further to shallow flash nightlies.

BTW should this issue should be closed before a rolling nightly OTA has been confirmed as working?
Flags: needinfo?(clement.lefevre)
(In reply to David Ross from comment #48)
> I meant not attempting the OTA once I had shallow flashed the latest (1 day
> behind haha) Flame nightly builds. Doing the OTA having only flashed the
> v18D_nightly_v4 fixed it without having to proceed further to shallow flash
> nightlies.
> 
> BTW should this issue should be closed before a rolling nightly OTA has been
> confirmed as working?

There are bugs for this problem, I gave you the links.

This specific bug is about the update failing because of insufficient space on the phone to uncompress and update. This issue is solved, as you can see, with base image v18D v4 as you could update an OTA build with it.
Any other remaining issues are other issues, and so are to be tracked on other bugs.
Flags: needinfo?(clement.lefevre)
Just a heads up for Gabriella & Nick:

go into settings >> developer
change the 'Update Channel' to nightly-test

then back to settings >> device information
and in check update press 'Check Now'

When I did this the OTA immediately found new update Build ID 20150828201018
Flags: needinfo?(nick.cumbo)
Flags: needinfo?(gmontagu)
(In reply to David Ross from comment #50)
> Just a heads up for Gabriella & Nick:
> 
> go into settings >> developer
> change the 'Update Channel' to nightly-test
> 
> then back to settings >> device information
> and in check update press 'Check Now'
> 
> When I did this the OTA immediately found new update Build ID 20150828201018

Just a heads-up in this case: be very careful with this this channel: nightly channel does have automatic tests ensuring the build have the minimum working features for a phone daily usage. If minimal requirements are not met, the build isn't offered as an OTA update.

Those tests are not performed on nightly-test, so it can result any day in a non-working phone.
(In reply to Clément Lefèvre from comment #51)
> (In reply to David Ross from comment #50)
> > Just a heads up for Gabriella & Nick:
> > 
> > go into settings >> developer
> > change the 'Update Channel' to nightly-test
> > 
> > then back to settings >> device information
> > and in check update press 'Check Now'
> > 
> > When I did this the OTA immediately found new update Build ID 20150828201018
> 
> Just a heads-up in this case: be very careful with this this channel:
> nightly channel does have automatic tests ensuring the build have the
> minimum working features for a phone daily usage. If minimal requirements
> are not met, the build isn't offered as an OTA update.
> 
> Those tests are not performed on nightly-test, so it can result any day in a
> non-working phone.

I followed your steps before, but I can't get past Build ID 20150825201018.
I get the same result as before this bug was fixed: the update downloads, uncompresses but does not install and I see "1 update available" again.
Flags: needinfo?(gmontagu)
(In reply to Gabriela [:gaby2300] from comment #52)
> (In reply to Clément Lefèvre from comment #51)
> > (In reply to David Ross from comment #50)
> > > Just a heads up for Gabriella & Nick:
> > > 
> > > go into settings >> developer
> > > change the 'Update Channel' to nightly-test
> > > 
> > > then back to settings >> device information
> > > and in check update press 'Check Now'
> > > 
> > > When I did this the OTA immediately found new update Build ID 20150828201018
> > 
> > Just a heads-up in this case: be very careful with this this channel:
> > nightly channel does have automatic tests ensuring the build have the
> > minimum working features for a phone daily usage. If minimal requirements
> > are not met, the build isn't offered as an OTA update.
> > 
> > Those tests are not performed on nightly-test, so it can result any day in a
> > non-working phone.
> 
> I followed your steps before, but I can't get past Build ID 20150825201018.
> I get the same result as before this bug was fixed: the update downloads,
> uncompresses but does not install and I see "1 update available" again.

I'm still surprised you get this issue even after a full flash of v18D v4, the one you can see here (https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame#Base_Image) at nightly v4, ie. http://cds.w5v8t3u9.hwcdn.net/v18D_nightly_v4.zip

Just to be sure, what results give you those commands:
adb shell getprop ro.bootloader
adb shell df /system

By the way, the build you mention, 20150825201018, isn't on the nightly channel, either you flashed it, either you use nightly-test channel.
Flags: needinfo?(gmontagu)
(In reply to Clément Lefèvre from comment #53)
> (In reply to Gabriela [:gaby2300] from comment #52)
> > (In reply to Clément Lefèvre from comment #51)
> > > (In reply to David Ross from comment #50)
> > > > Just a heads up for Gabriella & Nick:
> > > > 
> > > > go into settings >> developer
> > > > change the 'Update Channel' to nightly-test
> > > > 
> > > > then back to settings >> device information
> > > > and in check update press 'Check Now'
> > > > 
> > > > When I did this the OTA immediately found new update Build ID 20150828201018
> > > 
> > > Just a heads-up in this case: be very careful with this this channel:
> > > nightly channel does have automatic tests ensuring the build have the
> > > minimum working features for a phone daily usage. If minimal requirements
> > > are not met, the build isn't offered as an OTA update.
> > > 
> > > Those tests are not performed on nightly-test, so it can result any day in a
> > > non-working phone.
> > 
> > I followed your steps before, but I can't get past Build ID 20150825201018.
> > I get the same result as before this bug was fixed: the update downloads,
> > uncompresses but does not install and I see "1 update available" again.
> 
> I'm still surprised you get this issue even after a full flash of v18D v4,
> the one you can see here
> (https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/
> Updating_your_Flame#Base_Image) at nightly v4, ie.
> http://cds.w5v8t3u9.hwcdn.net/v18D_nightly_v4.zip
> 
> Just to be sure, what results give you those commands:
> adb shell getprop ro.bootloader
> adb shell df /system

The results are the following:



* daemon started successfully *
L1TC000118D0

C:\Users\Gabriela>adb shell df /system
Filesystem               Size     Used     Free   Blksize
/system                412.5M   288.1M   124.4M   4096


> 
> By the way, the build you mention, 20150825201018, isn't on the nightly
> channel, either you flashed it, either you use nightly-test channel.

Yes, I used the nightly-test channel as suggested above. Should I use another one then? Would this other one allow me to actually install the update?
Flags: needinfo?(gmontagu)
(In reply to Gabriela [:gaby2300] from comment #54)
> (In reply to Clément Lefèvre from comment #53)
> > (In reply to Gabriela [:gaby2300] from comment #52)
> > > (In reply to Clément Lefèvre from comment #51)
> > > > (In reply to David Ross from comment #50)
> > > > > Just a heads up for Gabriella & Nick:
> > > > > 
> > > > > go into settings >> developer
> > > > > change the 'Update Channel' to nightly-test
> > > > > 
> > > > > then back to settings >> device information
> > > > > and in check update press 'Check Now'
> > > > > 
> > > > > When I did this the OTA immediately found new update Build ID 20150828201018
> > > > 
> > > > Just a heads-up in this case: be very careful with this this channel:
> > > > nightly channel does have automatic tests ensuring the build have the
> > > > minimum working features for a phone daily usage. If minimal requirements
> > > > are not met, the build isn't offered as an OTA update.
> > > > 
> > > > Those tests are not performed on nightly-test, so it can result any day in a
> > > > non-working phone.
> > > 
> > > I followed your steps before, but I can't get past Build ID 20150825201018.
> > > I get the same result as before this bug was fixed: the update downloads,
> > > uncompresses but does not install and I see "1 update available" again.
> > 
> > I'm still surprised you get this issue even after a full flash of v18D v4,
> > the one you can see here
> > (https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/
> > Updating_your_Flame#Base_Image) at nightly v4, ie.
> > http://cds.w5v8t3u9.hwcdn.net/v18D_nightly_v4.zip
> > 
> > Just to be sure, what results give you those commands:
> > adb shell getprop ro.bootloader
> > adb shell df /system
> 
> The results are the following:
> 
> 
> 
> * daemon started successfully *
> L1TC000118D0
> 
> C:\Users\Gabriela>adb shell df /system
> Filesystem               Size     Used     Free   Blksize
> /system                412.5M   288.1M   124.4M   4096
> 
> 
> > 
> > By the way, the build you mention, 20150825201018, isn't on the nightly
> > channel, either you flashed it, either you use nightly-test channel.
> 
> Yes, I used the nightly-test channel as suggested above. Should I use
> another one then? Would this other one allow me to actually install the
> update?

Okay, so that confirm that's the right base image. I didn't performed tests with nightly-test channel, but as stated above, the builds on this channel are not automatically tested are nightly are like with blocking bugs and so on.

Did you have a correct OTA update if after one base image flash you do the OTA right after on nightly channel?
If yes and if you still want to use nightly-test, does is still to have problem if you switch channel *after* doing so?
Flags: needinfo?(gmontagu)
Yes, after flashing the new base image the OTA's worked fine till the build above mentioned.

Yes, after changing channels I still see the problem. Nightly channel shows no new update and nightly-test and nightly-latest have the installing problem.
Flags: needinfo?(gmontagu)
(In reply to Gabriela [:gaby2300] from comment #56)
> Yes, after flashing the new base image the OTA's worked fine till the build
> above mentioned.
> 
> Yes, after changing channels I still see the problem. Nightly channel shows
> no new update and nightly-test and nightly-latest have the installing
> problem.

Maybe an issue with current nightly-test builds, but that's strange if new builds are already too big for the new partition size.

Anyway, I don't know why would this issue be back in this particular situation.

NI nhirata in case he would have any idea on what could make this issue back.

Gabriela, provide a logcat can be useful too.
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(gmontagu)
I'll provide the logcat as soon as possible. Meanwhile I'll NI nhirata.
Flags: needinfo?(gmontagu) → needinfo?(nhirata)
I took the following logcat while downloading and trying to install the update. It downloaded, uncompressed but failed to install just as before the 18D v4 base image was built and I installed it.
I hope it's useful to help understanding the issue!

D/wpa_supplicant( 1000): nl80211: survey data missing!
I/GeckoUpdater( 1933): Progress [ =========================
     ]
I/GeckoUpdater( 1933): Progress [ ==========================
     ]
I/GeckoUpdater( 1933): Progress [ ===========================
     ]
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89978, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
I/Gecko   (  673): AlarmService: add(Mon Aug 31 2015 18:10:54 GMT-0300 (ART))
I/Gecko   (  673): AlarmService: Callback after adding alarm in database.
I/Gecko   (  673): AlarmService: Current alarm: {"date":"2015-08-31T21:10:54.135
Z","ignoreTimezone":true,"timezoneOffset":180,"id":89979}
I/Gecko   (  673): AlarmService: Alarm queue: []
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89979, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
I/GeckoUpdater( 1933): Progress [ ============================
     ]
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
I/Gecko   (  673): AlarmService: add(Mon Aug 31 2015 18:11:00 GMT-0300 (ART))
I/Gecko   (  673): AlarmService: Callback after adding alarm in database.
I/Gecko   (  673): AlarmService: Current alarm: {"date":"2015-08-31T21:11:00.582
Z","ignoreTimezone":true,"timezoneOffset":180,"id":89980}
I/Gecko   (  673): AlarmService: Alarm queue: []
I/GeckoUpdater( 1933): Progress [ =============================
     ]
I/GeckoUpdater( 1933): Progress [ ==============================
     ]
I/GeckoUpdater( 1933): Progress [ ===============================
     ]
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/GeckoUpdater( 1933): Progress [ ================================
     ]
I/GeckoUpdater( 1933): Progress [ =================================
     ]
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89980, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
I/Gecko   (  673): AlarmService: add(Mon Aug 31 2015 18:11:07 GMT-0300 (ART))
I/Gecko   (  673): AlarmService: Callback after adding alarm in database.
I/Gecko   (  673): AlarmService: Current alarm: {"date":"2015-08-31T21:11:07.136
Z","ignoreTimezone":true,"timezoneOffset":180,"id":89981}
I/Gecko   (  673): AlarmService: Alarm queue: []
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/GeckoUpdater( 1933): Progress [ ==================================
     ]
I/GeckoUpdater( 1933): Progress [ ===================================
     ]
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89981, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
I/GeckoUpdater( 1933): Progress [ ====================================
     ]
I/Gecko   (  673): AlarmService: add(Mon Aug 31 2015 18:11:13 GMT-0300 (ART))
I/GeckoUpdater( 1933): Progress [ =====================================
     ]
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
I/GeckoUpdater( 1933): Progress [ ======================================
     ]
I/GeckoUpdater( 1933): Progress [ =======================================
     ]
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/Gecko   (  673): AlarmService: Callback after adding alarm in database.
I/Gecko   (  673): AlarmService: Current alarm: {"date":"2015-08-31T21:11:13.491
Z","ignoreTimezone":true,"timezoneOffset":180,"id":89982}
I/Gecko   (  673): AlarmService: Alarm queue: []
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89982, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/GeckoUpdater( 1933): Progress [ ========================================
     ]
I/Gecko   (  673): AlarmService: add(Mon Aug 31 2015 18:11:20 GMT-0300 (ART))
I/Gecko   (  673): AlarmService: Callback after adding alarm in database.
I/Gecko   (  673): AlarmService: Current alarm: {"date":"2015-08-31T21:11:20.177
Z","ignoreTimezone":true,"timezoneOffset":180,"id":89983}
I/Gecko   (  673): AlarmService: Alarm queue: []
D/charger_monitor(  326): init target 500000
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89983, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
I/GeckoUpdater( 1933): Progress [ =========================================
     ]
I/Gecko   (  673): AlarmService: add(Mon Aug 31 2015 18:11:26 GMT-0300 (ART))
I/Gecko   (  673): AlarmService: Callback after adding alarm in database.
I/Gecko   (  673): AlarmService: Current alarm: {"date":"2015-08-31T21:11:26.694
Z","ignoreTimezone":true,"timezoneOffset":180,"id":89984}
I/Gecko   (  673): AlarmService: Alarm queue: []
I/GeckoUpdater( 1933): Progress [ ==========================================
     ]
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89984, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
I/Gecko   (  673): AlarmService: add(Mon Aug 31 2015 18:11:32 GMT-0300 (ART))
I/Gecko   (  673): AlarmService: Callback after adding alarm in database.
I/Gecko   (  673): AlarmService: Current alarm: {"date":"2015-08-31T21:11:32.827
Z","ignoreTimezone":true,"timezoneOffset":180,"id":89985}
I/Gecko   (  673): AlarmService: Alarm queue: []
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89985, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
I/Gecko   (  673): AlarmService: add(Mon Aug 31 2015 18:11:39 GMT-0300 (ART))
I/Gecko   (  673): AlarmService: Callback after adding alarm in database.
I/Gecko   (  673): AlarmService: Current alarm: {"date":"2015-08-31T21:11:39.031
Z","ignoreTimezone":true,"timezoneOffset":180,"id":89986}
I/Gecko   (  673): AlarmService: Alarm queue: []
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89986, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
I/Gecko   (  673): AlarmService: add(Mon Aug 31 2015 18:11:45 GMT-0300 (ART))
I/GeckoUpdater( 1933): Progress [ ===========================================
     ]
I/Gecko   (  673): AlarmService: Callback after adding alarm in database.
I/Gecko   (  673): AlarmService: Current alarm: {"date":"2015-08-31T21:11:45.170
Z","ignoreTimezone":true,"timezoneOffset":180,"id":89987}
I/Gecko   (  673): AlarmService: Alarm queue: []
I/GeckoUpdater( 1933): Progress [ ============================================
     ]
I/GeckoUpdater( 1933): Progress [ =============================================
     ]
I/GeckoUpdater( 1933): Progress [ ==============================================
=    ]
I/GeckoUpdater( 1933): Progress [ ==============================================
==   ]
I/GeckoUpdater( 1933): Progress [ ==============================================
===  ]
I/GeckoUpdater( 1933): Progress [ ==============================================
==== ]
I/GeckoUpdater( 1933): Finished applying update
I/GonkAutoMounter( 1933): Mounted /system partition as read-only
I/Gecko   (  673): *** AUS:SVC readStatusFile - status: failed: 70, path: /data/
local/updates/0/update.status
I/GeckoConsole(  673): AUS:SVC readStatusFile - status: failed: 70, path: /data/
local/updates/0/update.status
I/Gecko   (  673): UpdatePrompt: Update error, state: failed, errorCode: 70
E/GeckoConsole(  673): [JavaScript Error: "formatURLPref: Couldn't get pref: app
.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFor
matter.js" line: 145}]
W/GeckoConsole(  673): Content JS WARN: L10n Deprecation Warning: using innerHTM
L in translations is unsafe and will not be supported in future versions of l10n
.js. See https://bugzil.la/1027117
W/GeckoConsole(  673):     at translateElement (app://system.gaiamobile.org/gaia
_build_index.js:223:130)
W/GeckoConsole(  673): Content JS WARN: L10n Deprecation Warning: using innerHTM
L in translations is unsafe and will not be supported in future versions of l10n
.js. See https://bugzil.la/1027117
W/GeckoConsole(  673):     at translateElement (app://system.gaiamobile.org/gaia
_build_index.js:223:130)
I/Gecko   (  673): UpdatePrompt: Setting gecko.updateStatus: Install Pending
E/GeckoConsole(  673): [JavaScript Error: "formatURLPref: Couldn't get pref: app
.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFor
matter.js" line: 145}]
E/GeckoConsole(  673): [JavaScript Error: "formatURLPref: Couldn't get pref: app
.update.url.details" {file: "jar:file:///system/b2g/omni.ja!/components/nsURLFor
matter.js" line: 145}]
I/Gecko   (  673): *** AUS:SVC UpdateManager:refreshUpdateStatus - Notifying obs
ervers that the update was staged. state: pending, status: failed: 70
I/GeckoConsole(  673): AUS:SVC UpdateManager:refreshUpdateStatus - Notifying obs
ervers that the update was staged. state: pending, status: failed: 70
I/nsVolumeMountLock(  673): nsVolumeMountLock released for 'sdcard'
I/nsVolume(  673): nsVolume: sdcard state Mounted @ '/storage/sdcard' gen 1 lock
ed 0 fake 0 media 1 sharing 0 formatting 0 unmounting 0 removable 0 hotswappable
 0
I/AutoMounter(  673): AutoMounter state changed from IDLE to UMS_CONFIGURED
I/AutoMounter(  673): UpdateState: ums:A1C1E0 mtp:A1C0E0 mode:0 usb:1 tryToShare
:0 state:UMS_CONFIGURED
I/AutoMounter(  673): UpdateState: Volume sdcard is Mounted and inserted @ /stor
age/sdcard gen 1 locked 0 sharing en-n
I/AutoMounter(  673): UpdateState: Volume sdcard1 is NoMedia and missing
V/WLAN_PSA(  212): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
D/wpa_supplicant( 1000): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 5
0 4f 4c 4c
D/wpa_supplicant( 1000): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant( 1000): nl80211: survey data missing!
I/Gecko   (  673): AlarmService: _onAlarmFired()
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: _notifyAlarmObserver()
I/Gecko   (  673): AlarmService: remove(89987, undefined)
I/Gecko   (  673): AlarmService: _removeAlarmFromDb()
I/Gecko   (  673): AlarmService: Current alarm: null
I/Gecko   (  673): AlarmService: Alarm queue: []
I/Gecko   (  673): AlarmService: Remove alarm from DB successfully.
I/Gecko   (  673): AlarmService: Callback after removing alarm from database.
I/Gecko   (  673): AlarmService: No alarms set.
^C
C:\Users\Gabriela>
(In reply to David Ross from comment #50)
> Just a heads up for Gabriella & Nick:
> 
> go into settings >> developer
> change the 'Update Channel' to nightly-test
> 
> then back to settings >> device information
> and in check update press 'Check Now'
> 
> When I did this the OTA immediately found new update Build ID 20150828201018

I did just that and it worked till I installed build 20150825201018. Then I started hitting this bug again.
If the issue is resolved, at one point please use create a new bug if you are going to have a further discussion about an issue.

It makes it really confusing to follow the discussion esp if the topics are different.  Closed bugs usually aren't tracked either.
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(nick.cumbo)
Duplicate of this bug: 1055922
You need to log in before you can comment on or make changes to this bug.