"Edit this bookmark" popup from star button doesn't restore its height if it was high enough to exceed the screen

RESOLVED DUPLICATE of bug 1247824

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 1247824
3 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

17 Branch
regression
Points:
---
Bug Flags:
firefox-backlog ?

Firefox Tracking Flags

(firefox43 affected)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8654632 [details]
video - 'Edit this bookmark' popup from star button doesn't restore its height if it was high enough to exceed the screen.webm

STR:   (Win7_64, Nightly 43, 32bit, ID 20150830030224, new profile, HWA off)
0. Open http://example.org/
1. Adjust the windows height to be a bit larger than "Edit this bookmark" popup's height
2. Move window to the bottom of screen
3. Click star button in toolbar to open "Edit this bokmark" popup menu
4. Click "Show all boorkmarks folder" arrow to show all bookmarks folder
5. Click "Show all tags" arrow to show all tags
6. Click "Hide" arrow to hide all tags
7. Click "Hide" arrow to show all bookmarks folder

Result:       "Edit this bookmark" popup menu is very high, and if you'll open it in another tab, it
               of course will have the same height
Expectations: It should restore its normal height

Note:         It's very easy to reproduce on HiDPI.
(Reporter)

Updated

2 years ago
Has STR: --- → yes
(Reporter)

Updated

2 years ago
Blocks: 1244854

Comment 1

2 years ago
I can't reproduce on nightly nor Firefox 45 on Linux 1920x1080. Is it still happen on your machine?
Flags: needinfo?(arni2033)
(Reporter)

Comment 2

2 years ago
(In reply to Fred Lin [:gasolin] from comment #1)
> I can't reproduce on nightly nor Firefox 45 on Linux 1920x1080. Is it still happen on your machine?
Please show me a screencast and I'll determine where you're doing wrong step [OR]
follow the steps directly.
Flags: needinfo?(arni2033)

Comment 3

2 years ago
Created attachment 8743194 [details]
blank room

Can reproduce on Mac though :)

Comment 4

2 years ago
looks similar to bug 814565
See Also: → bug 814565

Comment 5

2 years ago
Regression range may be https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9d2a7a8ca1c7&tochange=582d4c67b3a7.
Has Regression Range: --- → no
Component: Menus → Bookmarks & History
Flags: firefox-backlog?
Keywords: regression, regressionwindow-wanted
Version: Trunk → 17 Branch
Managed to reproduce this on Windows 7 x32 on the latest release(45.0.2) and latest Nightly(48.0a1). Based on comment 5, removing the "regressionwindow wanted" keyword.
Keywords: regressionwindow-wanted
Forward duping to 1247824.
No longer blocks: 1244854
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247824
You need to log in before you can comment on or make changes to this bug.