Closed Bug 1200096 Opened 6 years ago Closed 6 years ago

built-in pdf renderer fails again

Categories

(Firefox :: PDF Viewer, defect, P2)

21 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
firefox44 --- verified

People

(Reporter: lloyd.wood, Assigned: Snuffleupagus)

References

Details

(Keywords: regression, Whiteboard: [testday-20151030][pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-regression][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/6407)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Downloaded pdf academic paper from
http://dx.doi.org/10.1109/RAST.2015.7208452



Actual results:

Noted large areas of empty blankness in mozilla's built-in pdf renderer where there should have been two columns of text.


Expected results:

Paper should have been as readable as it was in Acrobat Reader.
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Could you please attach the actual file exposing this behavior?
Flags: needinfo?(lloyd.wood)
Component: Untriaged → PDF Viewer
Priority: -- → P3
Whiteboard: [pdfjs-f-needinfo]
Flags: needinfo?(lloyd.wood)
cmap issues:

PDF 95fc10bd97106243b0d40fba1395cbf7 [1.4 Microsoft® Word 2013 / Microsoft® Word 2013] (PDF.js: 1.1.403) viewer.js:6645:1
Error: cmap table has unsupported format: 2 pdf.worker.js:232:5
readCmapTable@resource://pdf.js/build/pdf.worker.js:17207:11
Font_checkAndRepair@resource://pdf.js/build/pdf.worker.js:18013:25
Font@resource://pdf.js/build/pdf.worker.js:16461:16
PartialEvaluator_translateFont@resource://pdf.js/build/pdf.worker.js:11962:14
PartialEvaluator_loadFont@resource://pdf.js/build/pdf.worker.js:10712:1
PartialEvaluator_handleSetFont@resource://pdf.js/build/pdf.worker.js:10484:14
next@resource://pdf.js/build/pdf.worker.js:10877:22
next/<@resource://pdf.js/build/pdf.worker.js:11030:19
promise callback*next@resource://pdf.js/build/pdf.worker.js:11028:1
PartialEvaluator_getOperatorList@resource://pdf.js/build/pdf.worker.js:10810:1
promise callback*Page_getOperatorList@resource://pdf.js/build/pdf.worker.js:2184:29
promise callback*wphSetupRenderPage@resource://pdf.js/build/pdf.worker.js:33913:7
messageHandlerComObjOnMessage@resource://pdf.js/build/pdf.worker.js:1210:9
EventHandlerNonNull*MessageHandler@resource://pdf.js/build/pdf.worker.js:1172:3
pdfjsWrapper@resource://pdf.js/build/pdf.worker.js:34027:17
@resource://pdf.js/build/pdf.worker.js:28:1
 pdf.worker.js:233:1
Warning: Unsupported feature "unknown" pdf.worker.js:224:5
Warning: Unsupported feature "unknown" pdf.js:224:5
Warning: Unsupported feature "font" pdf.worker.js:224:5
Warning: Unsupported feature "font" pdf.js:224:5
Warning: Error during font loading: cmap table has unsupported format: 2 pdf.js:224:5
it regressed:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bc108d2ce8d1&tochange=04e13fc9dbff

Ryan VanderMeulen — Bug 835954 - Update pdf.js to version 0.7.180. r=yury
Blocks: 835954
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: 40 Branch → 21 Branch
This regressed upstream in PR https://github.com/mozilla/pdf.js/pull/2606.
Assignee: nobody → jonas.jenwald
Priority: P3 → P2
Whiteboard: [pdfjs-f-needinfo] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-regression]
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-regression] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-regression][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/6407
Depends on: 1205051
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Duplicate of this bug: 1207776
QA Whiteboard: [good first verify]
¡Hola!

https://bug1200096.bmoattachments.org/attachment.cgi?id=8655177 looks fine on 44.0a2 (2015-10-30)

¡Gracias!
Alex
Status: RESOLVED → VERIFIED
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-regression][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/6407 → [testday-20151030][pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-regression][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/6407
You need to log in before you can comment on or make changes to this bug.