Pinch zoom gesture does not always appear to work when C++APZ is enabled.

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: rbarker, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

2 years ago
The NYT.com desktop page has a scrollable div along the right side of the page. The pinch zoom gesture does not appear to work when C++APZ is enabled. The same action works as expect in nightly with Java APZ.
(Reporter)

Updated

2 years ago
Blocks: 776030
Please re-test to see if this still happens with the latest fixes, and if it does, see if you can make a reduced test case for it. Thanks!
Blocks: 1206872
snorp discovered that the scrollable div along the right side of nytimes.com has a touch listener and implements its own scrolling. So any touches in that area don't go through the APZ machinery, and not being able to zoom there is expected behaviour.
After discussion with Randall this may also have been due to an older version of the event untransformation code which didn't take the resolution into account properly. Closing as WFM since it seems to be ok now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.