If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't make the 'add to Reading List' icon appear

RESOLVED FIXED

Status

()

Firefox for iOS
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kar, Assigned: sleroux)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios1.0.5+)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Running build 43 on iOS 8 on my iPhone 6

Go to wikipedia or something and look at an article

I see the 'Reader View' icon in the URL bar. I tap on that and I see the article in Reader View.

However for the life of me, I can't make the 'add to Reading List' icon appear. I had it flicker at some point, but don't ask me how. In fact, there is *no* Reader View icon either, which means I can't get 'out' of Reader View.

Therefore the bug description may need to change depending on the problem, but there are definitely two problems here.

(Then there will be a navigation point, ie when I press 'back' I go back a page instead of out of Reader View which is how we manage the navigation on Android, but we can cross that bridge later.)
I see issues with https://mail.mozilla.org/pipermail/mobile-firefox-dev/2015-August/001451.html
(Assignee)

Updated

2 years ago
tracking-fxios: ? → 1.0.5+
Karen, can you please add a few links to this bug where this happens?
Flags: needinfo?(krudnitski)
(Reporter)

Comment 3

2 years ago
https://en.m.wikipedia.org/wiki/Little_Bunny_Foo_Foo
www.bbc.co.uk/news/world-europe-34113471

(although when trying to find a link to make this work, I stumbled on www.dkrisel.com/en/blog/2013/0802_xerox-workcentres_are_switching_written_numbers_when_scanning and that worked)
Flags: needinfo?(krudnitski)
(In reply to Karen Rudnitski [:kar] from comment #3)
> https://en.m.wikipedia.org/wiki/Little_Bunny_Foo_Foo
> www.bbc.co.uk/news/world-europe-34113471

I can see the Add to Reading List button in our toolbar fine. Tested on master.
Assignee: nobody → sarentz
Status: NEW → ASSIGNED
All sites that Karen mentioned should just work. I think there is something bigger happening, possibly related to our internal web server. Trying to produce a good STR.
(Reporter)

Comment 6

2 years ago
Created attachment 8657038 [details]
screenshot referenced in comment 6
(Reporter)

Comment 7

2 years ago
Ok, I have another example here that may provide more clues.

I went to techcrunch.com and scrolled down to the 'latest' and tapped on the 'Mozilla Drops First Public Preview Of Firefox For iOS' article.

It loaded, but the URL bar still states 'techcrunch.com' and hasn't loaded the exact article page (see attached screenshot as comment 6).

when I tap the RV icon, I see the progress bar, but then no change except that any icon in the URL bar disappears. 

If it also helps, I'm on 8.4.1.
(In reply to Karen Rudnitski [:kar] from comment #7)
> Ok, I have another example here that may provide more clues.
> 
> I went to techcrunch.com and scrolled down to the 'latest' and tapped on the
> 'Mozilla Drops First Public Preview Of Firefox For iOS' article.
> 
> It loaded, but the URL bar still states 'techcrunch.com' and hasn't loaded
> the exact article page (see attached screenshot as comment 6).
> 
> when I tap the RV icon, I see the progress bar, but then no change except
> that any icon in the URL bar disappears. 
> 
> If it also helps, I'm on 8.4.1.

Now that I read this, I'm interpreting this bug differently and it's sounding like bug https://bugzilla.mozilla.org/show_bug.cgi?id=1183075
(Assignee)

Comment 9

2 years ago
Now that I read this, it's starting to sound like https://bugzilla.mozilla.org/show_bug.cgi?id=1201592 :)
(Reporter)

Comment 10

2 years ago
Steph - that refers to the app being backgrounded, no? Which in my case it wouldn't be? (asking, because I don't know and/or you're thinking that bug may resolve a larger issue)
(Assignee)

Comment 11

2 years ago
It could be the case that you were previously using the, put the phone down for the bit and reopened it and saw it not working after that. This could also explain the infrequency of the bug. For example, if you navigate to a site that does work for reader view, then background the app or lock the phone then reopen it, it won't work the second time on the same site.
(Reporter)

Comment 12

2 years ago
that would be a false assumption.

This is me taking my phone in hand, navigating to the site, letting it load, pressing the RV icon, seeing the page 'load' but then nothing happen from that point on. Device still in hand.

Have done the exact same thing just navigating to wikipedia, tapping on the 'article of the day' (hemmema), and this time the full URL loads, yet not the article in RV (and the icon disappears).

Any logs that I could take? ... rnewman is in London next week and I could hand him my phone unless you want to tell me what to do in xcode.
(Assignee)

Comment 13

2 years ago
I was just able to produce this on another tech crunch article: http://techcrunch.com/2015/05/21/firefox-for-ios-begins-its-beta-testing-program/#.ib0hwl:wYYx but only some of the time. I haven't been able to get a steady STR but I think I can reproduce it enough to investigate. :st3fan, mind if I take this one unless you have better STR?
Flags: needinfo?(sarentz)
(Assignee)

Comment 14

2 years ago
Interestingly I'm able to reproduce this 100% of the time when following the same STR as this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1194501. It looks like what's happening is that because the web server no longer accepts connects, it's not displaying the reader version of the page. The reason the icon still disappears is because that code lives in the user script which runs on the current page. I'm just about to land the patch that will fix that bug so we should do a test flight next week and see if we can still reproduce this after that fix as has landed.
(In reply to Karen Rudnitski [:kar] from comment #12)
> that would be a false assumption.
> 
> This is me taking my phone in hand, navigating to the site, letting it load,
> pressing the RV icon, seeing the page 'load' but then nothing happen from
> that point on. Device still in hand.

That's the behavior I see in Comment 1. It's exactly as if we load the same page again, but with no reader controls and no reader icon. If that's what you mean by this bug, Karen, then I guess I can repro weirdness myself without having to shoulder-surf :D

If you mean something else, then let's split bugs!
Assignee: sarentz → sleroux
(Assignee)

Comment 16

2 years ago
Marking https://bugzilla.mozilla.org/show_bug.cgi?id=1194501 as a dependent issue to see if that fixes this issue. I'll keep this bug open in case that it doesn't and we can track the work to resolve any additional fixes here.
Depends on: 1194501
I'm pretty confident that https://bugzilla.mozilla.org/show_bug.cgi?id=1201592 will fix this.
Flags: needinfo?(sarentz)
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.