Closed Bug 1201084 Opened 4 years ago Closed Last year

Selection of messages cannot be moved to subfolders (maildir, starting with TB 38)

Categories

(Thunderbird :: Folder and Message Lists, defect, major)

38 Branch
x86_64
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: romuald.poteau, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 2015082600

Steps to reproduce:

I wanted to manually (I mean, with the mouse) move messages to a subfolder


Actual results:

It works with a unique message, but not with several ones. They remain in the inbox folder. I have repaired the folder, but that does not change anything. They actually stay in the Inbox. Moving one message and then trying to move a slection of two (or more) messages to the same folder by using the "moveto again" item of the contextual menu does not improve it. 


Expected results:

They should have moved to the target subfolder.
(Most of junk mails also stay in the Inbox - could it be related?)
Severity: normal → major
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Does it fail also in safe mode? 
https://support.mozilla.org/en-US/kb/safe-mode
Flags: needinfo?(romuald.poteau)
Whiteboard: [closeme 2015-10-20]
Yes. I checked that before mentioning the bug on this website, in order to be sure that it was not a bad behavior of an add-on
Flags: needinfo?(romuald.poteau)
Does it fail also with drag and drop?
Whiteboard: [closeme 2015-10-20]
There are several ways to move selected mails to a folder.
1. Message menu(via. Customize Toolbar, Show Menubar)
   (a) Request specific move target folder (b) Move again, Last folder, ... 
2. Context menu of selected messages
   (a) Request specific move target folder (b) Move again, Last folder, ...
3. Drag&Drop

Does problem occurs in any case?

Does problem occur even after "Repair Folder of the "move target folder" is executed?

Does ptoblem occur with next setting?
> mail.operate_on_msgs_in_collapsed_threads=false
> accessibility.force_disabled=1

If problem still occurs, does problem occur even after re-boot of PC?

FYI.
Similar phenomenon as yours was reported to a forum recently.
On Mac OS X, move of single mail by Drag&Drop works, but move of two mails by Drag&Drop doesn't work. Move via. Messaage menu works even when many mails are selected. And, after re-boot of Mac, problem disappered.
Previous tests at the very beginning of September were done with all add-ons disabled and also with add-ons active. Drag&drop did not work, neither the context menu, neither move again after successful move of a single mail. I also repaired the involved folders. I forgot to mention that I use the maildir format.

Actually, now it works again with drag&drop, with the last available version, 38.3.0-2.1, built on September 29th, that I installed a couple of days ago. On top of that, junk e-mails are now again automatically moved to the Junk folder, as configured in the settings.
(In reply to romuald.poteau from comment #5)
> I forgot to mention that I use the maildir format.

Bug 1152651 is a problem in maildir.
Many known problems are listed in dependency tree for meta Bug 859011. If maildir related problem, search bugzilla well for "Maildir in Bug Summary" and check dependency tree for that meta bug before bug open, please.
romulad, does this still reproduce for you?
Flags: needinfo?(romuald.poteau)
Summary: Selection of messages cannot be moved to subfolders (starting with TB 38) → Selection of messages cannot be moved to subfolders (maildir, starting with TB 38)
Mark, you still doing maildir?  If so, can you reproduce this?
Flags: needinfo?(MarkFilipak.mozilla)
Yes, I exclusively use maildir. I move messages to subfolders using just about every method that exists. And, when I move them, I move them from TBird running in Linux running in a VM to real disk hardware in the Win10 Host. I've had no problems whatsoever.
Flags: needinfo?(MarkFilipak.mozilla)
Thanks Mark!  The reporter seems to be gone, or not interested in responding.   So on the strength of your experience let's declare this dead.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Flags: needinfo?(romuald.poteau)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.