[Dialer] When dialing a number in keypad, only first tone will sound.

RESOLVED DUPLICATE of bug 1183033

Status

()

RESOLVED DUPLICATE of bug 1183033
3 years ago
3 years ago

People

(Reporter: vbelonenko, Unassigned)

Tracking

({foxfood, regression})

unspecified
ARM
Gonk (Firefox OS)
foxfood, regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark][2.5-aries-test-run-2], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8656064 [details]
logcat_20150902_0922.txt

Description:
User dials a number, he can only hear first audio tone.


Repro Steps:
1) Update a Aries to 20150902124951
2) Launch a dialer  
3) Press two numbers
4) Observe audio as you dial numbers.


Actual:
Observe that Audio only plays in first number.


Expected:
When dialing a number, Audio Tone should dial the whole number with audio tone.

Environmental Variables:
Device: Aries 2.5 kk Full Flash (319mb)
Build ID: 20150902124951
Gaia: e2fab8f6ac345ecde10a1350e699be9ceb6987d6
Gecko: 1b687fcb5213153855c7ac0f8392ce0a4a7e3382
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 3/3
See attached: Video and Logcat.
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → affected
Keywords: regression
(Reporter)

Comment 1

3 years ago
This issue also occurs on Flame 2.5

Environmental Variables:
Device: Flame 2.5 kk Full Flash (319 mb)
Build ID: 20150902043009
Gaia: e2fab8f6ac345ecde10a1350e699be9ceb6987d6
Gecko: f36760e839103199071e82546e31d8019c232cdf
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

-------------------------------------------------------------------
This issue does not occur on Flame 2.2

Environmental Variables:
Device: Flame 2.2 kk Full Flash (319 mb)
Build ID: 20150901123002
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: c03e2bc6a3a4
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted

Updated

3 years ago
QA Contact: mshuman
Adding foxfood as I see this on the Z3 as well.
Keywords: foxfood
This issue appears to be caused by:
Bug 1184058 - AudioChannelAgent should be muted when used without a proper window object.

Mozilla-inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150901031123
Gaia: c80e8ff25425b007181fd6e3de0500a0358fab37
Gecko: bd50f52c3bbea98ad78f75b27ec2f730e09b901f
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150901032723
Gaia: c80e8ff25425b007181fd6e3de0500a0358fab37
Gecko: ddc08e87843f8578adb0ba42887f66044358d563
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working gaia / First Broken gecko - Issue DOES reproduce
Gaia: c80e8ff25425b007181fd6e3de0500a0358fab37
Gecko: ddc08e87843f8578adb0ba42887f66044358d563

First Broken gaia / Last Working gecko - Issue does NOT reproduce
Gaia: c80e8ff25425b007181fd6e3de0500a0358fab37
Gecko: bd50f52c3bbea98ad78f75b27ec2f730e09b901f

Gaia Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bd50f52c3bbea98ad78f75b27ec2f730e09b901f&tochange=ddc08e87843f8578adb0ba42887f66044358d563
Blocks: 1184058
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Andrea this issue was caused by the changes for bug 1184058.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(amarchesini)
Regression that will lead to certification blocker.
blocking-b2g: 2.5? → 2.5+
Component: Gaia::Dialer → DOM
Product: Firefox OS → Core

Comment 7

3 years ago
After applying the patch in bug1183033, this issue would be solved.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183033
Flags: needinfo?(amarchesini)

Updated

3 years ago
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][2.5-aries-test-run-2]
You need to log in before you can comment on or make changes to this bug.