test_keyboard.py: NoSuchElementException: NoSuchElementException: Unable to locate element: details-view-header

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: NicholasN, Assigned: Martijn Wargers (zombie))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Description:

This test fails after text has been entered in to a new contact. A sting of text is typed in the comment field, and then the contact is saved. It may be failing for the same reason as https://bugzil.la/1201211, although the traceback appears different.

Steps:
1. Update a flame device to 20150902030203.
2. Open contacts and add a new contact.
3. Fill in the phone number field.
4. Fill in the comment field using a string of text with special characters.
5. Save the contact by tapping "Done".

Actual Result:
Test fails after saving contact.

Expected Result:
Test completes when the contact is saved.

Repro Rate: 4/5 in Jenkins adhoc, not reproduced manually.

Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@4/.env/lib/python2.7/site-packages/marionette_client-0.17-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@4/tests/python/gaia-ui-tests/gaiatest/tests/functional/keyboard/test_keyboard.py", line 41, in test_keyboard_basic
contact_details = contacts_app.contacts[0].tap()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@4/tests/python/gaia-ui-tests/gaiatest/apps/contacts/app.py", line 140, in tap
return self._return_class_from_tap(return_class)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@4/tests/python/gaia-ui-tests/gaiatest/apps/contacts/app.py", line 151, in _return_class_from_tap
return ContactDetails(self.marionette)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@4/tests/python/gaia-ui-tests/gaiatest/apps/contacts/regions/contact_details.py", line 28, in __init__
el = self.marionette.find_element(*self._details_header_locator)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@4/.env/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/marionette.py", line 1579, in find_element
el = self._send_message("findElement", body, key="value")
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@4/.env/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@4/.env/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/marionette.py", line 711, in _send_message
    self._handle_error(resp)
  File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace@4/.env/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/marionette.py", line 752, in _handle_error
    raise errors.lookup(error)(message, stacktrace=stacktrace)
NoSuchElementException: NoSuchElementException: Unable to locate element: details-view-header
(Assignee)

Comment 1

3 years ago
The failure you posted here is from bug 1201255, which should be fixed by now.
But then you'll encounter bug 1201211.
Assignee: martijn.martijn → nobody
Depends on: 1201211
(Assignee)

Comment 2

3 years ago
We have a workaround for bug 1201211, which we also should use for here, because we're currently getting failures in this test because of bug 1201211:
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/285/HTML_Report/
(Assignee)

Updated

3 years ago
Assignee: nobody → martijn.martijn
(Assignee)

Comment 4

3 years ago
Actually, it's better to put this workaround in the app.py object, so the workaround is not needed in individual tests.
(Assignee)

Comment 6

3 years ago
I've merged this because I think this might also fix bug 1204988.
https://github.com/mozilla-b2g/gaia/commit/1d215ca2c086fd738073a7232297a7e39d2a0c66

John, if you think there's anything wrong with the patch, I can still adjust afterwards.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Blocks: 1204988
(Assignee)

Updated

3 years ago
Blocks: 1205071
You need to log in before you can comment on or make changes to this bug.