cannot view MyEBay on eBay.com, strange save dialog

RESOLVED DUPLICATE of bug 120113

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 120113
17 years ago
14 years ago

People

(Reporter: Leston Buell, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
As of Linux trunk build 2002-01-15-06, i cannot view the MyEbay page on
<http://cgi1.ebay.com/aw-cgi/eBayISAPI.dll?MyEbayLogin>. When i click on the
link, i get a save dialog that says:

   You have chosen to download a file of type "#1" [#2] from
   
   What should Mozilla do with this file?
      Open using #1...

I had no problem viewing these pages with a 2002-01-11 build. I can still view
this page from an earlier build. I will upload an image of the strange save
dialog. Note how the area under the first line (after "from"), where the URL
should be displayed, is blank. Marking major because it's eBay.
(Reporter)

Comment 1

17 years ago
Created attachment 65065 [details]
strange save dialog

Comment 2

17 years ago
I just saw this same dialog at http://www.ual.com (United Airlines).  This
happened once out of three tries at loading the page.

Tested with Mozilla trunk build 2002-01-15-03 on Win2000.
(Reporter)

Comment 3

17 years ago
The precise URL for United Airlines that triggers this is:
   <http://www.ual.com/index/SiteSearch>

Changing platform to ALL. This seems pretty important, since it prevents viewing
pages on some high-profile sites.
OS: Linux → All

Comment 4

17 years ago
Precisely, the url was <http://www.ual.com>.
(Reporter)

Comment 5

17 years ago
Do you mean that you get the dialog when you try to go to <http://www.ual.com>?
I don't. However, when i go there, i do get the dialog by clicking on "Search
Site" in the upper right-hand corner of that page.
(Reporter)

Comment 6

17 years ago
Hmmm... It seems that this is not *always* reproducible, just *almost* always.
After trying the United Airlines "search site" link, the page successfully
loaded about two times out of ten trials. However, i've tried to load the eBay
URL about forty times and it has never succeeded.

Comment 7

17 years ago
CONFIRM, same problem with me Linux build 2002 01 15, not possible to login to
Ebay, wheter ebay.de nor ebay.com

http://cgi1.ebay.de/aw-cgi/eBayISAPI.dll?MyEbayLogin

Mozilla 2002 01 11 still works, tested as I have it lying around here.
Pulled the 2002 01 15 tree this morning around 11:00 am PST when SeaMonkey was
closed and the tinderboxen were green.

Comment 8

17 years ago
I got it on the home page (the url I indicated), but only once so far.  I tried
Search Site and did not get it.

When I try the EBay link, I always get the download dialog, but it has
"Application Extension" for #1 and "application/x-msdownload" for #2. (On the
UAL site I did get the template dialog with #1 and #2).  I do not think we
should be getting the download dialog at all.  The web server is returning 302,
and that may be trigerring the dialog.  The link works fine in IE6 and NN4, however.

Here is the conversation as reported by wget:

C:/usr/junk/xx> wget  http://cgi1.ebay.com/aw-cgi/eBayISAPI.dll?MyEbayLogin
--16:10:12--  http://cgi1.ebay.com/aw-cgi/eBayISAPI.dll?MyEbayLogin
           => `eBayISAPI.dll?MyEbayLogin'
Connecting to cgi1.ebay.com:80... connected!
HTTP request sent, awaiting response... 302 Object Moved
Location: http://cgi3.ebay.com/aw-cgi/eBayISAPI.dll?SignIn&UsingSSL=0&pUserId=&r
u=http%3A%2F%2Fcgi1.ebay.com%2Faw-cgi%2FeBayISAPI.dll%3FMyEbayLogin%26pass%3D%7B
_pass_%7D%26userid%3D&pp=pass&pageType=174&i1=0 [following]
--16:10:15--  http://cgi3.ebay.com/aw-cgi/eBayISAPI.dll?SignIn&UsingSSL=0&pUserI
d=&ru=http%3A//cgi1.ebay.com/aw-cgi/eBayISAPI.dll?MyEbayLogin&pass=%7B_pass_%7D&
userid=&pp=pass&pageType=174&i1=0
           => `eBayISAPI.dll?SignIn&UsingSSL=0&pUserId=&ru=http://cgi1.ebay.com/
aw-cgi/eBayISAPI.dll?MyEbayLogin&pass={_pass_}&userid=&pp=pass&pageType=174&i1=0
'
Connecting to cgi3.ebay.com:80... connected!
HTTP request sent, awaiting response... 400 Bad Request
16:10:36 ERROR 400: Bad Request.

I think maybe there are two separate bugs here, but who knows?

Comment 9

17 years ago
I think this is a blocker....major site that doesn't work at all!

I would like to mark this confirmed, but I can't
(Reporter)

Comment 10

17 years ago
Wow, it's wrse than i thought. Now i see that you can't even view any eBay
items. Upgrading severity to critical. To see that, go to any eBay product
category, such as 
<http://listings.ebay.com/aw/plistings/list/all/category3715/index.html?ssPageName=CompLaptpMB5>
and trying clicking on any listed item.
Severity: major → critical

Comment 11

17 years ago
Confirming on Windows 98, 0.9.7, Build ID:  2002011503.

For some reason Mozilla wants to save the file "eBayISAPI.dll."

Actual behavior: Can't login. 

Expected behavior: Can login.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Major site sucks and breaks the HTTP protocol, sending no content-type header. 
Duplicate of "files with unknown content type trigger horked download dialog"

*** This bug has been marked as a duplicate of 120113 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.