Version Registry: Duplicate entries for absolute pathname registryname

RESOLVED WONTFIX

Status

defect
P3
normal
RESOLVED WONTFIX
20 years ago
3 years ago

People

(Reporter: jimmykenlee, Assigned: dveditz)

Tracking

Trunk
Future
All
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Build: 8/17/99 SeaMonkey build

1. From http://jimbob/trigger2.html, trigger f_adddirectory_regname_absolute.jar

Install.StartInstall("Functional: f_adddirectory_regname_absolute",
"f_adddirectory_regname_absolute", vi, 0);
f = Install.GetFolder("Program", "f_adddir_regname_absolute");
Install.AddDirectory("/" + regName, vi, jarSrc, f, jarSrc, true);

RESULT:
The directory is installed gracefully.  The Install.log records as expected.
The Version registry shows a node at
Version Registry/f_adddirectory_regname_absolute/ as expected.

There also exists a node at
Version Registry/Netscape/Communicator #/f_adddirectory_regname_absolute and
shows only a Version.

EXPECTED RESULT:
There is no node at
Version Registry/Netscape/Communicator #/f_adddirectory_regname_absolute
Assignee: cathleen → dveditz
assigning to Dan.
Target Milestone: M11
set target mileston to M11 per today's meeting
*** Bug 14800 has been marked as a duplicate of this bug. ***
Blocks: 14902
Status: NEW → ASSIGNED
Target Milestone: M11 → M12
Target Milestone: M12 → M13
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Target Milestone: M13 → M14
change to REMIND.
bug meeting 3/20
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → REMIND
REMIND is deprecated per bug 35839.
Status: RESOLVED → REOPENED
Resolution: REMIND → ---
->default
Status: REOPENED → NEW
retargeting
Target Milestone: M14 → Future
Test case can be triggered from
http://www.mozilla.org/quality/smartupdate/xpinstall-trigger.html
Select f_adddir_regname_absolute from the Functional Test Case menu.
The xpinstall script engine has been removed from the trunk, bugs in it are obsolete.
Status: NEW → RESOLVED
Closed: 20 years ago12 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.