Version Registry: Duplicate node appears after patching

RESOLVED WONTFIX

Status

P3
major
RESOLVED WONTFIX
20 years ago
3 years ago

People

(Reporter: jimmykenlee, Assigned: dveditz)

Tracking

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Build: 9/24/99 SeaMonkey build

1. From http://jimbob/trigger2.html, click drop-down button and select
   f_addwinpatch_exe and click Trigger case button to install file to be
   patched
2. From http://jimbob/trigger2.html, click drop-down button and select
   f_winpatch_exe and click Trigger case button to patch

var regName = "f_winpatch.exe";
var jarSrc = "charmap.exe.gdf";
var vi = "1.0.1.11";

Install.StartInstall("Functional: f_winpatch_exe", "f_winpatch_exe", "1.0.1.11",
0);
f = Install.GetFolder("Program", "f_winpatch_exe");
err = Install.Patch(regName, vi, jarSrc, f, "clock.exe", true);
Install.LogComment("Install Patch = " + err);

RESULT:
File on disk appears to be patched correctly.  The Install.log is accurate in
describing the patching.  A dump of the Version registry shows the following:

Subtree Dump of /Version Registry/Netscape/Communicator #20
--------------------------------
f_winpatch_exe
    Version (S)=1.0.1.11
f_winpatch_exe/f_winpatch.exe
    Path (F)=C:/Program Files/moz924/x86rel/f_winpatch_exe/clock.exe
    Version (S)=1.0.1.11
f_winpatch_exe/f_winpatch_exe
    RefCount (S)=1
    Path (F)=C:\Program Files\moz924\x86rel\f_winpatch_exe\clock.exe
    Version (S)=1.0.1.10

EXPECTED RESULT:
There is only one leaf node that corresponds to the patched file.  Notice the
use of "/" versus "\" in the Path.  Can this be part of the reason?

Updated

20 years ago
Target Milestone: M11

Comment 1

20 years ago
possible dup of 12020

Updated

19 years ago
Depends on: 12020

Updated

19 years ago
Blocks: 17432

Updated

19 years ago
Assignee: cathleen → dveditz
Target Milestone: M11 → M12

Comment 2

19 years ago
reassign to dveditz.  possible dup of his bug 12020

Updated

19 years ago
Blocks: 17907

Updated

19 years ago
Blocks: 18471
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12 → M13

Comment 3

19 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M15
(Assignee)

Updated

19 years ago
Target Milestone: M15 → M17

Comment 4

19 years ago
we don't register individual files anymore.
push out to M30
Target Milestone: M17 → M30
(Assignee)

Comment 5

19 years ago
Taking advantage of new "Future" target milestone.
Target Milestone: M30 → Future

Updated

19 years ago
No longer blocks: 17432

Updated

19 years ago
No longer blocks: 17907

Updated

19 years ago
No longer blocks: 18471

Comment 6

17 years ago
*** Bug 156292 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

11 years ago
The xpinstall script engine has been removed from the trunk, bugs in it are obsolete.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.