Closed Bug 1202217 Opened 6 years ago Closed 6 years ago

[Contacts][NGA][Detail] Merge contact B to contact A, but the contact B is also displayed.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S7 (18Sep)
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: yue.xia, Assigned: borjasalguero)

References

Details

(Keywords: regression, Whiteboard: [NG Gaia Contacts][patch][2.5-aries-test-run-2][patch])

Attachments

(4 files)

[1.Description]:
[Aries KK v2.5][Flame KK v2.5][Contacts]Merge contact B to contact A, but the contact B is also displayed, tap contact B, a blue blank screen is displayed.
See attachment: logcat_AriesKK2.5_0104.txt & AriesKK2.5_video1.3gp
Found time: 01:04

[2.Testing Steps]: 
Precondition: In the address book there should be two contacts fulfilling one of the matching rules (i.e: contact A and contact B have the same phone number)
1. Launch Contacts app 
2. Select contact A and open the details view 
3. Tap on 'Find duplicate contacts' option
4. Tap on 'Merge with 1 contact'
5. Tap Back icon and go back to Contacts list screen.

[3.Expected Result]: 
5. Only contact A should be displayed and the contact B information merged to contact A successfully .

[4.Actual Result]: 
5. But the contact B is also displayed, tap contact B, a blue blank screen is displayed.

[5.Reproduction build]: 
Device: Aries KK v2.5 (Affected)
Build ID               20150905112803
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150905.105729
Firmware Date          Sat Sep  5 10:57:37 UTC 2015
Bootloader             s1

Device: Flame KK v2.5 (Affected)
Build ID               20150905150219
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.183746
Firmware Date          Sat Sep  5 18:38:03 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.2 (Unaffected)
Build ID               20150905032501
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d3cb4f28c735
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.065255
Firmware Date          Sat Sep  5 06:53:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
9857

[8.Note]:
After killing Contacts app, enter Contacts app again, the contact B will disappear and the contact A detail information is correct.
Attached video AriesKK2.5_video1.3gp
QA Contact: lixia
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150819054940
Gaia Revision          fa32b801f6d854e846ea8294dc37840450d36c1e
Gaia Date              2015-08-19 12:01:44
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150820.183055
Firmware Date          Thu Aug 20 18:31:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150819061537
Gaia Revision          b57de4c493b611dc70c27c7d78445fcb04b1491c
Gaia Date              2015-08-19 12:27:22
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150806.135403
Firmware Date          Thu Aug  6 13:54:17 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          b57de4c493b611dc70c27c7d78445fcb04b1491c
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb

First Broken Gecko & Last Working Gaia - issue DOES NOT repro
Gaia Revision          fa32b801f6d854e846ea8294dc37840450d36c1e
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/fa32b801f6d854e846ea8294dc37840450d36c1e...b57de4c493b611dc70c27c7d78445fcb04b1491c

Possibly caused by Bug 1183727.
QA Whiteboard: [MGSEI-Triage+]
Hi Borja,

    This bug is probably caused by Bug 1183727, could you help to check?  

Thank you.
Flags: needinfo?(borja.bugzilla)
Based on the STR described in comment 1:
> 1. Launch Contacts app 
> 2. Select contact A and open the details view 
> 3. Tap on 'Find duplicate contacts' option
> 4. Tap on 'Merge with 1 contact'
> 5. Tap Back icon and go back to Contacts list screen.

Step (5) should not exist (actually I can not reproduce it!), because after tapping in 'Merge with 1 contact' it's automatically redirected to the list...

Could you record
Assignee: nobody → borja.bugzilla
Flags: needinfo?(borja.bugzilla)
Update: I can reproduce the STR based on the VIDEO. I hope to have a patch asap. Thanks!
Status: NEW → ASSIGNED
Target Milestone: --- → FxOS-S7 (18Sep)
Summary: [Contacts]Merge contact B to contact A, but the contact B is also displayed. → [Contacts][NGA][Detail] Merge contact B to contact A, but the contact B is also displayed.
Attachment #8657795 - Flags: review?(francisco)
Whiteboard: [2.5-aries-test-run-2] → [2.5-aries-test-run-2][patch]
Comment on attachment 8657795 [details] [review]
[gaia] borjasalguero:fix_merge_detail > mozilla-b2g:master

Tried on the phone, working pretty nice. Thanks.
Attachment #8657795 - Flags: review?(francisco) → review+
Blocks: 1183727
Whiteboard: [2.5-aries-test-run-2][patch] → [NG Gaia Contacts][patch][2.5-aries-test-run-2][patch]
[Blocking Requested - why for this release]:regression, broken functionality
blocking-b2g: --- → 2.5?
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: 2.5? → ---
Tested in latest master build (9/9) and I cannot reproduce the issue. Thanks a lot Borja!

Environmental Variables (9/9):
flame master (2.5 version)
Build ID: 20150909070122
Gecko: eea972e
Gaia: 404a35a
Platform version: 43.0a1
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aries KK 2.5 by the STR in comment 0.

Actual results: Only contact A can be displayed and the information of contact B can be merged to contact A correctly.
See attachment: Verify_Aries_KK2.5.3gp
Reproduce rate: 0/10

Device: Flame KK 2.5 (Pass)
Build ID               20150909150223
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150909.185733
Firmware Date          Wed Sep  9 18:57:43 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20150909215153
Gaia Revision          47459eead04385e22f967012b824f5abdddcfb7c
Gaia Date              2015-09-09 10:37:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd2a1d737a64d9a3f23714ec5cc623ec8933b51f
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150909.211310
Firmware Date          Wed Sep  9 21:13:17 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
Keywords: verifyme
Attached video Verify_AriesKK_2.5.3gp
You need to log in before you can comment on or make changes to this bug.