Closed Bug 1202244 Opened 6 years ago Closed 6 years ago

Logging in to existing box.com account fails to close window (eternal throbber), setup of account fails

Categories

(Thunderbird :: FileLink, defect)

defect
Not set
normal

Tracking

(thunderbird40 affected, thunderbird41 affected, thunderbird42 affected, thunderbird43 affected, thunderbird_esr31 unaffected, thunderbird_esr38? affected)

RESOLVED DUPLICATE of bug 1045845
Tracking Status
thunderbird40 --- affected
thunderbird41 --- affected
thunderbird42 --- affected
thunderbird43 --- affected
thunderbird_esr31 --- unaffected
thunderbird_esr38 ? affected

People

(Reporter: aryx, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [regression:tb38])

Thunderbird 43.0a1 20150813 Daily, 38.2.0 on Windows 8.1

Logging in to existing box.com account fails to close window (eternal throbber), setup of account fails.

Steps to reproduce:
1. Open Thunderbird's Options.
2. Go to Attachments > Outgoing.
3. Click on Add.
4. In the new dialog, click on "Set up account".
5. Enter the account credentials for box.com into the popup window.
6. Confirm the access for Thunderbird.
Actual result: Throbber in dialog window where you clicked "set up account" spins forever and never finishes, the window never closes. If you close the window and reopen the Options, a broken account is shown in the list.

Last good build:
20150218
comm-central: 0e0fb54e1299c89ff9f0477258f9df2608348db9
https://hg.mozilla.org/mozilla-central/rev/9696d1c4b3ba

bad:
20150219
comm-central: b2740fce3080e4ccd9163e11d349fc123727cb15
https://hg.mozilla.org/mozilla-central/rev/360b5f211180

Changes:
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=0e0fb54e1299c89ff9f0477258f9df2608348db9&tochange=b2740fce3080e4ccd9163e11d349fc123727cb15 (nothing suspicious)
mozilla-central: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9696d1c4b3ba&tochange=360b5f211180

Building fails here even after downgrading to MozillaBuild 1.11.0, so I can't narrow it down at the moment.
After deleting the .pyc files, building worked (thanks Fallen). This is caused by http://hg.mozilla.org/mozilla-central/rev/e34594984392 / bug 1131317.

Bug 1045845 started earlier (report in July 2014, this is a regression from February 2015).
Blocks: 1131317
The error console shows
Error: NS_NOINTERFACE: Component does not have requested interface [nsIRequestObserver.onStopRequest]
Source File: file:///c:/Mozilla/Coding/Code/comm-central3/obj-i686-pc-mingw32/dist/bin/components/nsBox.js
Line: 485

The same issue occurs with the Dropbox extension which uses the same code pattern like the Box one https://hg.mozilla.org/comm-central/file/802cf75f479b/mail/components/cloudfile/nsBox.js#l485

  createExistingAccount: function nsBox_createExistingAccount(aRequestObserver) {
     // XXX: replace this with a better function
    let successCb = function(aResponseText, aRequest) {
      aRequestObserver.onStopRequest(null, this, Cr.NS_OK);
    }.bind(this);

    let failureCb = function(aResponseText, aRequest) {
      aRequestObserver.onStopRequest(null, this,
                                     Ci.nsIMsgCloudFileProvider.authErr);
    }.bind(this);

    this.logon(successCb, failureCb, true);
  },
Patrick can you slay this one, like bug 1045845?
Flags: needinfo?(clokep)
Whiteboard: [regression:tb38]
I don't think this is an exact duplicate of bug 1045845, but I believe it was fixed at the same time as that. So I'm going to dup to it.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(clokep)
Resolution: --- → DUPLICATE
Duplicate of bug: 1045845
You need to log in before you can comment on or make changes to this bug.