Closed Bug 1202332 Opened 4 years ago Closed 4 years ago

XiphExtradataToHeaders miscalculates final header length

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox42 --- fixed
firefox43 --- fixed

People

(Reporter: kinetik, Assigned: kinetik)

References

Details

Attachments

(1 file)

For an example file I have on hand, the CodecPrivate element contains 4022 bytes, with 3 headers, and the first two headers are 30 and 81 bytes.  XiphExtradataToheaders calculates the final header size as 4019 (4022 - 1 - 1 - 1) rather than 3908 (4022 - 1 - 1 - 1 - 30 - 81).

This is caused by XiphExtradataToheaders using aAvailable without subtracting total (the running count of header sizes) as the final header size.
Attachment #8657679 - Flags: review?(tterribe)
Attachment #8657679 - Flags: review?(tterribe) → review+
https://hg.mozilla.org/mozilla-central/rev/391d49ed7ca7
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Blocks: 1197083
You need to log in before you can comment on or make changes to this bug.