Closed Bug 120247 Opened 20 years ago Closed 20 years ago

Bidi text changes direction when cut and pasted.

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 95400

People

(Reporter: xslf, Assigned: smontagu)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.7+) Gecko/20020111
BuildID:    2002011108
http://www.haayal.co.il/reply.php3?id=845&rep=52827&LastView=2002-01-15%2015%3A00%3A43
(I put the URL here again since I am having truble getting focus and pasting in
the URL text field)
On that page (logical) copy the text and paste into the textarea. It appears
reveresed (the order of the words & the order of the characters in the words)

Reproducible: Always
Steps to Reproduce:
1. go to the above url
2. copy the text
3. paste into the textarea

Actual Results:  text is reversed

Expected Results:  text should be ok
On my W2K and Linux systems the URL comes up in Mozilla as visual
(charset=iso-8859-8), but in IE as logical (charset=windows-1255). Are you using
client-spoofing to get the IE version served to Mozilla?

In the visual version I see the reversal in cut and paste on W2K, but not on
Linux. Confirming, assigning to myself, and changing platform to All.
Assignee: mkaply → smontagu
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac System 9.x → All
Hardware: Macintosh → All
Actaully no. If you sign up to the site, among other things you can tell it what
Hebrew encoding to serv you, and I choose logical.
There is also a menu item on the main page that lets you choose your encoding.
*** Bug 122183 has been marked as a duplicate of this bug. ***
As reported in bug 122183, there is a similar problem in visual pages also (The
operating system there was OS/2). Changing summary to reflect this.
Summary: Text copied from a logical page appears reveresed when pasted into a text area → Bidi text changes direction when cut and pasted.
It occurs to me that this could be a dupe of bug 95400. Shoshannah, can you
confirm whether you are seeing the same behaviour described in
http://bugzilla.mozilla.org/show_bug.cgi?id=95400#c1 ?
Yes, on OS 9 that text does indeed go back to the right way as soon as I type
something. Cam't test on OSX since mozilla crashes for me on startup (this was
reported by other people as well in the Israeli Mac forum-
http://forums.ort.org.il/mac
Marking as dupe per comment #6

*** This bug has been marked as a duplicate of 95400 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.