Copied hebrew text is not rendered right

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
18 years ago
11 years ago

People

(Reporter: stas-bugzilla, Assigned: smontagu)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

If I go to Hebrew site (in 'logical' display order, e.g.
http://news.walla.co.il/) and select there a text and copy it, then try to paste
it to a text widget, the text renders in a wrong (reversed) way. At the same
time, if I type it, the text is rendered OK.

The browser revision is 0.9.3 (2001080312).
I tried to reproduce this on WinNT (US), and found that when I pasted the text
it appeared reversed, but as soon as I added any other character to the text
widget the whole text was reordered correctly. Does the same thing happen in Linux?
Yes, same effect. Also, if I delete some hebrew text and then press "Undo", it
reappears reversed. If I type something, it becomes OK.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
I'll take this one
Assignee: mkaply → simon
Status: ASSIGNED → NEW
I thought this would be a no-brainer, but it turns out to be more complicated.
In fact the contents of a text field are never reordered after the first
keystroke, but since one keystroke normally only enters one character into the
field, nobody noticed that it hadn't been reordered. I need to do more debugging
of the reflow process to understand exactly why this happens and how to correct it.
Mass-move all BiDi Hebrew and Arabic qa to me, zach@zachlipton.com. 
Thank you Gilad for your service to this component, and best of luck to you 
in the future.

Sholom. 
QA Contact: giladehven → zach
Blocks: 115711
Status: NEW → ASSIGNED
*** Bug 120247 has been marked as a duplicate of this bug. ***
Marking ALL since this bug is also on Mac OSX
OS: Linux → All
Hardware: PC → All
It seems that attachment 81953 [details] [diff] [review] in bug 95228 fixes this bug as well.
Marking FIXED
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Keywords: fixed1.0.0
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.