Closed Bug 1202543 Opened 6 years ago Closed 6 years ago

[Browser] Cancel button on browser overflow menu is unobvious

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: ashiue, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

STR:
1. Open a site
2. Tap the overflow menu (... on right-upper corner)

Expected result:
1. The Cancel button on browser overflow menu should be obvious

Actual result:
1. The Cancel button is unobvious

Build info:
[aries]
Build ID               20150907110522
Gaia Revision          891798f1e345bc2b69e71de42bd524a90b1745c4
Gaia Date              2015-09-07 02:49:56
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5fe9ed3edd6811a662d40d05e37b0d66e9520d82
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150907.102632
Firmware Date          Mon Sep  7 10:26:39 UTC 2015
Bootloader             s1

[flame]
Build ID               20150907150218
Gaia Revision          891798f1e345bc2b69e71de42bd524a90b1745c4
Gaia Date              2015-09-07 02:49:56
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5fe9ed3edd6811a662d40d05e37b0d66e9520d82
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150907.182946
Firmware Date          Mon Sep  7 18:29:58 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [COM=Pin the Web]
Kevin, was this one of your component patches?
Flags: needinfo?(kevingrandon)
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Whiteboard: [systemsfe]
UX, is this using the to-spec component?  
I'm presuming not so will set to blocking for now.
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(firefoxos-ux-bugzilla)
Priority: -- → P3
This is caused by a platform change, bug 1179288.

It is currently tracked in bug 1196268.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(kevingrandon)
Resolution: --- → DUPLICATE
Duplicate of bug: 1196268
removing NI because of comment 4 (not ux issue, it's a regression)
Flags: needinfo?(firefoxos-ux-bugzilla)
QA Whiteboard: [COM=Pin the Web]
Still broken with other fixes, so going to re-open and block bug 1196268 on this.
Assignee: nobody → kevingrandon
Blocks: 1196268
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Blocks: 1214000
Blocks: 1213386
Comment on attachment 8675324 [details] [review]
[gaia] KevinGrandon:bug_1202543_browser_overflow_cancel > mozilla-b2g:master

This is just a very simple fix to the context menu, and all tests are passing. R=me.
Attachment #8675324 - Flags: review+
In master: https://github.com/mozilla-b2g/gaia/commit/f4aebf0260dc9b4478e3d4dad882e98fc06bdf85
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
This may have busted Gij17 on b2g-inbound. Still running retriggers to confirm suspicion.
(In reply to Nigel Babu [:nigelb] from comment #10)
> This may have busted Gij17 on b2g-inbound. Still running retriggers to
> confirm suspicion.

Looks like the retriggers are showing bug 1202422?
This bug has been verified as "pass" on the latest build of Flame KK 2.5&2.6 and Aires KK 2.6 by the STR in comment 0.

Actual results: The Cancel button shows normally on browser overflow menu.
See attachment: verified_Flame_v2.6.png
Reproduce rate: 0/10


Device: Flame KK 2.5 512mb (Pass)
Build ID               20151103004501
Gaia Revision          91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gaia Date              2015-10-28 20:32:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/4e0955369a51850f2982087145ac5c2df257ffe9
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151103.054921
Firmware Date          Tue Nov  3 05:49:36 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.6 512mb (master)(Pass)
Build ID               20151103150203
Gaia Revision          61918ddd9ccce104c009e873e34a0791e125753a
Gaia Date              2015-11-03 17:22:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f742b9412ed5aace90ad863b276faae0641090a8
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151103.182550
Firmware Date          Tue Nov  3 18:26:03 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.6 (master)(Pass)
Build ID               20151104004249
Gaia Revision          61918ddd9ccce104c009e873e34a0791e125753a
Gaia Date              2015-11-03 17:22:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f742b9412ed5aace90ad863b276faae0641090a8
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151104.000116
Firmware Date          Wed Nov  4 00:01:24 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
This bug has been verified as "pass" on the latest Aires KK 2.5 by the STR in comment 0.

Actual results: The Cancel button shows normally on browser overflow menu as same as mentioned in comment 13.
See above attachment: "verified_Flame_v2.6.png".
Reproduce rate: 0/10

Device: Aries KK 2.5 (Pass)
Build ID               20151107112205
Gaia Revision          577948202ae12154524a2bd2bd6d467838ad50b8
Gaia Date              2015-11-07 10:00:59
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/ae7b8b1fd9e1504347b938820f99d75058049386
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151107.104119
Firmware Date          Sat Nov  7 10:41:27 UTC 2015
Bootloader             s1
You need to log in before you can comment on or make changes to this bug.