Cannot send email. Stuck at "Sending message" and "Attaching' when remote image of HTML mail is intentionally blocked by user

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
3 years ago
2 years ago

People

(Reporter: peter-mozilla, Unassigned)

Tracking

38 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8658210 [details]
attaching-dialog.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826185949

Steps to reproduce:

I get an email with images embedded but as I do block loading images they are not visible. See image.

I reply to this email but Thunderbird resists to send it, it says 'Attaching' endlessly. See image.


Actual results:

I cannot send the email.

A workaround I found was to remove all images (blank boxes due to my blocking settings)

See also discussion here: http://forums.mozillazine.org/viewtopic.php?f=39&t=2459519&sid=6507127268886ce80f870b50c329f0b2&start=135


Expected results:

I should be able to send the reply even if the original email contains embedded images.
(Reporter)

Comment 1

3 years ago
Created attachment 8658211 [details]
Broken images example
(Reporter)

Comment 2

3 years ago
Created attachment 8658212 [details]
attaching-dialog.png

Please remove old image.
Attachment #8658210 - Attachment is obsolete: true
Phenomenon itself is same as bug 817245(See also bug 766495, bug 799450). If Tb 38 or newer, issue of bug 1201782 may happen.

(In reply to peter from comment #0)
> Steps to reproduce:
> I get an email with images embedded but as I do block loading images

Embed image in HTML : <img src="http://aaa.bbb.ccc/...">
In composed mail, Tb tries to send the image data as "Embed image data in mail".
   Content-Type=image/xxx, Content-Id=<PQR> part for image data
   <img src="cid:PQR"> in HTML
This is because "attach image data in mail" is on by default for such <img> in HTML.
However, because you block loading remote image, access to http://aaa.bbb.ccc/... is prohibited by you.
Then, Tb can't get image data for <img src="cid:PQR"> in HTML.
In this case, I think same phenomenon as bug 817245 occurs.

In HTML mode composition, <IMG> is inserted by "Insert Image", and it has option of "attach image data" or "don't attach image data"(send URL of image).
Is option of "don't attach image data" usable in your case?
Summary: Cannot send email, it just says 'Attaching' endlessly. → Cannot send email, it just says 'Attaching' endlessly, when remote image of HTML mail is intentionally blocked by user

Comment 4

2 years ago
I cannot reproduce this. Replying to a message with blocked remote images doesn't cause any problems for me.

Comment 5

2 years ago
peter hasn't replied. Let's assume duplicate of bug 1201782 rather than closing incomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Depends on: 1201782
Resolution: --- → DUPLICATE
Summary: Cannot send email, it just says 'Attaching' endlessly, when remote image of HTML mail is intentionally blocked by user → Cannot send email. Stuck at "Sending message" and "Attaching' when remote image of HTML mail is intentionally blocked by user
Duplicate of bug: 1201782

Comment 6

2 years ago
I still have this issue, maybe the enigmail add on causes this?

The other bug report does not read similar though.

Comment 7

2 years ago
Ah, issue https://bugzilla.mozilla.org/show_bug.cgi?id=532395 read like this and it looks like it is fixed already - nice & thanks!

Comment 8

2 years ago
Try using TB 49 beta. That should have most issues fixed. Note: Still open: Bug 1251853.

Comment 9

2 years ago
Not a good idea to close this as a duplicate since this is explicitly about blocked content.
Resolution: DUPLICATE → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.