[OMTC] Firefox doesn't repaint hg.mozilla.org when I autoscroll it slowly

RESOLVED DUPLICATE of bug 1209100

Status

()

Core
Graphics
--
major
RESOLVED DUPLICATE of bug 1209100
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Whiteboard: [gfx-noted], URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8658249 [details]
video - [OMTC] Firefox doesn't repaint hg.mozilla.org when I autoscroll it slowly.webm

STR:   (Win7_64, Nightly 43, 32bit, ID 20150907030206, new profile, safe mode)
1. Open URL
2. Place mouse in the center of content area
3. Click middle mouse button
4. Move mouse 1-5px below the autoscroll circle

Result:       Page is being scrolled, but elements repaint only when I move mouse over them
Expectations: Page should repaint normally

Workaround:   1) html5.offmainthread -> false
              2) layers.offmainthreadcomposition.async-animations -> false
              3) layers.offmainthreadcomposition.enabled -> false
              4) Restart browser
(Reporter)

Updated

2 years ago
Severity: normal → major
Does turning off e10s or APZ (layers.async-pan-zoom.enabled) also stop this from happening?
(Reporter)

Comment 2

2 years ago
As you can see on the video, e10s is not enabled. APZ doesn't stop this.
// You asked _me_ because you failed to reproduce this yourself, right?
Correct.
(Reporter)

Comment 4

2 years ago
(In reply to Markus Stange [:mstange] from comment #3)
I saw you're using Mac OS. That's important information and should've been mentioned.
(Reporter)

Comment 5

2 years ago
I figured out that "layers.offmainthreadcomposition.enabled"->false is enough to cure it.

Markus, we have a theory that VM blocks/doesn't allow OMTC. (See bug 1189438 comment 13)
Whiteboard: [gfx-noted]
(Reporter)

Updated

2 years ago
Has STR: --- → yes
(Reporter)

Comment 6

2 years ago
I created user.js in my profile where I enabled OMTC (just in case) and bisected using that profile.
This was caused by bug 1165185. Regression range:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cd741d3ae78a7ef127b6baf7c4efc0fff0472267&tochange=f7fca0232ffc4ec5855557cfb7a6d039b28488e4
Blocks: 1165185
Keywords: regression
(Reporter)

Comment 7

2 years ago
Any success reproducing this bug on Windows?
Flags: needinfo?(mstange)
This is the same underlying bug as bug 1209100 - we're failing to recomposite at the bottom end of very large pages.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mstange)
Resolution: --- → DUPLICATE
Duplicate of bug: 1209100
You need to log in before you can comment on or make changes to this bug.