Add webRequest requestId property

RESOLVED DUPLICATE of bug 1163862

Status

()

Toolkit
WebExtensions: Untriaged
P2
major
RESOLVED DUPLICATE of bug 1163862
2 years ago
2 years ago

People

(Reporter: billm, Assigned: mao)

Tracking

(Blocks: 3 bugs)

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
blocking-webextensions +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webRequest]triaged)

(Reporter)

Description

2 years ago
To do this, we'll need everything to run in the parent process. That means that the content policy stuff will have to be moved to an http-on-modify handler or something.
(Assignee)

Updated

2 years ago
Blocks: 1161828, 1058542

Updated

2 years ago
Whiteboard: [webRequest]

Updated

2 years ago
Blocks: 1214733

Updated

2 years ago
Blocks: 1214433

Updated

2 years ago
Flags: blocking-webextensions+

Updated

2 years ago
Blocks: 1213483

Updated

2 years ago
Assignee: nobody → g.maone
Iteration: --- → 45.3 - Dec 14
(Assignee)

Updated

2 years ago
Iteration: 45.3 - Dec 14 → 46.1 - Dec 28
(Reporter)

Updated

2 years ago
Blocks: 1235639
(Assignee)

Updated

2 years ago
Iteration: 46.1 - Dec 28 → 46.2 - Jan 11

Updated

2 years ago
Iteration: 46.2 - Jan 11 → 46.3 - Jan 25
(Assignee)

Updated

2 years ago
Iteration: 46.3 - Jan 25 → 47.1 - Feb 8
Depends on: 1163862

Updated

2 years ago
Whiteboard: [webRequest] → [webRequest]triaged

Updated

2 years ago
Priority: -- → P2
(Assignee)

Updated

2 years ago
Iteration: 47.1 - Feb 8 → 47.2 - Feb 22

Comment 1

2 years ago
making major as needed for ghostery - 15M users
Severity: normal → major

Comment 2

2 years ago
make that 1.5M users - still major impact
(Assignee)

Updated

2 years ago
No longer blocks: 1058542
(Assignee)

Comment 3

2 years ago
This is being fixed by the patch I've just attached to bug 1163862. Should I resolve this one as a dupe?
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1163862

Updated

2 years ago
Duplicate of this bug: 1250428
You need to log in before you can comment on or make changes to this bug.