[Contacts]custom label of address is displayed as '#TYPE#' .

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Contacts
P3
normal
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Assigned: borjasalguero)

Tracking

({regression})

unspecified
FxOS-S9 (16Oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [NG Gaia Contacts][patch][2.5-aries-test-run-2][only for NGA Contacts branch])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8658628 [details]
Aries_2.5.3gp

[1.Description]:
[Contacts][Aries kk v2.5][Flame kk v2.5]If user use a custom label to mark an address, and then check it on details view, they will find address lablel is displayed as '#TYPE#'.
Found time:04:44
See Attachment:Aries_v2.5.3gp & logcat_0444.txt

[2.Testing Steps]: 
1. Launch Contacts app.
2. Load existing contact with phone number, or create new contact with phone number.
3. Tap on the address label.
4. Tap on custom label, and type 'vvvv'.
5. Save contact.
6. Observe contact.

[3.Expected Result]: 
6.Label for address displays as 'vvvv' the custom tag added by user.

[4.Actual Result]: 
6.Label for address displays as '#TYPE#'.

[5.Reproduction build]: 
Device: Aries KK v2.5(Affected)
Build ID               20150909010033
Gaia Revision          e69f2c86b931b723dd405115e33a1d02e6c5f5e6
Gaia Date              2015-09-08 20:39:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a4f512250d7d6199ae8c39eafdb3a2d8977a7dc4
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150909.002137
Firmware Date          Wed Sep  9 00:21:45 UTC 2015
Bootloader             s1

Device: Flame KK v2.5(Affected)
Build ID               20150908150203
Gaia Revision          b81185d30e548f782770b852473ffb53c641a490
Gaia Date              2015-09-08 08:13:20
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b23b2fa33a9dcda59dbbca1d157eca3c32c5b862
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150908.183329
Firmware Date          Tue Sep  8 18:33:40 EDT 2015
Bootloader             L1TC000118D0

Device: Flame KK 2.2 (Unaffected) 
Build ID               20150908032505
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/96170c571381
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150908.065039
Firmware Date          Tue Sep  8 06:50:53 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
8786
(Reporter)

Comment 1

3 years ago
Created attachment 8658630 [details]
logcat_0444.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Keywords: regression
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Blocks 2.5 with P3 priority.
blocking-b2g: 2.5? → 2.5+
Priority: -- → P3
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK 2.5
Build ID               20150819054940
Gaia Revision          fa32b801f6d854e846ea8294dc37840450d36c1e
Gaia Date              2015-08-19 12:01:44
GeckoRevision
https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150819.183303
Firmware Date          Wed Aug 19 18:33:18 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK 2.5
Build ID               20150819061537
Gaia Revision          b57de4c493b611dc70c27c7d78445fcb04b1491c
Gaia Date              2015-08-19 12:27:22
GeckoRevision
https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150819.183303
Firmware Date          Wed Aug 19 18:33:18 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          b57de4c493b611dc70c27c7d78445fcb04b1491c
Gecko Revision
https://hg.mozilla.org/integration/b2g-inbound/rev/8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb

First Broken Gecko & Last Working Gaia - issue DOES NOT repro
Gaia Revision          fa32b801f6d854e846ea8294dc37840450d36c1e
Gecko Revision
https://hg.mozilla.org/integration/b2g-inbound/rev/7feeb30abb6856d4176fd0e5eb7b45da18931c49

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/fa32b801f6d854e846ea8294dc37840450d36c1e...b57de4c493b611dc70c27c7d78445fcb04b1491c

Possibly caused by Bug 1183727.

----------------------------------------------
Hi Borja,
This bug is probably caused by Bug 1183727, could you help to check?  
Thank you.
Flags: needinfo?(borja.bugzilla)
QA Whiteboard: [MGSEI-Triage+]
Blocks: 1183727
Whiteboard: [2.5-aries-test-run-2] → [NG Gaia Contacts][2.5-aries-test-run-2]
Target Milestone: --- → FxOS-S7 (18Sep)
Assignee: nobody → borja.bugzilla
Status: NEW → ASSIGNED
Flags: needinfo?(borja.bugzilla)
Created attachment 8659211 [details] [review]
[gaia] borjasalguero:label_detail > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8659211 - Flags: review?(francisco)
Whiteboard: [NG Gaia Contacts][2.5-aries-test-run-2] → [NG Gaia Contacts][patch][2.5-aries-test-run-2]
After reverting the commits that gave us separated views in Contacts, the issue reported in this bug is not happening anymore in master (as it raised when bug 1183727 landed and it has already been backed out)

For that reason, removing the 2.5+ flag and adding [only for NGA Contacts branch] whiteboard to ensure that this bug need to be fixed in NGA branch (but not in current master branch).
blocking-b2g: 2.5+ → ---
Whiteboard: [NG Gaia Contacts][patch][2.5-aries-test-run-2] → [NG Gaia Contacts][patch][2.5-aries-test-run-2][only for NGA Contacts branch]
Comment on attachment 8659211 [details] [review]
[gaia] borjasalguero:label_detail > mozilla-b2g:master

Looking good, please land this on the nga branch.
Attachment #8659211 - Flags: review?(francisco) → review+
Target Milestone: FxOS-S7 (18Sep) → FxOS-S8 (02Oct)
Created attachment 8665371 [details] [review]
[gaia] borjasalguero:fix_label_nga > mozilla-b2g:nga
Target Milestone: FxOS-S8 (02Oct) → FxOS-S9 (16Oct)

Comment 9

4 months ago
Firefox OS is not being worked on
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.