Huge context menu after right click in message [ReferenceError: GetThreadTree is not defined] in mailContextMenus.js

RESOLVED FIXED in Thunderbird 44.0

Status

Thunderbird
Folder and Message Lists
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Stefan Sitter, Assigned: alta88)

Tracking

({regression})

43 Branch
Thunderbird 44.0
regression

Thunderbird Tracking Flags

(thunderbird42 unaffected, thunderbird43+ fixed, thunderbird44 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

2 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Thunderbird/43.0a1 (Build ID 20150909030202)
Lightning 4.5a1 is installed but disabled.

Steps to reproduce:
* Start Thunderbird with clean profile
* Skip system integration and initial account creation
* Create a Feed account to stop Thunderbird for asking for accounts
* Download and save the .eml file from 
  https://bugzilla.mozilla.org/attachment.cgi?id=8658787&action=edit
* Use File > Open Saved Message to view the message in new window
* Right click into message content

Actual Results:
Context menu is huge with many entries. Error Console shows:

Error: ReferenceError: GetThreadTree is not defined
Source File: chrome://messenger/content/mailContextMenus.js Line: 64

Error: TypeError: gContextMenu is undefined
Source File: chrome://messenger/content/mailContextMenus.js Line: 50

Works in Earlybird 42.0a2 (2015-09-09). Probably regressed by Bug 500610.
(Reporter)

Updated

2 years ago
Keywords: regression
(Assignee)

Comment 1

2 years ago
Created attachment 8658850 [details] [diff] [review]
context.patch
Assignee: nobody → alta88
Attachment #8658850 - Flags: review?(mkmelin+mozilla)

Comment 2

2 years ago
Comment on attachment 8658850 [details] [diff] [review]
context.patch

Review of attachment 8658850 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/base/content/mailContextMenus.js
@@ +60,5 @@
>      return true;
>  
>    // No menu on grouped header row currently, any command would be an implied
>    // multiselect.
> +  if (gFolderDisplay.tree) {

what's gFolderDisplay.tree?
(Assignee)

Comment 3

2 years ago
the same thing as GetThreadTree() and null in a message window.  another global func that can be gotten rid of.

Comment 4

2 years ago
Comment on attachment 8658850 [details] [diff] [review]
context.patch

Review of attachment 8658850 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good thx. 
I'll attach an unbitrotted patch.
Attachment #8658850 - Flags: review?(mkmelin+mozilla) → review+

Comment 5

2 years ago
Created attachment 8663801 [details] [diff] [review]
context.patch
Attachment #8658850 - Attachment is obsolete: true
Attachment #8663801 - Flags: review+
(Assignee)

Comment 6

2 years ago
thanks.
Keywords: checkin-needed

Comment 7

2 years ago
Created attachment 8663805 [details] [diff] [review]
context.patch

Really unbitrotted.
Attachment #8663801 - Attachment is obsolete: true

Updated

2 years ago
Attachment #8663805 - Flags: review+

Comment 8

2 years ago
https://hg.mozilla.org/comm-central/rev/3e27b83156b6
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0

Updated

2 years ago
Target Milestone: Thunderbird 43.0 → Thunderbird 44.0
(Reporter)

Comment 9

2 years ago
Verified fixed using Thunderbird 44.0a1 (20150922030229).
(Reporter)

Comment 10

2 years ago
Comment on attachment 8663805 [details] [diff] [review]
context.patch

[Approval Request Comment]
Regression caused by (bug #): bug 500610
User impact if declined: broken context menu
Testing completed (on c-c, etc.): see comment 9
Risk to taking this patch (and alternatives if risky):
Attachment #8663805 - Flags: approval-comm-aurora?
(Reporter)

Updated

2 years ago
status-thunderbird43: --- → affected
(Reporter)

Updated

2 years ago
status-thunderbird42: --- → unaffected
tracking-thunderbird43: --- → ?
Blocks: 500610

Comment 11

2 years ago
Comment on attachment 8663805 [details] [diff] [review]
context.patch

http://hg.mozilla.org/releases/comm-aurora/rev/ca799fe0e2fe
Attachment #8663805 - Flags: approval-comm-aurora? → approval-comm-aurora+

Updated

2 years ago
status-thunderbird43: affected → fixed
status-thunderbird44: --- → fixed
tracking-thunderbird43: ? → +
You need to log in before you can comment on or make changes to this bug.