Music doesn't stop when call is received

RESOLVED DUPLICATE of bug 1180618

Status

RESOLVED DUPLICATE of bug 1180618
3 years ago
3 years ago

People

(Reporter: Borisbudini, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150910004036

Steps to reproduce:

I had an song playing with headphones . I received a call . While the call sound was playing , the music didn't stop.


Actual results:

The music wouldn't stop until the person spook . Latter this bug became worse . It would happen even without headphones and the music don't stop even when you talk , making impossible to communicate .


Expected results:

The music should have been paused right away , when receiving the call.
(Reporter)

Comment 1

3 years ago
The version of Firefox is 2.5 nightly
blocking-b2g: --- → 2.5?
Component: General → Gaia::Dialer
(Reporter)

Updated

3 years ago
Summary: Music doesn't stop when call is recived → Music doesn't stop when call is received
marking as qawanted to confirm bug.

In which case will be a blocker.
Keywords: qawanted
This issue is reproducible on today's Flame and Aries in central.

While playing a song in music app and there's an incoming call, music is still heard when DUT is ringing, and music continues to play after DUT picks up the call.

Device: Flame 2.5
BuildID: 20150914030233
Gaia: 4d9b996be4b1935651057d0651461c1a36d98a18
Gecko: 9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Aries 2.5
BuildID: 20150914130903
Gaia: f37e8f732e0af961b43e912629c84c9e2ceda55d
Gecko: fba4b0cd3823975949765acc0b16b964d1712b75
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

-------

This issue does NOT occur on Flame 2.2. Music is not heard when an incoming call is ringing, and it is not heard when call is connected. However 2.2 is not completely exhibiting the expected behavior either, bug 1063664 and bug 1145067 both exist in 2.2.

Device: Flame 2.2
BuildID: 20150914032507
Gaia: 7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gecko: 0d9c46d01861
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: UNCONFIRMED → NEW
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Ever confirmed: true
Flags: needinfo?(jmercado)
Keywords: qawanted → regression
Let's get a window here.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
QA Contact: pcheng
*Note that the last working build behavior is: Upon answering a call, the call is automatically being put on hold (hence music is heard, which I had initially thought this as reproducing the issue). I can work around this by un-holding the call, and after un-holding, the bug does not reproduce. The first broken build reproduces exactly as comment 0 described, without the auto-hold issue.

Last Working
Device: Flame
BuildID: 20150820075238
Gaia: 5d3a7bbe66f26a22b3179edc7b3a7cb26561c59b
Gecko: 37a7c0a7fc9dcb11c90cf7b9a80aa38b50d8936f
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Device: Flame
BuildID: 20150820082237
Gaia: c6705f739fb605031eb2a0b943ba55c64bee5a03
Gecko: 6c9cd390c157040b28ed8e4b8509f72ee5c14e2b
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5 Master) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working Gaia First Broken Gecko - no repro
Gaia: 5d3a7bbe66f26a22b3179edc7b3a7cb26561c59b
Gecko: 6c9cd390c157040b28ed8e4b8509f72ee5c14e2b

Last Working Gecko First Broken Gaia - repro
Gaia: c6705f739fb605031eb2a0b943ba55c64bee5a03
Gecko: 37a7c0a7fc9dcb11c90cf7b9a80aa38b50d8936f

This issue is likely caused by changes made in Bug 1185442.
Blocks: 1185442
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Kevin this issue seems to have been caused by the changes made for bug 1185442.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(kevingrandon)
Broken feature, blocking.
blocking-b2g: 2.5? → 2.5+

Comment 9

3 years ago
Same as the bug1180618, the ringer can be managed after landing bug1180618.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1180618
Looks like this has been duplicated against a bug with a patch in it, clearing needinfo.
Flags: needinfo?(kevingrandon)
You need to log in before you can comment on or make changes to this bug.