tinderbox generates relative urls that are off by one level

RESOLVED DUPLICATE of bug 345804

Status

Webtools Graveyard
Tinderbox
--
major
RESOLVED DUPLICATE of bug 345804
17 years ago
4 years ago

People

(Reporter: Andreas Otte, Assigned: Chris McAfee)

Tracking

Dependency tree / graph

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
The Problem:
tinderbox generates relative urls that are off by one level

Reproduceable:
1. Go to http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey
2. Look at Page source. It contains lines like:
<a
href=../bonsai/cvsquery.cgi?module=MozillaTinderboxAll&date=explicit&mindate=1011211680&maxdate=1011214079>C</a>

This relative url is in error, there is no upper level to root.

Alternativly go to:

http://tinderbox.mozilla.org/SeaMonkey/

This will show the same page. Then again call page source. It will contain lines
like this:

<a
href=../../bonsai/cvsquery.cgi?module=MozillaTinderboxAll&date=explicit&mindate=1011208020&maxdate=1011213959>C</a>

Again this relative urls are off by one level and wrong.

The only reason we currently have no problem with this urls is that we silently
 drop to much levels of ../

The patch for bug 119071 was about to change that and that's how this problem
was detected.
(Reporter)

Updated

17 years ago
Blocks: 119071

Comment 1

17 years ago
you don't really need to evangelize us, you can just file a bug directly.
Assignee: doronr → mcafee
Component: US General → Tinderbox
Product: Tech Evangelism → Webtools
QA Contact: zach → timeless
Version: unspecified → other
(Assignee)

Comment 2

17 years ago
the server code has been hit by the 4.x browser and IE for years,
not sure I buy that this is a problem.  For url foo, what should the
new url be?  And if we are wrong, why is this working for mozilla,
4.x, and IE?

Note that tinderbox.mozilla.org does point to a root, but that there
is a sibling directory "bonsai" that is being accessed.
(Reporter)

Comment 3

17 years ago
I always wanted to file an evangelism bug against mozilla.org ... ;-)

The reason this has not been detected before is that apparently all browsers
drop silently to much ../ in a resolution of relative urls. According to RFC
2396 it is a possible solution and mozilla is doing it too. But it is not the
only solution. RFC 2396 allows also to leave the ../ in the path or not to
execute that url at all.

tinderbox should not depend on the idea that all browser implementors go for one
of many possible solutions for this kind of wrong urls.

See bug 119071 for a related discussion.

If I have an URL http://tinderbox.mozilla.org/ than that is the root of the
access to the website. A relative url to this base url like "../bonsai/xxx"
resolves to an invalid url because there is no access allowed above "/".

Currently this url resolves to http://tinderbox.mozilla.org/bonsai/xxx (dropping
the ../ silently and getting it right by accident).

RFC 2396 would also allow to resolve this to:
http://tinderbox.mozilla.org/../bonsai/xxx (which results in a "bad request"
answer from the server)

Third solution is to throw an error and to send no request at all.
(Reporter)

Comment 5

17 years ago
looks good to me, when this is checked in I will test the first patch from
119071 against it.
(Assignee)

Comment 6

17 years ago
This comment in the code worries me:

# $rel_path is the relative path to webtools/tinderbox used for links.
# It changes to "../" if the page is generated statically, because then
# it is placed in tinderbox/$::tree.

I'd rather not fix something that isn't broken.
I suggest we fix this in the tbox 2.0 server and mark
this won't fix.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 7

17 years ago
woops, don't mark won't fix just yet
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 8

17 years ago
Created attachment 66249 [details]
diff of /showbuilds.cgi?tree=MozillaTest and /MozillaTest

Note that there really are too many ../'s for registry and bonsai. compare with
addnote and showlog
(Reporter)

Updated

17 years ago
Blocks: 122133
(Reporter)

Comment 9

17 years ago
Any ETA on this?
(Assignee)

Comment 10

17 years ago
I tried this patch, it didn't quite work for me, some URL's weren't working.
I'm not especially motivated to look at this because I don't see anything
wrong.  What we have has worked since 1996, let's fix this in the
new tinderbox codebase.  Convince me to look at this, or try pulling
down webtools/{bonsai,tinderbox} and help me test this.
(Reporter)

Comment 11

17 years ago
You don't see the problem because mozilla and other browsers are so forgiving
about the error in the generated urls. But I can live with it when it is looked
at in the new tinderbox codebase. There is no immediate rush about this. We were
able to code around it.
(Assignee)

Updated

16 years ago
Target Milestone: --- → Future

Updated

16 years ago
Blocks: 146076
(Reporter)

Updated

16 years ago
No longer blocks: 146076
QA Contact: timeless → tinderbox

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 345804
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.