[e10s][TSF] The suggest window position of Japanese MS-IME for Win8.1 and Win10 is sometimes positioned top-left of the screen

RESOLVED FIXED in Firefox 43

Status

()

Core
Widget: Win32
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

(Blocks: 2 bugs, {inputmethod})

Trunk
mozilla43
x86
Windows
inputmethod
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox43 fixed)

Details

Attachments

(2 attachments)

In e10s mode, the suggest window of Japanese MS-IME for Win8.1 and Win10 are sometimes positioned at top-left of the screen.

According to the log, the cause might be that we return TS_E_NOLAYOUT at unexpected time, but I still doesn't find the reason yet.

I don't see this issue in non-e10s mode, but if you see it, let me know.
tracking-e10s: --- → +
Created attachment 8662238 [details] [diff] [review]
part.1 Add a method which checks if the active TIP is Microsoft IME for Japanese
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Attachment #8662238 - Flags: review?(VYV03354)
Created attachment 8662240 [details] [diff] [review]
part.2 Hack TSFTextStore::GetTextExt() for TS_E_NOLAYOUT issue of MS-IME for Japanese

This is exactly same hack as for Google Japanese Input.

You know, we are going to remove the hack for Google Japanese Input, we should duplicate the code rather than merge with them. Because if we need to uplift some patches around here for other urgent bugs which would be found in the future, this is easier to merge the patch.
Attachment #8662240 - Flags: review?(VYV03354)
Blocks: 1204519
Attachment #8662238 - Flags: review?(VYV03354) → review+
Attachment #8662240 - Flags: review?(VYV03354) → review+
Did you report the bug to Microsoft?
(In reply to Masatoshi Kimura [:emk] from comment #3)
> Did you report the bug to Microsoft?

Not yet. I'm still looking for a good email address. (I need to report the bug of Chinese TIP's too)
Hmm, even with these patches, I rarely see this bug. (one per hour?)

But the frequency is too low, so, I've still caught the log at failure. Anyway, we should fix it in another bug.

Comment 6

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9a4a98b0b998
https://hg.mozilla.org/integration/mozilla-inbound/rev/266ea5415d6b
https://hg.mozilla.org/mozilla-central/rev/9a4a98b0b998
https://hg.mozilla.org/mozilla-central/rev/266ea5415d6b
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox43: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
I reported this bug to MS via Windows Feedback.
Windows-Feedback:?contextid=330&feedbackid=33ebb799-ddf7-4d7d-83ab-1919599af3c5&form=1&src=2
See Also: → bug 1208977
You need to log in before you can comment on or make changes to this bug.