Closed Bug 1204831 Opened 6 years ago Closed 6 years ago

[v2.5][Gaia::UI Tests]test_browser_private_navigation.py:"TimeoutException: TimeoutException: Timed out after 30.1 seconds'"

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: xiongfuchao, Assigned: apastor)

References

()

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(2 files)

[Description]:
test_browser_private_navigation.py  fails

[Steps to Reproduce]
test_browser_private_navigation.py

[Reproduction Frequency]
occasionally Recurrence, 6/10

Traceback (most recent call last):
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.17-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/browser/test_browser_private_navigation.py", line 22, in test_browser_private_navigation
    browser = private_window.go_to_url(self.test_url)
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/search/regions/browser.py", line 100, in go_to_url
    Wait(self.marionette).until(lambda m: self._root_element.get_attribute('aria-hidden') == 'true')
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.1 seconds

[Build info]
Device firmware (base)	L1TC000118D0
Device firmware (date)	14 Sep 2015 18:32:45
Device firmware (incremental)	eng.cltbld.20150914.063235
Device firmware (release)	4.4.2
Device identifier	flame
Gaia date	13 Sep 2015 18:47:32
Gaia revision	4d9b996be4b1
Gecko build	20150914030233
Gecko revision	9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gecko version	43.0a1

[Attachments]
2015-09-15-12_Non-Smoketest.html
Failure path:
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/tests/functional/browser/test_browser_private_navigation.py#22
http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/apps/search/regions/browser.py#100

I also saw failure, but a little later, because the virtual keyboard suddenly disappears.

It looks like when opening a private browser window, something is loading, which takes a while (system.gaiamobile.org is shown in the url bar during that).
If you then click on the url bar, during this loading phase, then when the loading phase is finished, the focus gets removed on the url bar and the virtual keyboard has disappeared.
This looks like a clear bug to me in the browser app.

We could workaround this by tapping on the url bar later, after this loading thing has finished, but I think this weird loading state in the browser needs to be fixed.

I guess this is a recent regression, I can reproduce it in:
Build ID               20150915030230
Gaia Revision          e6994410dcc88bfead0e44620a065220b7f12290
Gaia Date              2015-09-14 15:23:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c69e31de9aec2b9e8c0b3128ac6dc3897aa7381f
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150914.063235
Firmware Date          Mon Sep 14 06:32:45 EDT 2015
Bootloader             L1TC000118D0
Component: Gaia::UI Tests → Gaia::Browser
It works in:
Build ID               20150913150208
Gaia Revision          4d9b996be4b1935651057d0651461c1a36d98a18
Gaia Date              2015-09-13 10:47:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150913.184300
Firmware Date          Sun Sep 13 18:43:14 EDT 2015
Bootloader             L1TC000118D0

It fails in:
Build ID               20150914030233
Gaia Revision          4d9b996be4b1935651057d0651461c1a36d98a18
Gaia Date              2015-09-13 10:47:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ed17db42e3e46f1c712e4dffd62d54e915e0fac
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150913.184300
Firmware Date          Sun Sep 13 18:43:14 EDT 2015
Bootloader             L1TC000118D0
Hmm, that doesn't make sense, there is no difference between those builds, afaict.
I'll try to get the window here.
QA Contact: pcheng
I can reproduce this manually, but when doing the same manual steps on Flame 2.2, the loading of private browser was very fast, and either it didn't allow me to enable the rocketbar during loading, or I wasn't fast enough to tap on search bar before loading complete. To ensure I'm doing this right, I'll run these two tests 'test_browser_private_navigation.py' and 'browser.py' 10 times on each build to find the window.
Actually, I can't run 'browser.py' because the file name doesn't start with 'test_' and it gave me an error. So I'll just run 'test_browser_private_navigation.py'.
On early September builds (9/3 and 9/7) I'm getting a different kind of error 10/10 of times.

    self._handle_error(resp)
  File "/home/flash/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/marionette.py", line 752, in _handle_error
    raise errors.lookup(error)(message, stacktrace=stacktrace)
ElementNotVisibleException: ElementNotVisibleException: Element is not currently visible and may not be manipulated

Not sure if I can actually get a window of this issue. It looks like it's error a, b, and possibly more errors in different periods of time.
Flags: needinfo?(martijn.martijn)
nvm i think i can figure this out
Flags: needinfo?(martijn.martijn)
Last working build behavior: 10/10 passed, no error
First broken build behavior: a mix of timeout error and error described at comment 7; I think they're of the same cause.

Last Working
Device: Flame 2.5
BuildID: 20150828025950
Gaia: 79dba9c072f6aaec932be4eabd4f006f07bacb24
Gecko: b54092c56aca4e5091adb66936441f8bd8c4afa1
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Device: Flame 2.5
BuildID: 20150828030450
Gaia: 5b75e1620ed11529945f3585efeb4a42106bfac6
Gecko: a2b1b9341309a781313045ee600b8efb1f81d9df
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working Gaia First Broken Gecko - no repro
Gaia: 79dba9c072f6aaec932be4eabd4f006f07bacb24
Gecko: a2b1b9341309a781313045ee600b8efb1f81d9df

Last Working Gecko First Broken Gaia - repro
Gaia: 5b75e1620ed11529945f3585efeb4a42106bfac6
Gecko: b54092c56aca4e5091adb66936441f8bd8c4afa1

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/79dba9c072f6aaec932be4eabd4f006f07bacb24...5b75e1620ed11529945f3585efeb4a42106bfac6

This issue occurs due to changes made in Bug 1198976.
Blocks: 1198976
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Alberto this issue seems to have been caused by the changes for bug 1198976.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(apastor)
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Whiteboard: [systemsfe]
Depends on: 1205626
Sorry, lost track of this bug. As we are moving from Gip to Gij, is this still an issue? Thanks!
Flags: needinfo?(martijn.martijn)
This is not an issue anymore, so these lines could be removed: http://mxr.mozilla.org/gaia/source/tests/python/gaia-ui-tests/gaiatest/apps/search/regions/browser.py#107
I was working on this, but with the move from Gip to Gij, I stopped working on that.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(martijn.martijn)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.