Closed Bug 1205108 Opened 6 years ago Closed 6 years ago

Remove unused DSTCA root certificates from NSS

Categories

(NSS :: CA Certificates Code, task)

task
Not set
normal

Tracking

(firefox43 affected)

RESOLVED FIXED
Tracking Status
firefox43 --- affected

People

(Reporter: kwilson, Unassigned)

References

Details

(Whiteboard: Removed in NSS 3.21, planned for Firefox 44)

Please remove the following two root certificates from NSS.

Builtin Object Token: Digital Signature Trust Co. Global CA 1
OU = DSTCA E1
O = Digital Signature Trust Co.
SHA-1 Fingerprint: 81:96:8B:3A:EF:1C:DC:70:F5:FA:32:69:C2:92:A3:63:5B:D1:23:D3

Builtin Object Token: Digital Signature Trust Co. Global CA 3
OU = DSTCA E2
O = Digital Signature Trust Co.
SHA-1 Fingerprint: AB:48:F3:33:DB:04:AB:B9:C0:72:DA:5B:0C:C1:D0:57:F0:36:9B:46

I received email from the representative of IdenTrust saying that these two root certificates are no longer in use, and should be removed from the Mozilla root store.
Renne, Please confirm that the data in this bug description is correct.
Kathleen,
We confirm that the roots can be removed.
Thank you.
Depends on: 1214729
I have checked the test build 
https://bugzilla.mozilla.org/show_bug.cgi?id=1214729#c2
and confirm that these root certs have been removed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: Removed in NSS 3.21, planned for Firefox 44
Duplicate of this bug: 847604
You need to log in before you can comment on or make changes to this bug.