Closed Bug 1205209 Opened 6 years ago Closed 6 years ago

[RTSP]When user connects a special RTSP link, the crash will happen.

Categories

(Firefox OS Graveyard :: RTSP, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:2.5+, firefox44 fixed, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S9 (16Oct)
blocking-b2g 2.5+
Tracking Status
firefox44 --- fixed
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: wangxin, Assigned: jhao)

References

Details

(Keywords: crash, regression, Whiteboard: [2.5-aries-test-run-2])

Attachments

(3 files, 1 obsolete file)

[1.Description]:
[Aries KK v2.5][Flame v2.5]The crash happened on RTSP streaming.
While device  opens a special RTSP URL, the will crash happen.
Here are the detail information:
 -Title
   ~B2G 43.0a1 Crash Report [@ pthread_mutex_lock_impl | libmozglue.so@0x2c449 ]
 -Crash report
  ~https://crash-stats.mozilla.com/report/index/56e581a9-03b8-4902-bdfe-572bc2150916

See log:"logcat_1120.txt"
See video: "Aries_v2.5.3GP"

[2.Testing Steps]: 
1. Connect a network in "Settings".
2. Open Browser and go to "rtsp://184.72.239.149/vod/mp4:BigBuckBunny_175k.mov".
3. Wait for the page to load completely.

[3.Expected Result]: 
3. The page should load completely.

[4.Actual Result]: 
3. The crash will happen.

[5.Reproduction build]: 
Device: Flame KK v2.5 (Affected)
Build ID               20150915150223
Gaia Revision          d2e5c49440bf8410ae747b15c0dd11c54053ef3e
Gaia Date              2015-09-15 07:18:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5d61714cf5c3ec2440e9491ba30893ac37ca06c2
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150915.182947
Firmware Date          Tue Sep 15 18:29:57 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Affected)
Build ID               20150916005824
Gaia Revision          994ff1537c2d7ca4d1658806c50f3ceba1053f9b
Gaia Date              2015-09-15 12:54:59
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bd52dfa335821853c69c2fa559edf3e59d55c6f5
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150916.001741
Firmware Date          Wed Sep 16 00:17:49 UTC 2015
Bootloader             s1

Device: Flame KK 2.2 (Unaffected) 
Build ID               20150915032502
Gaia Revision          7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gaia Date              2015-09-09 13:06:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0d9c46d01861
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150915.065222
Firmware Date          Tue Sep 15 06:52:33 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12921
Severity: normal → major
Keywords: regression
[Blocking Requested - why for this release]:
Nominate. It is a 100% crash&regression bug.

Hi No-jun,

Could you help to dispatch this bug? thanks. :)
blocking-b2g: --- → 2.5?
Flags: needinfo?(npark)
Hmm, not exactly sure who would know more aobut this, since I'm not even sure what RTSP is.  Naoki, could you help out with this bug please?
Flags: needinfo?(npark) → needinfo?(nhirata.bugzilla)
Hi, Ethan,

Could you help me assign this bug to developer?
Thank you.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(ettseng)
Keywords: crash
Jonathan,
This is a regression and critical bug. Please help to investigate it.
Assignee: nobody → jhao
Status: NEW → ASSIGNED
Flags: needinfo?(ettseng)
The RTSP link (BigBuckBunny) in comment 0 is a basic test case. If we can reproduce this bug, we should mark it as 2.5+.
I can reproduce this bug on Flame-kk.
Blocks: 1207964
Blocks 2.5. Ethan in Triage meeting says the fix will be coming in this week.
blocking-b2g: 2.5? → 2.5+
Attached patch bug-1205209-fix.patch (obsolete) — Splinter Review
RtspOmxReader overwrites the function that initializes mStreamSource,
so we need to check if mStreamSource is null before using it.

Hi Benjamin,
Could you review this patch? It should fix RTSP.
Attachment #8670588 - Flags: review?(bechen)
=== Note ===
The assertion which causes the RTSP crash was added in bug 1190238 (Remove MediaResource::Read/Seek/Tell API).
This bug reminds us again we have to add automation test for RTSP to avoid such regression in the future. Jonathan, we should try to make it happen in 2.5 if possible (Bug 1032111 - [RTSP] Basic RTSP test case on ICS emulator).
See Also: → 1190238
Sorry for causing the regression.

The original behaviour was to query the decoder's resource Tell(). Which for RtspMediaResource always returned 0.

So the patch provided will work.

But are their any other OMX readers not setting mStreamSource and that could return a position in the stream != 0 ?
Comment on attachment 8670588 [details] [diff] [review]
bug-1205209-fix.patch

Review of attachment 8670588 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, the fix is simple.
Attachment #8670588 - Flags: review?(bechen) → review+
> But are their any other OMX readers not setting mStreamSource and that could
> return a position in the stream != 0 ?

As far as I know, RtspOmxReader is the only class inheriting MediaOmxReader
Keywords: checkin-needed
add r=bechen to patch summary
Attachment #8671214 - Flags: review?(jhao)
Attachment #8670588 - Attachment is obsolete: true
Attachment #8671214 - Flags: review?(jhao) → review+
https://hg.mozilla.org/mozilla-central/rev/55f6d8363666
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S9 (16Oct)
Jonathan and Benjamin,
Thank you for fixing this bug! Good job! ^o^
This bug has been verified as pass on latest Flame v2.5 and Aries KK v2.5.
Same STR as comment 0
Reproduce Rate: 0/10

Flame 2.5(pass):
Build ID               20151009150221
Gaia Revision          1609aecaba381c14eff95d5084e59280f53b7d8b
Gaia Date              2015-10-09 07:16:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c00e93135684441d065791f4f98a338b872d0420
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151009.183801
Firmware Date          Fri Oct  9 18:38:15 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Aries v2.5(pass):
Build ID               20151010002512
Gaia Revision          74b0d4b17f39d238a7997800bd9363d3c60f20c3
Gaia Date              2015-10-09 19:27:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/d1bb0de19476541cd517ab14017e7fedbd9f13e3
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151009.234251
Firmware Date          Fri Oct  9 23:42:59 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.