Assertion failure: !self->mInitPromise.IsEmpty(),

RESOLVED FIXED in Firefox 43

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

(Blocks: 1 bug, {assertion, intermittent-failure, regression})

Trunk
mozilla44
assertion, intermittent-failure, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 fixed, firefox44 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
From https://bugzilla.mozilla.org/show_bug.cgi?id=1105760#c465


PROCESS | 1863 | Assertion failure: !self->mInitPromise.IsEmpty(), at
/builds/slave/fx-team-l64-d-0000000000000000/build/src/dom/media/mediasource/MediaSourceDemuxer.cpp:66
PROCESS-CRASH | /media-source/SourceBuffer-abort-readyState.html | application
crashed [@
nsRunnableFunction<mozilla::MediaSourceDemuxer::NotifyDataArrived(uint32_t,
int64_t)::<lambda()> >::Run]
TEST-UNEXPECTED-CRASH | /media-source/SourceBuffer-abort-readyState.html |
expected OK
SSLError: [Errno 1] _ssl.c:1242: error:1409F07F:SSL
routines:SSL3_WRITE_PENDING:bad write retry
SSLError: [Errno 1] _ssl.c:1242: error:1409F07F:SSL
routines:SSL3_WRITE_PENDING:bad write retry
SSLError: [Errno 1] _ssl.c:1242: error:1409F07F:SSL
routines:SSL3_WRITE_PENDING:bad write retry
Return code: 1


We have a race accessing the init promise should shutdown occurs prior everything.
I had thought about and thought that it didn't matter. Prove njn's point I gather ; there's no such thing as a trivial race
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1206331
(Assignee)

Updated

4 years ago
Keywords: assertion, intermittent-failure
(Assignee)

Comment 2

4 years ago
Can also remove mInitDone member as that information is redundant with the init promise being present
Attachment #8663476 - Flags: review?(cpearce)
(Assignee)

Updated

4 years ago
Assignee: nobody → jyavenard
Attachment #8663476 - Flags: review?(cpearce) → review+
https://hg.mozilla.org/mozilla-central/rev/44be220d93ec
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
(Assignee)

Comment 5

4 years ago
Comment on attachment 8663476 [details] [diff] [review]
[MSE] Remove assertion.

Approval Request Comment
[Feature/regressing bug #]:1204757
[User impact if declined]: Assert.
[Describe test coverage new/current, TreeHerder]: in central
[Risks and why]: Low, removing assertion
[String/UUID change made/needed]: none
Attachment #8663476 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 6

4 years ago
Seems this one flew under the radar... Any particular reason for the request to still be pending?

thank you
Flags: needinfo?(sledru)
Comment on attachment 8663476 [details] [diff] [review]
[MSE] Remove assertion.

Because I am managing 42 and not 43. Therefor, I am watching only the beta uplift requests.
Anyway, taking it to fix the assert.
Flags: needinfo?(sledru)
Attachment #8663476 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 8

4 years ago
Ah ok . I see.. thanks
You need to log in before you can comment on or make changes to this bug.