Closed Bug 1205561 Opened 6 years ago Closed 5 years ago

[RTL] Responsive design mode has wrong direction (position) in RTL locales

Categories

(DevTools :: Responsive Design Mode, defect)

defect
Not set
normal

Tracking

(firefox41 wontfix, firefox42 wontfix, firefox43 wontfix, firefox44 wontfix, firefox47 wontfix, firefox48 affected, firefox49 affected, firefox-esr38 wontfix, firefox-esr45 affected, firefox50 affected)

RESOLVED FIXED
Tracking Status
firefox41 --- wontfix
firefox42 --- wontfix
firefox43 --- wontfix
firefox44 --- wontfix
firefox47 --- wontfix
firefox48 --- affected
firefox49 --- affected
firefox-esr38 --- wontfix
firefox-esr45 --- affected
firefox50 --- affected

People

(Reporter: magicp.jp, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: rtl)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150916030203

Steps to reproduce:

1. Run any Firefox version in Arabic.
2. Open Responsive design mode in developer tools.


Actual results:

Responsive design mode has wrong direction (position).


Expected results:

If Responsive design UI is in the right side, devtools-responsiveui-resizebarV and devtools-responsiveui-resizehandle should be opposite position in RTL locales.
Or if keep their position, Responsive design UI should be in the left side (same with LTR locales).
Blocks: 137995
Component: Untriaged → Developer Tools: Responsive Mode
Keywords: rtl
OS: Unspecified → All
Hardware: Unspecified → All
Duplicate of this bug: 1210343
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 43 Branch → unspecified
Fixed by the new RDM that centers the viewport.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: enable-rdm
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.