Closed Bug 12057 Opened 21 years ago Closed 19 years ago

[FEATURE] Partial tooltips hookup

Categories

(SeaMonkey :: UI Design, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: don, Assigned: bugs)

References

Details

(Keywords: meta, Whiteboard: [nsbeta2-] [nsbeta3-])

Priority: P3 → P1
Whiteboard: Need to find an owner for this
Target Milestone: M11
Blocks: 10983
Blocks: 12659
Summary: [FEATURE] Partial tooltips hookup → [BETA][FEATURE] Partial tooltips hookup
Blocks: 13355
No longer blocks: 12659
Summary: [BETA][FEATURE] Partial tooltips hookup → [FEATURE] Partial tooltips hookup
No longer a beta issue.
No longer blocks: 13355
Blocks: 13355
QA Contact: beppe → claudius
Target Milestone: M11 → M13
OK, this may be a beta issue again.  Move to M13 while we decide ...
Assignee: don → rgoodger
Target Milestone: M13 → M14
Ben, can you handle some of this for beta 1?
Status: NEW → ASSIGNED
Sure, I'll take a look at this once I'm done molesting the Profile Manager.
No longer blocks: 10983
No longer blocks: 13355
Whiteboard: Need to find an owner for this
Removed dependency.
Tooltips and tabletips are explicitly post-beta, according to the latest doc
from Chris Saito.
no word yet from pink on the document.tooltipNode thing, so pushing past M14...
Target Milestone: M14 → M15
What's the plan for this feature for Beta 2?
this should be a simple but tedious hookup process. waiting on pink or similar 
to fix the popup positioning woes, then ready to go.
ben - do you have an ETA for this?  We depend on this infrastructure being there 
for some IM features.  thanks!
the infrastructure is almost complete. you can actually use tooltips now, but 
the positioning is incorrect (I think a bug is filed against pink)
Move to M16 for now ...
Target Milestone: M15 → M16
verah said that she and the other doc people wanted to take a crack at this...

reassigning to her...
Assignee: ben → verah
Status: ASSIGNED → NEW
Yup, we're going to learn how to do this. We've got most of the content written; 
now we just have to figure out how to do the hard part. Volunteers have already 
stepped forward to tutor us.
Status: NEW → ASSIGNED
Nominating for nsbeta2. Tooltip text has been written and checked in but they're 
not yet visible in daily builds -- they're turned off due to the numerous errors 
they generate. Reassigning to Mike Pinkerton who can close this when tooltips 
are working "perfectly."
Assignee: verah → pinkerton
Status: ASSIGNED → NEW
Keywords: nsbeta2
huh? what? they work now. they are in for mailnews and composer!
Assignee: pinkerton → verah
In mail and news *some* of them show up, but only for an instant and then they 
disappear. In Composer they mostly show up. Nothing in Navigator or in general 
UI items (such as task bar and Sidebar).

Reassigning to Ben to fix Navigator tooltips.

Is there a bug for the mail/news "instantly disappearing" tooltips?
Assignee: verah → ben
Yes, we have to fix this.  Move to M17.
Target Milestone: M16 → M17
*** Bug 39517 has been marked as a duplicate of this bug. ***
nbaca's comments from bug 39517:

Overview: Tooltips not appearing in the Taskbar for various items such as 
Browser, Mail, IM, Address Book...

Expected Results: Please refer to the Main Mail spec's Taskbar section. It 
states:

- If no accounts have new mail (regular icon), the ToolTip reads, "Mail & 
Newsgroups". 

- If any of the users accounts have new mail (BIF icon) the ToolTip 
reads, "Mail 
and Newsgroups. <n> new messages for <account name>.  <n> new messages for 
<account name>. etc. ". 
     
- No ToolTips are provided for new newsgroup postings. 

I Noticed that Taskbar tooltips aren't working for any component. Should this 
be 
logged as an XP Toolkit/Widgets bug?
Blocks: 38497
Adding dependencies
No longer blocks: 38497
Depends on: 9767, 23216, 39505
Depends on: 41120
I opened a new bug for the absence of task bar tooltips: bug # 41120
Depends on: 41123
I opened a new bug for the absence of browser tooltips: bug # 41123
Since verah's splitting up most of the tooltip issues and this "bug" really 
doesn't report anything, I'm going to turn this into a tracking bug (which is 
pretty much what it's become anyways).
Keywords: meta
Depends on: 39517
Ben, how much work is left for this?  Can we close this sucker now?
[nsbeta2-]
Whiteboard: [nsbeta2-]
Since this is now an "nsbeta-" tracking bug, I'm moving it out to M20.
Target Milestone: M17 → M20
Whiteboard: [nsbeta2-] → [nsbeta2-] [nsbeta3-]
Adding nsbeta3 keyword to bugs which already have nsbeta3 status markings so 
the queries don't get all screwed up.
Keywords: nsbeta3
This bug is ancient, and its scope vast. I'm closing this now as FIXED. There
are still more places that require tooltips, however I would prefer a more
specific bug/set of bugs for the windows that require it.

Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
agreed. resolving as VERIFIED Fixed.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.