Dragging a bookmark draws frame of entire window

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: mikepinkerton, Assigned: janv)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [driver:dbaron])

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
- 1/16/01 build, osx (prolly os9 as well)
- open bookmarks
- drag a bookmark

expected:
- single line outline of item selected

actual:
- drag entire frame of bookmark outliner. User has no idea what they are dragging.

This is a serious usability issue.
(Reporter)

Updated

17 years ago
Keywords: nsbeta1

Comment 1

17 years ago
Yeah, same thing happens for me with build 2001122106 using OS 9.1. Seems to be
another issue as well: If you try to drag a bookmark (Open manage bookmark
etc)to the trash bin (looks like entire frame of bookmark outliner ends up in
the trash...) you will find the bookmark you wanted to delete in the trash. But
it doesn´t disappear from the bookmark menu. Mozilla just makes a copy of the
bookmark instead of deleting it.
Is this at all related to what waterson landed yesterday (bug 119504)?
(Reporter)

Comment 3

17 years ago
dbaron: totally unrelated:

stefan: please, one problem per bugreport.
Whiteboard: [driver:dbaron]
Mac only outliner D&D issue. 
Assignee: ben → jaggernaut
Component: Bookmarks → XP Toolkit/Widgets
QA Contact: claudius → jrgm

Comment 5

17 years ago
This affects OS 9.1 and X for me.

Updated

17 years ago
Keywords: mozilla0.9.8

Comment 6

17 years ago
Is this the same as bug 121855 and bug 121187?  This is a serious mac
regression. Jan or bryner, any chance you can dig into this so we can have an
0.9.8 that doesn't suck for Mac users? I can try to search back through the
builds and find out when this broke (maybe tomorrow) but I believe it's as
recent as the last couple weeks. 

Comment 7

17 years ago
The mail threadpane dragging problem (and I think this bookmark problem)
happened sometime after Jan 9 and before Jan 16. I'll try to narrow it down to a
day's worth of checkins.

Comment 8

17 years ago
OK, I think I've narrowed this down. Drag (and drop) in outliner seems to work
as expected on the 15th builds and is broken on the 16th builds. It looks like
it could be the big landing from Jan Varga. 

Jan, can you take a look at this, bug 121855 and bug 121187. Thanks.

Assignee: jaggernaut → varga

Comment 9

17 years ago
adding hyatt in case he has any ideas. 
(Assignee)

Comment 10

17 years ago
sigh, sigh, sigh...
Sorry pink, I know that you warn me about this possible issue, but I was convinced
that it was well tested on mac by some guys.
Status: NEW → ASSIGNED
(Reporter)

Comment 11

17 years ago
this is an easy easy fix. just copy the code in messengerdnd.js that finds the
rect for the selected cells in an outliner, move that into some common place and
call it. pass that region into InvokeDragSession.

I'd do it myself, but i don't know where ben wants the common JS to live.

Comment 12

17 years ago
Jan, any progress here? This is the worst of the 0.9.8 blockers. I really don't
want to release a Mac milestone with seriously broken outliners. 
(Assignee)

Comment 13

17 years ago
Created attachment 66913 [details] [diff] [review]
partial backout of my changes

pink, could you play with this patch ?
(Assignee)

Comment 14

17 years ago
Created attachment 66919 [details] [diff] [review]
an experimental patch
(Reporter)

Comment 15

17 years ago
Comment on attachment 66919 [details] [diff] [review]
an experimental patch

this last patch from jan works. the drag hilighting is still pretty bad (lots
of jiggling and window corruption) but the outline is correct at least.

r=pink
Attachment #66919 - Flags: review+

Comment 16

17 years ago
What's the status here? This is our only major 0.9.8 blocker. Hyatt, hewitt,
blake, mscott, can one of you sr this?

Comment 17

17 years ago
Comment on attachment 66919 [details] [diff] [review]
an experimental patch

sr=blake
Attachment #66919 - Flags: superreview+

Comment 18

17 years ago
a=asa (on behalf of drivers) for checkin to 0.9.8
Keywords: mozilla0.9.8 → mozilla0.9.8+
(Assignee)

Comment 19

17 years ago
landed on the trunk and branch
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.