[System] After updating latest OTA , keyboard did not automatically show up on SIM Pin Screen

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: VladimirBelonenko, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Systemsfe][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8662565 [details]
logcat_20150917_1227.txt

Description:
When user updated latest OTA (dogfood-latest), the SIM PIN Screen show up without keyboard.

Repro Steps:
1) Enable Sim Pin
2) Update to Latest OTA to doogfood-latest
3) Restart the phone
4) Sim Pin screen appears after unlocking the phone
5) Observe that Sim Pin keyboard does not appear automatically.

Actual:
When user gets Sim Pin screen the keyboard does not appear automatically.

Expected:
The keyboard shows up automatically

Environmental Variables:
Device: Aries 2.5 kk Full Flash (319 mb)
Build ID: 20150917133514
Gaia: aede8622d780ec71f766a3ecccbff74c04aaba4e
Gecko: 8d4c37a86b576db4ef150dff715a89ff77e84bf5
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0


Repro frequency: 3/3
See attached: video clip and logcat
(Reporter)

Comment 1

3 years ago
We could not reproduce due to Uncompressing error on Flame 2.5
Result: We could not reproduce.

Environmental Variables:
Device: Flame 2.5 kk 
Build ID: 20150916030229
Gaia: 994ff1537c2d7ca4d1658806c50f3ceba1053f9b
Gecko: 3e8dde8f8c174cce2c0b65c951808f88e35d1875
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

------------------------------------------------------------------------------------------------------

We could not reproduce due to Uncompressing error on Flame 2.2
Result: We couldn't reproduce.

Environmental Variables:
Device: Flame 2.2 kk
Build ID: 20150811123013
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: 9295034c0ee3
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

3 years ago
(In reply to [:VladimirBelonenko] from comment #1)
> This issue also occurs on Flame 2.5
> Result: I was unable to OTA, due to Uncompressed error while updating
> 
> Environmental Variables:
> Device: Flame 2.5 kk 
> Build ID: 20150916030229
> Gaia: 994ff1537c2d7ca4d1658806c50f3ceba1053f9b
> Gecko: 3e8dde8f8c174cce2c0b65c951808f88e35d1875
> Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
> Version: 43.0a1 (2.5)
> Firmware Version: v18D
> User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
> 
> -----------------------------------------------------------------------------
> -------------------------
> This issue also occurs on Flame 2.2
> Result: I was unable to OTA, due to Uncompressed error while updating.
> 
> Environmental Variables:
Device: Flame 2.2
Build ID: 20150918002506
Gaia: d52d714afd14c6253ddac8fab63f29b8bcf59f2b
Gecko: 3ee82451dd67
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
We are unable to check this on Flame because we are blocked by bug 1199863.
Flags: needinfo?(ktucker)
Work around is that you tap off the keyboard to dismiss the keyboard and tap back onto the field.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][severe]
Is this correct that this bug only shows on Aries 2.5 kk Full Flash (319 mb)? Why are we doing 319MB testing on aries?
Flags: needinfo?(nhirata.bugzilla)
No, the report is not on a 319 mb aries device.  I think he meant to place in Flame.

It doesn't seem to happen on a recent build.  The UI seems to have changed.  So this now makes it a 2.5 specific issue.
Flags: needinfo?(nhirata.bugzilla)

Comment 7

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.