Closed Bug 1206304 Opened 5 years ago Closed 4 years ago

Created text tracks don't appear in the textTracks list

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1242599
Tracking Status
firefox43 --- affected

People

(Reporter: yury, Assigned: bechen)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Attached file Test case
The created TextTrack (via document.createElement) doesn't appear in the video element's textTracks property, until the track's track property accessed.

        var track = document.createElement('track');
        track.kind = "subtitles"; track.label = "English"; track.srclang = "en";
        video.appendChild(track);
        // track.track; // when un-commented, the line below prints 1
        console.log(video.textTracks.length); // prints 0
Blocks: 1131952
In bug 1214027 I've found that textTracks is updated asynchronously, so if I put the console.log() inside of a setTimeout, then textTracks is defined.
See Also: 1214027
See Also: → 1242599
Assignee: nobody → bechen
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1242599
You need to log in before you can comment on or make changes to this bug.