Closed Bug 1206368 Opened 4 years ago Closed 4 years ago

Nexus 4 KK on TaskCluster and blobfree

Categories

(Taskcluster :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla44

People

(Reporter: gerard-majax, Assigned: gerard-majax)

References

Details

(Whiteboard: [systemsfe][tc-build-support])

Attachments

(1 file, 8 obsolete files)

From bug 1187946:

(In reply to Michael Shal [:mshal] from comment #5)
> I updated base_job_flags.yml & also added blobfree for nexus-5l per our IRC
> conversation. The nexus-4 builds failed with blobfree enabled, so if that's
> required someone will have to dig into it some more :)

This is probably because the nexus 4 build pushed on taskcluster is a Nexus 4 JB and not a KK.
Looks like we don't even have KK build at all :)
Attachment #8663270 - Attachment is obsolete: true
It's failing to download stuff, but I don't understand anything about this ... And the previous bug was no information whatsoever on this topic.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8703c9921f5b
Flags: needinfo?(wcosta)
Flags: needinfo?(garndt)
Depends on: b2g-addon
Attachment #8663279 - Attachment is obsolete: true
I believe this is related to 1206383 that has been discussed on IRC.  Really the issue is that the package we are trying to upload as a cache is exceeding the maximum size of a PUT request (5gb).  The only way around this is trying to make the cached object smaller (perhaps doing a shallow clone) and moving towards multi-part uploads, which would require taskcluster-queue changes if it's possible.
Flags: needinfo?(garndt)
Right, after checking, nexus-5-l/sources.xml do not references Gecko repo, while I did. That probably explains why.
Attachment #8663288 - Attachment is obsolete: true
Clearing NI
Flags: needinfo?(wcosta)
Depends on: 1207092
Attachment #8663368 - Attachment is obsolete: true
Attachment #8664171 - Attachment is obsolete: true
https://treeherder.mozilla.org/#/jobs?repo=try&revision=be9e312c67b4
Should be a userdebug/eng build with blobfree.
Blocks: b2g-addon
No longer depends on: b2g-addon
Whiteboard: [systemsfe]
Successfully flashed device.
Attachment #8664173 - Flags: review?(wcosta)
Comment on attachment 8664173 [details] [diff] [review]
Nexus 4 Kitkat build on TaskCluster

Review of attachment 8664173 [details] [diff] [review]:
-----------------------------------------------------------------

I found just a minor cache config issue, otherwise lgtm. It might be worth assign a second reviewer for the b2g/config files, as I don't have much experience on that. Maybe mshal.

::: testing/taskcluster/tasks/builds/b2g_nexus_4_kk_eng.yml
@@ +10,5 @@
> +  metadata:
> +    name: '[TC] B2G Nexus 4 KK Eng'
> +  payload:
> +    cache:
> +      build-nexus-4-kk-eng: /home/worker/object-folder

The cache configuration is outdated, you can use flame or aries build task files as a template.

::: testing/taskcluster/tasks/builds/b2g_nexus_4_kk_user.yml
@@ +10,5 @@
> +  metadata:
> +    name: '[TC] B2G Nexus 4 KK User'
> +  payload:
> +    cache:
> +      build-nexus-4-kk-user: /home/worker/object-folder

The cache configuration is outdated, you can use flame or aries build task files as a template.
Attachment #8664173 - Flags: review?(wcosta) → review+
Attachment #8664173 - Attachment is obsolete: true
Attachment #8664870 - Flags: review?(wcosta)
Attachment #8664870 - Flags: review?(mshal)
Comment on attachment 8664870 [details] [diff] [review]
Nexus 4 Kitkat build on TaskCluster

Carrying r+, addressed cache.
Attachment #8664870 - Flags: review?(wcosta) → review+
Michael, it is my understanding I should be removing completely sources.xml and that B2G Bumper bot will do the job.
Flags: needinfo?(mshal)
Comment on attachment 8664870 [details] [diff] [review]
Nexus 4 Kitkat build on TaskCluster

Yeah, sources.xml will just get overwritten by b2g bumper. I suppose it might not build correctly until b2g bumper runs though, but either way it's not a big deal.

We do need to also land the mozharness/configs/b2g_bumper/master.py change to hg.mozilla.org/build/mozharness and merge it to production, since that uses the old mozharness repo rather than the in-tree version. Ping me or ask in #releng if you want a hand doing that.
Flags: needinfo?(mshal)
Attachment #8664870 - Flags: review?(mshal) → review+
mozharness changes were pushed: http://hg.mozilla.org/build/mozharness/rev/e00a599b7341
Thank Michael!
Depends on: 1208024
Rebased, removed sources.xml and try jobs
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad6f5ad5d139
Attachment #8664870 - Attachment is obsolete: true
Attachment #8665849 - Flags: review+
And that is all green!
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/dcff442c846a
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Whiteboard: [systemsfe] → [systemsfe][tc-build-support]
You need to log in before you can comment on or make changes to this bug.