FFmpeg decoder will crash should we failed to create decoder

RESOLVED DUPLICATE of bug 1206568

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1206568
2 years ago
2 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

(Blocks: 1 bug)

43 Branch
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

Attachments

(1 obsolete attachment)

(Assignee)

Description

2 years ago
There are two reasons for this:

1- If FFmpeg failed to create a decoder ; and a function such as Drain is called : it will cause a null deref.
2- The MediaFormatReader attempts to flush / drain the decoder even when we failed to create one.
(Assignee)

Updated

2 years ago
Assignee: nobody → jyavenard
(Assignee)

Comment 1

2 years ago
Created attachment 8663501 [details] [diff] [review]
Prevent potential null deref when flushing decoder.
(Assignee)

Comment 2

2 years ago
Comment on attachment 8663501 [details] [diff] [review]
Prevent potential null deref when flushing decoder.

no wonder you had conflict ; the r? wasn't set :(
Attachment #8663501 - Flags: review?(cpearce)
(Assignee)

Comment 3

2 years ago
Going to merge this bug with bug 1206568 as I don't want to wait and it also fixed the issue (albeit differently)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1206568
(Assignee)

Updated

2 years ago
Attachment #8663501 - Attachment is obsolete: true
Attachment #8663501 - Flags: review?(cpearce)
You need to log in before you can comment on or make changes to this bug.