APN Settings does not select the correct item when user cancelled the dialog

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: gasolin, Assigned: scottwu)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
when dialog is shown, no matter I press any button, the radio will set to current tapped item. 

Step:

1. open 'data roaming' in Settings > Cellular
2. open Settings > Cellular & Data > APN Settings > Data Settings
3. add any new APN setting
4. select the radio butotn near the new APN settings, then cancel the dialog 

result:

selected to the new APN settings

expect:

move back to original APN settings
(Reporter)

Comment 1

3 years ago
set regressionwindow-wanted to make sure if its a regression
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
Depends on: 1196178
Related to Bug 1196179.
See Also: → bug 1196179

Updated

3 years ago
QA Contact: yelanying

Comment 3

3 years ago
b2g-inbound Regression Window:
Last Working Environmental Variables:
Flame KK v2.5
Build ID               20150731172337
Gaia Revision          1a814a4e7fa57132cdc0512a6c363b6b9471431d
Gaia Date              2015-07-31 23:07:21
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/423b23f385d7
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150803.063420
Firmware Date          Mon Aug  3 06:34:32 EDT 2015
Base Image         v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Flame KK v2.5
Build ID               20150731174837
Gaia Revision          9a45076c37ad2139f25194613916af5efb55bbc7
Gaia Date              2015-08-01 00:09:41
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/3f27403cf187
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150815.062121
Firmware Date          Sat Aug 15 06:21:33 EDT 2015
Base Image         v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          9a45076c37ad2139f25194613916af5efb55bbc7
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/423b23f385d7

First Broken Gecko & Last Working Gaia – issue DOES NOT repro
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/3f27403cf187
Gaia Revision          1a814a4e7fa57132cdc0512a6c363b6b9471431d

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/1a814a4e7fa57132cdc0512a6c363b6b9471431d...9a45076c37ad2139f25194613916af5efb55bbc7

Possibly caused by bug 1185269

Comment 4

3 years ago
Hi Kevin, 
  
   This bug is probably caused by bug 1185269, could you help to check?
Thank you.
Flags: needinfo?(kevingrandon)

Updated

3 years ago
QA Whiteboard: [MGSEI-Triage+]
Keywords: regressionwindow-wanted
(Reporter)

Comment 5

3 years ago
2.5 regression
blocking-b2g: --- → 2.5?
Keywords: regression

Comment 6

3 years ago
Created attachment 8665240 [details]
Aries KK_v2.5.3gp

I set "Tracking Flags:", because this bug can be repro on latest Flame KK v2.5 & Aries KK v2.5, and can't be repro on latest Flame KK v2.2.

Actual results:
On Flame v2.2, move back to original APN settings. 
On Flame v2.5&Aries v2.5, switch to the new APN settings. 

Reproduce rate: 0/10(Flame v2.2), 10/10(Flame v2.5&Aries v2.5)

See attachments: Aries KK_v2.5.3gp and logcat_1034.txt

Device: Flame KK v2.2 (Unaffected)
Build ID               20150923032502
Gaia Revision          5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gaia Date              2015-09-21 11:20:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/65ddad73ad6b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150923.070045
Firmware Date          Wed Sep 23 07:00:57 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.5 (Affected)
Build ID               20150923150203
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4a46de29431baa621d98d8f1168e43297ce1a916
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150923.184655
Firmware Date          Wed Sep 23 18:47:17 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Affected)
Build ID               20150923233246
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f1dffc8682fbba463cb4bb305f293ddcccbc20b4
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150923.225204
Firmware Date          Wed Sep 23 22:52:12 UTC 2015
Bootloader             s1

Comment 7

3 years ago
Created attachment 8665242 [details]
logcat_1034.txt

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
(Assignee)

Comment 8

3 years ago
Found the issue. Will submit a patch shortly.
Assignee: nobody → scwwu
Created attachment 8665343 [details] [review]
[gaia] scottwu:1206600-APN-settings-cancel-selection > mozilla-b2g:master
Scott, thank you very much for fixing my mistake. I owe you one!
Flags: needinfo?(kevingrandon)
(Assignee)

Comment 11

3 years ago
Comment on attachment 8665343 [details] [review]
[gaia] scottwu:1206600-APN-settings-cancel-selection > mozilla-b2g:master

No problem Kevin! I've got the fix to work but not sure if it's a good way. I'd appreciate if you could take a quick look and let me know what you think.

Thanks Kevin and Fred!
Attachment #8665343 - Flags: review?(kevingrandon)
Attachment #8665343 - Flags: review?(gasolin)
Comment on attachment 8665343 [details] [review]
[gaia] scottwu:1206600-APN-settings-cancel-selection > mozilla-b2g:master

This looks great to me. I think you still need a review from a settings peer though, so hopefully Fred can take a look. Thanks for the patch!
Attachment #8665343 - Flags: review?(gasolin) → feedback+
Comment on attachment 8665343 [details] [review]
[gaia] scottwu:1206600-APN-settings-cancel-selection > mozilla-b2g:master

Oops, I flipped the wrong switch there.
Attachment #8665343 - Flags: review?(kevingrandon) → review?(gasolin)
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
(Reporter)

Comment 14

3 years ago
Comment on attachment 8665343 [details] [review]
[gaia] scottwu:1206600-APN-settings-cancel-selection > mozilla-b2g:master

great solution to deal the radio click during event capturing!
Attachment #8665343 - Flags: review?(gasolin) → review+
(Assignee)

Comment 15

3 years ago
Thanks Fred and Kevin for reviewing and feedback :)

It's been merged.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: APN Settings selects the correct item when user cancelled the roaming dialog. 
See attachment: verified_Aries_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20151008150210
Gaia Revision          e698df503ff700eb5782e3d50c6eb753567d3451
Gaia Date              2015-10-08 17:26:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e5f1bc63ad52d0eb86f7fb838226ca6036774660
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151008.182756
Firmware Date          Thu Oct  8 18:28:08 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151008233852
Gaia Revision          e698df503ff700eb5782e3d50c6eb753567d3451
Gaia Date              2015-10-08 17:26:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/23b7f289df923c01e692299fcd4be7029de8b155
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151008.225742
Firmware Date          Thu Oct  8 22:57:51 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
Created attachment 8671733 [details]
verified_Aires_v2.5.3gp
You need to log in before you can comment on or make changes to this bug.