Closed Bug 1206837 Opened 4 years ago Closed 4 years ago

[Gallery] Bad animation happens when user switches to the full screen mode

Categories

(Core :: Layout, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED DUPLICATE of bug 1206418
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: MaxIvanov, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Description:
In a single image view mode user will see a bad animation while switching to the full screen mode 


Repro Steps:
1) Update a Flame to 20150921030234
2) Open the Gallery app
3) Single tap on any image
4) Tap on centre of a screen
5) Observe action bar behaviour 

Actual:
Wrong animation, action bar disappears from the bottom  then appears on the top of the screen, then disappears again. 


Expected:
Action bar with a tools should just disappears 


Notes:

Environmental Variables:
Device: Flame 2.5
Build ID: 20150921030234
Gaia: e67d319d0854e32e23210784eb9c4e1b8a025adb
Gecko: d49db60f3894b375ff7d905e11d639939c2f3b3a
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0


Repro frequency: (10/10)
See attached: (video clip, logcat)
https://youtu.be/Mz38PqtvAIM
This issue DOES occur on Flame 2.5 and Aries 2.5 and does NOT on Flame 2.2 
Result: Wrong animation, action bar disappears from the bottom  then appears on the top of the screen, then disappears again.

Device: Flame 2.5 Kk Full flash (319mb)
Build ID: 20150921030234
Gaia: e67d319d0854e32e23210784eb9c4e1b8a025adb
Gecko: d49db60f3894b375ff7d905e11d639939c2f3b3a
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
--------------------------------------------------------------------

Device: Aries Master
Build ID: 20150921152621
Gaia: 2d370fa35c1a0ee2a637e3772c0843586a5f96c9
Gecko: 039a8490891595736b16a3ccb17f025f4dcf13eb
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:

This looks bad and is a regression so nominating this to block.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Contact: sleedavid
Mozilla  inbound window: 

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150917233553
Gaia: 2082894c8e974b0c371e4dec298e0ad0f3ac56b1
Gecko: 7641104770a80015e63597b58cb312fefcbd9ab4
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150917234653
Gaia: 2082894c8e974b0c371e4dec298e0ad0f3ac56b1
Gecko: 621ab19e86db28c38bbbf9119fbf6831ea344c54
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

PushLog: 

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7641104770a80015e63597b58cb312fefcbd9ab4&tochange=621ab19e86db28c38bbbf9119fbf6831ea344c54

This issue appears to be caused by changes made in bug 1097464
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Thinker this issue seems to have been caused by the change for bug 1097464.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(tlee)
I think this is the same problem as Bug 1206418.
Flags: needinfo?(tlee)
blocking-b2g: 2.5? → 2.5+
Component: Gaia::Gallery → Layout
Priority: -- → P2
Product: Firefox OS → Core
Depends on: 1206418
Status: NEW → RESOLVED
Closed: 4 years ago
No longer depends on: 1206418
Resolution: --- → DUPLICATE
Duplicate of bug: 1206418
You need to log in before you can comment on or make changes to this bug.