Closed Bug 1206418 Opened 4 years ago Closed 4 years ago

Flickering artifacts after landing patches from bug 1097464

Categories

(Core :: Graphics, defect, major)

44 Branch
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla44
Tracking Status
firefox42 --- unaffected
firefox43 + unaffected
firefox44 + unaffected
firefox45 --- unaffected
firefox46 --- verified
b2g-v2.5 --- unaffected
b2g-master --- fixed

People

(Reporter: Virtual, Assigned: sinker)

References

Details

(Keywords: nightly-community, regression)

Attachments

(5 files, 4 obsolete files)

[Tracking Requested - why for this release]: Regression
This seems to be duplication of Bug 1205630
Could be, but I have APZ disabled per not using e10s.
I can't reproduce this bug, but I noticed that similar problem of animation happens in the content.
And by backout bug 1097464, my problem has gone.
I am not sure, but it may relate to bug 779598.  So, I would look into it, and find out a solution ASAP.
Flags: needinfo?(tlee)
Is it only happening on windows 7.  I don't see it on Linux.
This also happens on Mac OS 10.10.
I can reproduce it on Linux too, now.
Severity: normal → major
OS: Windows 7 → All
Hardware: x86_64 → All
(In reply to Toshihiro Yamada from comment #7)
> I can't reproduce this bug, but I noticed that similar problem of animation
> happens in the content.
> And by backout bug 1097464, my problem has gone.
Could you show me the test case you have?
Flags: needinfo?(yamadat501)
(In reply to Thinker Li [:sinker] from comment #13)
> (In reply to Toshihiro Yamada from comment #7)
> > I can't reproduce this bug, but I noticed that similar problem of animation
> > happens in the content.
> > And by backout bug 1097464, my problem has gone.
> Could you show me the test case you have?

Unfortunately, my case needs account registration because I found it in the browser-game...
Flags: needinfo?(yamadat501)
See Also: → 1206841
Assignee: nobody → tlee
Status: NEW → ASSIGNED
Attached video screencast2.mp4
(In reply to Thinker Li [:sinker] from comment #13)
> (In reply to Toshihiro Yamada from comment #7)
> > I can't reproduce this bug, but I noticed that similar problem of animation
> > happens in the content.
> > And by backout bug 1097464, my problem has gone.
> Could you show me the test case you have?

Go to http://markeedragon.com/ and move you mouse pointer between "FEATURED" and "<"
I see this on windows 10 and osx 10.11 as well
(In reply to Virtual_ManPL [:Virtual] from comment #16)
> Created attachment 8665639 [details]
> screencast2.mp4
> 
> (In reply to Thinker Li [:sinker] from comment #13)
> > (In reply to Toshihiro Yamada from comment #7)
> > > I can't reproduce this bug, but I noticed that similar problem of animation
> > > happens in the content.
> > > And by backout bug 1097464, my problem has gone.
> > Could you show me the test case you have?
> 
> Go to http://markeedragon.com/ and move you mouse pointer between "FEATURED"
> and "<"

Yes, Confirmed the problem and the patch fixes it.
Great! If we can land and verify this fix, it may be good to uplift it to 43.
In retrospect as I come across the many regressions from bug 1097464, I think we may be better off backing out of aurora and not uplifting patches. Let's talk about that and reconsider on Monday.
--
Attachment #8664771 [details] [diff] - Attachment is obsolete: true
Attachment #8666436 - Flags: review?(roc)
Attachment #8664771 - Attachment is obsolete: true
Attachment #8666436 - Flags: review?(roc)
--
Attachment #8666436 [details] [diff] - Attachment is obsolete: true
Attachment #8666482 - Flags: review?(roc)
Attachment #8666436 - Attachment is obsolete: true
Blocks: 1206818
Blocks: 1207529
Blocks: 1206837
Blocks: 1206841
Blocks: 1206631
Blocks: 1207420
Blocks: 1206778
Comment on attachment 8666482 [details] [diff] [review]
Compute origin of animations from the parent frame, v3

Review of attachment 8666482 [details] [diff] [review]:
-----------------------------------------------------------------

Add a reftest please!!!
Attachment #8666482 - Flags: review?(roc) → review+
--
Attachment #8666482 [details] [diff] - Attachment is obsolete: true
Attachment #8666482 - Attachment is obsolete: true
Attachment #8666598 - Attachment is obsolete: true
This causes some animations on fxos new homescreen to disappear too - just tested and this patch fixes those issues.
Attached video screencast on mac.mov
Just verified that a similar effect seen on Mac is fixed by this patch
No longer blocks: 1207529
Duplicate of this bug: 1207529
[Blocking Requested - why for this release]: In bug, the contact app in Firefox OS shows a long awkward animation while seeing the details of a contact. This animation can be easily spotted by a regular user, see attachment 8664758 [details].
blocking-b2g: --- → 2.5?
https://hg.mozilla.org/mozilla-central/rev/547905a13380
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Marking Firefox 43 as unaffected per Bug #1097464 Comment #94
> Backed out of aurora:
> https://hg.mozilla.org/releases/mozilla-aurora/rev/8d8e196388b2
Status: RESOLVED → VERIFIED
Summary: Dragging and dropping a tab causes artifacts on tab bar → Flickering artifacts after landing patches from bug 1097464
Version: 43 Branch → 44 Branch
Blocks: 1209742
Backed out from Aurora44 so that bug 1097464 could be backed out cleanly. It remains fixed on Fx45+ where bug 1097464 is still landed.

https://hg.mozilla.org/releases/mozilla-aurora/rev/60c3a5f91464
blocking-b2g: 2.5? → ---
Blocks: 1240783
The change that caused this regression was backed out from Firefox 45. A current Developer Edition build should now work correctly, or you can wait until 45 goes to Beta some time next week.

https://hg.mozilla.org/releases/mozilla-aurora/rev/64ec448f156d
You need to log in before you can comment on or make changes to this bug.