Closed Bug 1206841 Opened 4 years ago Closed 4 years ago

[Homescreen] Homescreen icons will flicker/jump around when adjusting to make room for moved icon

Categories

(Core :: Graphics: Layers, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED DUPLICATE of bug 1206418
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- fixed

People

(Reporter: AdamA, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark] [systemsfe][gfx-noted])

Attachments

(1 file)

Description:
When the user is moving an app around on the homescreen and other app icons have to move to make room for the icon they will flicker/jump around the homescreen. The movemoent seems to befurther depending on how far down you are scrolled in the homescreen.

Repro Steps:
1) Update a Aries to 20150921152621
2) Long press an app on the homescreen
3) Move the app in front of other app icons
4) Observe app icons as they move

Actual:
The moving app icons will flicker/jump around the screen

Expected:
It is expected that the app icons do not jump around the screen when moving.

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150921152621
Gaia: 2d370fa35c1a0ee2a637e3772c0843586a5f96c9
Gecko: 039a8490891595736b16a3ccb17f025f4dcf13eb
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/VRIW9PEXEQA), logcat
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150921073455
Gaia: 2d370fa35c1a0ee2a637e3772c0843586a5f96c9
Gecko: 039a8490891595736b16a3ccb17f025f4dcf13eb
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
The moving app icons will flicker/jump around the screen
------------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20150921073455
Gaia: 2d370fa35c1a0ee2a637e3772c0843586a5f96c9
Gecko: 039a8490891595736b16a3ccb17f025f4dcf13eb
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
The moving app icons do not jump around the screen
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:

This looks bad and it's a recent regression so nominating this to block.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark] [systemsfe]
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
mozilla-inbound regression window:

Last Working
Device: Flame 2.5
BuildID: 20150917233553
Gaia: 2082894c8e974b0c371e4dec298e0ad0f3ac56b1
Gecko: 7641104770a80015e63597b58cb312fefcbd9ab4
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken
Device: Flame 2.5
BuildID: 20150917234653
Gaia: 2082894c8e974b0c371e4dec298e0ad0f3ac56b1
Gecko: 621ab19e86db28c38bbbf9119fbf6831ea344c54
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=7641104770a80015e63597b58cb312fefcbd9ab4&tochange=621ab19e86db28c38bbbf9119fbf6831ea344c54

Caused by changes made in Bug 1097464.
Blocks: 1097464
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Thinker this issue seems to have been caused by the changes made for bug 1097464.  Can you please take a look?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(tlee)
Could you take a video and attach it on the bug?
Flags: needinfo?(tlee)
ok! I have found the video.  I think this is the same problem as Bug 1206418.
Component: Gaia::Homescreen → Graphics: Layers
Product: Firefox OS → Core
Milan, could you help on this?
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(milan)
Priority: -- → P1
See Also: → 1206418
Seems to be a layout related issue, and Thinker's already got a patch on bug 1206418, so let's see if that works.
Flags: needinfo?(milan)
Whiteboard: [2.5-Daily-Testing][Spark] [systemsfe] → [2.5-Daily-Testing][Spark] [systemsfe][gfx-noted]
Depends on: 1206418
This should now be fixed, qawanted to verify.
Keywords: qawanted
Looks like bug 1206418 has just landed today, so I used inbound builds to test this. Confirmed that this is fixed on latest mozilla inbound on Aries and Flame. Icon no longer flickers when moving them over another icon.

Device: Flame 2.5
BuildID: 20151001115026
Gaia: bd8ff00faac97ad6a2df5a6217910b8d295d56a3
Gecko: e5776222e1f15764a328d1d0a07ee16c7b662988
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Aries 2.5
BuildID: 20151001183534
Gaia: bd8ff00faac97ad6a2df5a6217910b8d295d56a3
Gecko: a473909f575931f67e836ae17dd739f480275e85
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Setting bug status as fixed.
Status: NEW → RESOLVED
Closed: 4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Resolution: --- → FIXED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
No longer blocks: 1097464
No longer depends on: 1206418
Resolution: FIXED → DUPLICATE
See Also: 1206418
Duplicate of bug: 1206418
You need to log in before you can comment on or make changes to this bug.