dom/events/test/test_bug946632.html frequently times out on Linux m-e10s with APZ enabled

RESOLVED FIXED in Firefox 44

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

(Blocks: 1 bug)

Trunk
mozilla44
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox44 fixed)

Details

Attachments

(1 attachment)

With APZ enabled this test frequently times out on tryserver. I can repro locally, investigating.
Created attachment 8663844 [details] [diff] [review]
Patch

This fixes it for me locally, but I'll do a try push to make sure it doesn't break anything else. The problem is basically that if a second call to waitForAllPaints arrives before the first one is completely dealt with, then one of them gets lost because the "onpaint" variable is clobbered.
Attachment #8663844 - Flags: review?(matt.woodrow)
Attachment #8663844 - Flags: review?(matt.woodrow) → review+

Updated

3 years ago
Blocks: 984139
tracking-e10s: --- → +
https://hg.mozilla.org/mozilla-central/rev/407ee28650b3
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox44: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
You need to log in before you can comment on or make changes to this bug.